Mac is stuck... Weird error

Discussion in 'macOS' started by samuelbarthelem, May 19, 2009.

  1. samuelbarthelem macrumors newbie

    Joined:
    May 19, 2009
    #1
    Ok, my mac was fine yesterday.

    I have an Imac 22" inch 2 gb of ram...

    I had shut it down, and I turned it back on. It came up but started running sluggishly. So It ended up freezing, so i held the power button down. Now it's stuck at the apple white screen with the little spinning thing. I have logged in via single user mode, and tried to run fsck -fy... It gets to checking catalog file... and sits... then an error comes up....

    Failed to issue COM RESET successfully after 3 attempts. Failing...
    then
    AppleAHCIDiskQueueManager::setPowerState(0x4079c00, 2 -> 1) timed out after 190049

    I don't know what to do. I just need to know if its the hard drive took a crap or something more serious... or if something simple... I don't have a retail cd but I am trying to find one...

    I have boot camp installed, and windows booted up once... Ran fine for a little then kinda froze... so i'm not sure... Is there something i can do if i can get the windows side running? Please help me out as I have no idea where to look up error codes...

    Thanks in advance,

    Samuel
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Mac OS X error codes via search "mac os x error code".

    Have you tried reseting the PRAM and SMC?

    If you find the install DVDs, try running Disk Utility and repair permissions and maybe even the disk.


    And there are only three iMac screen sizes (since they gone G5): 17", 20" & 24".
     
  3. samuelbarthelem thread starter macrumors newbie

    Joined:
    May 19, 2009
    #3
    Yes i have tried reseting the PRAM and the SMC... still no luck. As for the error code, I searched the apple support site and google and still could not find anyone or any documentary on that error code.

    and I meant to put 20 inch, I have no idea why i wrote 22
     
  4. Greenb macrumors newbie

    Joined:
    Jul 10, 2009
    #4
    Same Problem with 20" mac

    I have exactly the same problem. Did you ever find a solution or figure out what the problem is?
     
  5. elsea macrumors newbie

    Joined:
    Sep 7, 2009
    Location:
    Sydney, Australia
    #5
    Similar problem!

    iMac 20" Intel Core 2 Duo. 2 GB ram, 2.4 GHz (i think? can't remember and can't check cause, well, it's pretty much dead).

    Was stuck on grey start up screen, tried to verify disk using install dvd, failed with error "invalid sibling link". Attempted to run "fsck_hfs -r /dev/disk0s2" in single user mode but was met with "Failed to issue COM RESET successfully after 3 attempts. Failing..."

    Did you ever find a fix that didn't require an expensive trip to Apple store?
     
  6. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #6
    The AHCI setPowerState failure message I believe refers to the system attempting to spin-up/access the hard disk, but the HDD isn't responding for some reason. I think you all have dying hard disks. (Hey, as long as you have a backup, it's not nearly as bad as a dead logic board)
     
  7. olivier101 macrumors newbie

    Joined:
    Sep 28, 2009
    #7
    Same problem here.. I think the hard drive is dying.
    When I boot into single-user mode I can list my files, so I think that area of the disk is OK.
    The only option now is probably to take the Mac for repair :(
     

Share This Page