Resolved Mac keeps waking from sleep, its driving me nuts!

Discussion in 'Mac mini' started by Sir Ruben, Feb 25, 2013.

  1. Sir Ruben, Feb 25, 2013
    Last edited by a moderator: Mar 1, 2013

    Sir Ruben macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #1
    When I got my mac mini I really loved the sleep mode and decided that I was never going to turn my mac off. Fast forward to today and Ive had enough of it! My mac is in my bedroom and it just randomly wakes up all the time, very often in the middle of the night lighting up the room. I know when its come on without even opening my eyes as I can faintly hear the HDD activity.

    I get the feeling it has something to do with one of my attached devices. I have an external drive directly connected to the mac (for time machine backups) and I also have a network drive (which connected directly to my router).

    Here is a snippet of the wake reasons from terminal:

    Feb 23 18:26:11 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: EHC1
    Feb 23 18:43:33 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: EHC1
    Feb 23 21:34:15 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 23 23:22:40 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 24 01:11:04 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 24 02:59:28 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 24 04:47:52 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 24 11:28:14 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: EHC1
    Feb 24 13:19:57 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 24 14:28:13 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 24 15:36:04 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 24 16:43:30 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 24 17:50:32 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 24 18:14:00 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: EHC1
    Feb 24 20:02:25 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 24 21:37:02 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: EHC1
    Feb 24 22:02:51 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: ARPT (Network)
    Feb 24 23:53:45 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 25 00:23:02 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 25 02:11:27 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 25 03:59:51 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 25 05:48:16 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Feb 25 06:00:18 Craigs-Mac-Mini kernel[0] <Debug>: Wake reason: ARPT (Network)

    Can anyone with any experience of this offer any insight? I could Google it and read the web for days but you guys are pretty clued up on the mac mini and may have experienced the exact same thing.

    Cheers :D

    EDIT: Forgot to add, I have wifi sync enabled for my iPhone, do you think the phone may be querying the mac every now and again and waking it up?
     
  2. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #2
    You have wake on network activity turned on.
     
  3. Sir Ruben, Feb 25, 2013
    Last edited: Feb 25, 2013

    Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #3
    Yeah I do, but what could be waking it all the time?. I have disabled it now to see how it goes.

    However Im wondering what turning this off will effect? For example if my mac is sleeping and I want to access its music library from my iPad or iPhone, accessing the shared library option would wake the mac. Will unticking this option disable that feature?

    Also, I use logmein from my phone to access the mac. Logmein would show the mac was sleeping and I could wake it from the app. I presume I would lose that feature too?
     
  4. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #4
    How about turning it off?
     
  5. Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #5
    Turning the mac off? Well the whole point of using sleep mode is to avoid boot up times and reloading everything you use frequently. Turning it off means one of the features of my mac becomes redundant. Just like turning off wake for network access makes another feature redundant. Hardly the best solutions are they?

    Also when I turned off wake for network access I now get this:

    [​IMG]

    So that's another feature made redundant!

    Coming from Windows 7, I have to say that there are a lot of things that feel quite amateurish in Mountain Lion :(
     
  6. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #6
    Boot times on a 2012 Mini are tiny. Also, OS X's Resume feature loads all the apps and documents that you had open when you shutdown.

    Turning off an annoying electrical device in your bedroom while you sleep seemed to be the obvious solution.

    Waiting for 15 seconds in the morning is a small price to pay for no interruptions to your sleep.
    You can even turn it on and then go and brush your teeth, or "something", so you're not actually sitting waiting for it.
     
  7. Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #7
    Oh yeah don't get me wrong I completely appreciate what you are saying. However Im the kind of person that would rather fix a problem than work around it. Sleep should WORK, and I shouldn't have to disable something, which in turn disables other features, just to get it to do what its supposed to do. Thats crazy. If we simply disabled something or switched something off every time we had a problem we would be left with pretty featureless devices.

    What I want to do is find out what request is causing the mac to wake and work from there. Not disable valuable features or just turn it off.

    Mountain Lion is frustratingly poor at times. Like when you view the properties of a file, however viewing them again after the first time results in a lot of the properties having disappeared . Never to be seen again. Oh its just another amateur bug, just don't view the properties of a file right?
     
  8. takiv macrumors member

    Joined:
    Jan 5, 2013
    Location:
    Moonville, SC
    #8
    Wake reason: RTC (Alarm)
    After a quick search I found the Knowledge Base Article that describes exactly my problem: About Wake on Demand

    The reason for this odd behaviour is the Bonjour Sleep Proxy that is used to periodically advertise services of the machine to the network. While I had this turned off in 10.6, is was set to on automatically when I upgraded to 10.7. To shorten the article, the solution is to disable “Wake on Network Access” in the Energy Saving options
     
  9. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #9
    Compromise: Turn off the monitor? That way you won't be woken by light. ;-)

    Never seen that. Sounds like a Spotlight reindex might be in order.
     
  10. Omnius macrumors 6502a

    Joined:
    Jul 23, 2012
    #10
    honestly, I think most folks just turn off the monitor if they sleep in the same room as their machine.
     
  11. SVTmaniac macrumors 6502

    Joined:
    Jan 30, 2013
    #11
    My Mini wakes up all the time as well but it's in another room so it doesn't bother me much. I would hate it if it were in the bedroom as I have a Thunderbolt display that they forgot to put a power button on :rolleyes: so I wouldn't be able to just turn the display off.
     
  12. Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #12
    Thanks for the info.

    ----------

    I may be resorting to this lol

    It may be something that they fix in 10.8.3 or the next major release of Mac OSX
     
  13. adnbek macrumors 65816

    adnbek

    Joined:
    Oct 22, 2011
    Location:
    Montreal, Quebec
    #13
    AFAIK, time machine wouldn't wake the computer. Could be the other drive if it's related to Bonjour.

    Do you have any shares setup on it? (iTunes home sharing or what-not)
     
  14. Cubytus macrumors 65816

    Joined:
    Mar 2, 2007
    #14
    Couldn't it be the automated system designed to automatically check for updates even during sleep?
     
  15. adnbek macrumors 65816

    adnbek

    Joined:
    Oct 22, 2011
    Location:
    Montreal, Quebec
    #15
    Only on notebooks, not on the mini.
     
  16. Omnius macrumors 6502a

    Joined:
    Jul 23, 2012
    #16
    I'm not really sure that's a bug. It's more of a personal preference apparently. Your concern seems to be it wakes you when you sleep. Sleeping the monitors is generally for when you're back and forth using the machine during the day to save power and extend the life of components.

    I think the reason you're getting the response to just turn them off is that you're not awake or trying to sleep when this is an issue. While sleeping monitors are good, off monitors will save more power and extend component life even longer.

    I turn mine off before sleep. I don't consider that a compromise. I'm asleep, why would i care if it takes 4 seconds for the monitors to turn on when I wake up, as opposed to 2 seconds?
     
  17. Sir Ruben, Feb 26, 2013
    Last edited: Feb 26, 2013

    Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #17
    Really my main issue is that I just want it to work. In other words if I put the mac to sleep after use I dont want to walk into the room 4 hours later and find it back on again. What I really want to do is find out what triggers the RTC alarm and deal with that directly, whether it be an external drive, or some other connected device.

    I have been an internet technician for over 11 years (with almost no mac experience sadly) so I am a big fan of fixing the core issues rather than using workarounds which isnt really fixing anything. What seems to be common with Mac OSX use is that people tend to accept workarounds. As an example a Google search of my issue turned up forum replies such as "Hey! I finally solved my sleep issue! What you have to do is just untick 'wake for network access' amazing!" - that's not a fix at all. That's turning a useful feature off at the expense of other features which use that setting.

    Sadly from everything I have read there is no way to check how to identify the cause of the RTC alarm, and Mac forums don't go into very much depth with regards to issues in the same way as say a Windows or Linux forum would. I guess i always imagined Mac users to be quite techie, but it seems that if unticking a box or flipping a switch in the settings doesnt fix it, you quite often hit a brick wall :(
     
  18. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #18
    RTC is the computer waking itself up, not network activity.

    EHC1 is from peripherals attached to the Mac, probably USB.
     
  19. elolaugesen macrumors regular

    Joined:
    Aug 1, 2008
    #19
  20. Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #20
    But I have no scheduled events.

    ----------

    Going By Ben's post wouldnt it then be an ECH1 rather than an RTC?
     
  21. MacBoobsPro macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #21
    I agree its an issue that I would prefer to 'fix' than workaround but failing that you could always set your mac to start up just before you wake up and turn off just after you go to bed everyday.
     
  22. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #22
    I would not alter TM's interval. Firstly, you don't want to reduce the backup rate during the daytime. Secondly, IME, TM (and Spotlight) work well if you leave them alone, but not so much if you start tinkering with them.

    Check Energy Settings; check /Library/LaunchDaemons and LaunchAgents (and the user Library equivalent) for files that are scheduling tasks.

    You had both ECH1 and RTC in your Console log, according to your earlier post.

    For the sake of completeness: what other devices do you have on your Network?
     
  23. Omnius, Feb 26, 2013
    Last edited: Feb 26, 2013

    Omnius macrumors 6502a

    Joined:
    Jul 23, 2012
    #23
    At the moment. It's working as intended. Activity is waking the monitor from sleep.

    You want your computer to continue sleeping despite a specific activity type. That's different than wanting it to "just work."

    Insulting posters is not likely to get you much help. Admittedly, this thread is misplaced and better posted in the OSX forum. Unticking a box or flipping a switch would be an excellent indicator of whether specific features are functioning as intended or not.

    While I hate to be rude, as a "techie" you probably could have run a pretty standard test to whittle down the potential causes. But I'm not a techie. I just know that google exists and that generally its best to search first.0

    http://reviews.cnet.com/8301-13727_7-57333182-263/tackling-macs-that-randomly-wake-from-sleep/
    http://forums.macrumors.com/showthread.php?t=591555
    http://hints.macworld.com/article.php?story=20070729205103490
    http://forums.whirlpool.net.au/archive/983402

    A more exhaustive search also finds that this is a common issue for windows users who leave self-refreshing websites open. Fox News being a classic example of a site that used to wake computers from sleep.

    Of course, folks here turn off their monitors when they're leaving because that's just generally better to begin with. Sleep is for shorter periods of the monitor being off. If you're gone for several hours, it simply makes sense not to leave them on.
     
  24. Sir Ruben, Feb 26, 2013
    Last edited: Feb 26, 2013

    Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #24
    I think you have taken my comments the wrong way. I was in no way insulting anyone, far from it, I was just stating that unticking a box that turns off other features or turning off the monitor is not a fix, its a workaround.

    You are also right that it IS waking because of some sort of activity. I just want to know what that activity might be BEFORE going down the route of pulling my setup apart bit by bit until I eliminate the cause. I am quite capable of teching my setup but past experience has taught me to ask first, sometimes someone will post "oh I had that problem and this is how its fixed".

    However, with this particular issue, a google search shows that most people are happy to just untick an option that takes away other useful features with it.

    I have made a list of things to try so I'll run through a few things over the next couple of days and report back if I get any luck resolving it.
     
  25. Sir Ruben, Feb 26, 2013
    Last edited: Feb 26, 2013

    Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #25
    Just a quick update. Just had time to sit down and have another look at this and the ECH1's you are seeing in the logs are from me manually waking up the mac by hitting a key on my keyboard.

    So at least I know its only RTC's that I need to be looking at.
     

Share This Page