Mac Keyboard Hotkeys issue

Discussion in 'Windows, Linux & Others on the Mac' started by Deviatorz, Jul 18, 2010.

  1. Deviatorz macrumors newbie

    Joined:
    Dec 24, 2008
    #1
    I have an iMac with OSX (10.5.8) (dual core one). I have Vista Business installed with Bootcamp and everything is working well. When I first installed Vista, I was able to use the quick function keys (ie. F1/F2 controls brightness, F11/F12 controls volume) but now after a year it stopped working. I only get the standard function keys.

    In windows bootcamp control panel, I navigated to the Keyboard tab and there's only one option to "Use the F1-F12 keys to control software features". It was deselected. No matter what I do (select and apply or deselect and apply) the quick keys won't work. Heck I've even tried it with pressing down the "fn" key. Nothing gets those keys working. I've even tried reinstalling the keyboard software located on the CD that came with the iMac.

    Anyone have any suggestions on how I can get those keys working again?

    Edit: The keyboard came with the iMac. It's the ultra-thin aluminum keyboard. Also the IR remote isn't working too. I used to be able to control volume using that as well. The remote option in the Bootcamp control panel is NOT set to disable.
     
  2. Van W macrumors member

    Joined:
    Sep 5, 2009
    #2
    I'm not sure if this will work, but have you tried toggling your Mac function key settings in System Preferences?

    Go to the Keyboard section, select the Keyboard tag (as opposed to Keyboard Shortcuts), and click "Use all F1, F2, etc. keys as standard function keys". (This may look slightly different on 10.5.8-- I have 10.6.4.)

    on edit: Well, this will probably do nothing considering you are using Boot Camp, not a virtualizer...have you downloaded all the latest Windows updates?
     
  3. Deviatorz thread starter macrumors newbie

    Joined:
    Dec 24, 2008
    #3
    I actually think the problem was caused by Windows Update. Yes right now it's on the latest update. The keyboard used to work, now it doesn't.
     
  4. Deviatorz thread starter macrumors newbie

    Joined:
    Dec 24, 2008
    #4
    Any have a solution? It's still not working...
     
  5. duhduhdork macrumors newbie

    Joined:
    Dec 2, 2010
    #5
    same problem... but i think i only had it recently like a week ago. does anyone know how to solve it? or to take away the windows update then?
     
  6. huckduck macrumors newbie

    Joined:
    Mar 31, 2009
    #6
    have you updated your boot camp drivers recently?
     
  7. atr-drivr macrumors member

    Joined:
    Nov 23, 2010
    #7
    Via Mac or Windows?
     

Share This Page