Mac Mail can't send mail, only retrieves

Discussion in 'Mac Pro' started by veralynn, Nov 17, 2008.

  1. veralynn macrumors newbie

    Joined:
    Nov 17, 2008
    #1
    My Mac Mail 3.5 can retrieve the mail from my comcast account.
    It can't send mail
    I get a message stating The sender was rejected by the server smtp.comcast.net.

    I have changed my port settings from 110 to 587 and 25 and 4something as suggested by the comcast technician.

    Nothing works. I've never had this problem before.
    I have a G5 and OS 10.5.5:
    This is making me crazy!!!!! :eek:
     
  2. Big-TDI-Guy macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #2
  3. veralynn thread starter macrumors newbie

    Joined:
    Nov 17, 2008
  4. Big-TDI-Guy macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #4
    I had the same problem myself a while back. Glad to have been of assistance.
     
  5. PaperQueen macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #5
    These directions are fine if you’re using Mail 3.3, but what about those of us using Mail 3.5? Default ports 25, 465, and 587 are lumped together under one radio button option. If you manually set 587 as the custom port, you get an error message that two fields can’t use the same port number.

    Using Comcast’s SMTP while at home is fine as a bandaid, but what happens when I go on the road? Will I need to reset my outbound server for all the email boxes I use (21, since three companies are run from my laptop) so they can access my host company’s servers?
     
  6. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #6
    Yes you have to change it when you are off comcast network.

    Changing port to 587 works for me with my previous ISP (cox ->rhymes with socks) and outside their network.
     
  7. PaperQueen macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #7
    I’m sure it would work for me too...if I could bypass 25. With the three ports lumped together as a default, my guess is there’s a backdoor way to skip over it, but....need someone to tell me how to do that.

    Manually changing the SMTP server for all 21 mailboxes every time I’m on the road for work will be a royal pain in the patoot.

    If not for the fact I live by MailTags and paper trails, I’d move to webmail, but no go. Doesn’t fit my workflow.
     
  8. smoore1003 macrumors newbie

    Joined:
    Jan 30, 2009
    #8
    More help on sending mac mail please!

    I use comcast broadband and had gotten my mac mail to work by following advice found here on using port 587. However, I just moved and have new comcast account. Same broadband service, same mac, but no luck sending. I get error message that my email address is rejected by smtp.comcast.net. However, I can receive. Repeated calls to comcast haven't helped. Using Port 587 doesn't help. I've double checked settings and they're correct. Adding my user name after : to smtp.comcast.net doesn't help. Any other fixes? Desperate!
     
  9. MobiusStrip macrumors regular

    Joined:
    Dec 11, 2009
    #9
    They're still ignorant.

    Comcast is still pulling this. "Sender address (blahblah@whatever.com) rejected by server smtp.comcast.net"

    Their "support" is absolutely ignorant; they don't even understand that the incoming and outgoing servers have nothing to do with each other. They're claiming that it's because my reply-to address isn't the obscure, auto-assigned Comcast one.

    They even suggested that I try to authenticate to the Comcast server using the user ID and password from my personal E-mail account at my domain host. Incredible.
     

Share This Page