Mac mail displays wrong recipient in sent box

Discussion in 'Mac Basics and Help' started by neilwhitefox, Oct 6, 2009.

  1. neilwhitefox macrumors newbie

    Joined:
    Oct 6, 2009
    #1
    Suddenly having problems with sending emails via Mail for Mac. Some, but not all, messages show in the display window as having been sent to the wrong recipient.

    However, when you click on them, the details shown are correct and they seem to be getting through to the intended address. So it's a display issue of some sort rather than Mail actually sending to the wrong place.

    Can't find any reference to this issue in Mail Help or online forums.

    I'm running OSX 10.4.11, Mail 2.1.3.

    Many thanks.
     
  2. kiddax macrumors newbie

    Joined:
    Oct 19, 2006
    Location:
    San Antonio
    #2
    I am running Snow Leopard with the latest mail application.

    I noticed the same thing a couple of days ago when I was clearing out my mailboxes of unimportant mail. I came across an email in the sent box that showed the wrong recipient until I opened it. Nearly gave me a heart attack to think that it went to the wrong person until I was relieved to see it went to the right person.

    Didn't really try and troubleshoot it, my accounts are setup via IMAP. I wonder if it glitched when downloading the headers. But don't know.

    Whatever the issue is, it doesn't seem to be mail version specific as our setups are different.
     
  3. neilwhitefox thread starter macrumors newbie

    Joined:
    Oct 6, 2009
    #3
    Thanks for response - at last I'm not alone! Still experiencing the problem but strangely not with all sent emails. I repaired disc permissions, as I'd seen this suggested for various software problems, but no joy.

    So would still be grateful for further suggestions from anyone out there.
     

Share This Page