mac mail forgets quoted text colours

Discussion in 'Mac Apps and Mac App Store' started by PeterJP, Feb 7, 2019.

  1. PeterJP macrumors 6502

    PeterJP

    Joined:
    Feb 2, 2012
    Location:
    Leuven, Belgium
    #1
    I dislike the purple-blue-green colours that mac mail sets as standard for quoting mails. So I always set them to grey-grey-grey. It works fine when I do this.

    But when I close mac mail, it reverts to the standard purple-blue-green. I have to manually set it back to grey.

    Any way I can fix this? Thanks!
     
  2. niji Contributor

    niji

    Joined:
    Feb 9, 2003
    Location:
    tokyo
    #2
    hi

    i have not been able to figure out a way to get preferred colours to stick.
    as you have indicated, they always revert to the pre-set apple originally set colours.

    has this bug been introduced recently?

    the reason why it interests me is that i have filed with apple about some other bugs that were introduced with the macOS 10.14.3 update, specifically in macOS Mail.
     
  3. PeterJP thread starter macrumors 6502

    PeterJP

    Joined:
    Feb 2, 2012
    Location:
    Leuven, Belgium
    #3
    Thanks! Good to know others are experiencing the same.

    I have another problem in mac mail. I'm connecting to an Exchange server and the search function only works in the inbox. I always work with lots of folders to organise my mails. In outlook, I could make them under the inbox. Outlook find finds the mails nicely, in the inbox, folders, sent items, everywhere.

    Mac mail doesn't allow me to make subfolders of the inbox, so I had to create folders next to (on the same level as) the inbox. Outlook still finds mails in those folders. But mac mail doesn't find any mails, except those in the inbox itself. I tried moving a test folder back under the inbox, but mac mail still doesn't find mails in that folder.

    Anything I can do to force mac mail to index those folders or something like that?
     
  4. SDColorado Contributor

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #4
    Same for default font color for composing mail. AFAIK it will always resort back to black. Apple has decided what they want the defaults to be I guess.
     
  5. Pyrotechnic macrumors 6502

    Pyrotechnic

    Joined:
    Feb 28, 2009
    Location:
    United Kingdom
    #5
    I seem to have a different issue in that all my received emails are in bold italics. Even messages from the likes of PayPal are coming in to my inbox in italics. I suspect there are a few bug lurking in this latest update. My MacBook was fine, until I updated it. :(
     
  6. SDColorado, Feb 15, 2019
    Last edited: Feb 15, 2019

    SDColorado Contributor

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #6
    That is one I haven't seen before. Message Font still set under preferences to Helvetica 12?

    Oddly it seems if I change the quoted text colors from Purple-Blue-Green to Yellow-Orange-Magenta, which are on the same menu, the colors stick when I restart mail. But as soon as I choose anything off the "Other" color pallet it defaults back to Purple-Blue-Green

    Which is to say, I am still not sure how you fix it. But it seems to be related to any color off the main one.
     
  7. Pyrotechnic macrumors 6502

    Pyrotechnic

    Joined:
    Feb 28, 2009
    Location:
    United Kingdom
    #7
    It’s annoyed me so much I did a clean install last night. The text reverted back to how it should be. However during the updates of the OS the text within the emails changed again with no intervention from myself and nothing changed by me in any setting, so it’s got to be a bug within the update.

    It’s also showing all the correct settings in the fonts and colours with no reference anywhere to italics. :(
     
  8. SDColorado Contributor

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #8
    Wow. I can't imagine where that change in text is coming from if you have already done a full and clean install and all the mail font settings are the default. I am guessing you have no mail plugins either?
     
  9. Pyrotechnic macrumors 6502

    Pyrotechnic

    Joined:
    Feb 28, 2009
    Location:
    United Kingdom
    #9
    Nothing at all. I have a really standard set up which is what makes it worse. Its been fine for a good while, then all of a sudden I realised 90% of emails I was being sent were in italics, even PayPal emails. I thought I was missing something as I have never changed a single font and have always used the standard set up.

    As I say, installed Mojave as a fresh which I had on a USB Drive originally and obviously once installed wanted to add the past few months updates. Once it had done the updates, fonts had gone to italics and bold. Very puzzling.
     
  10. bbzzz macrumors newbie

    Joined:
    Mar 7, 2008
    #10
    > I dislike the purple-blue-green colours that mac mail sets as standard for quoting mails. So I always set them
    > to grey-grey-grey. It works fine when I do this.
    >
    > But when I close mac mail, it reverts to the standard purple-blue-green. I have to manually set it back to grey.

    I disable html rendering as such colouring makes it almost impossible to read (for me and many others)

    > Any way I can fix this? Thanks!

    You could quote email the traditional way then those that don't use html email (security/disability) will also see your message correctly. With html colouring, in the plain text version your reply is mixed in with the original message and it's all the same font and colour making it hard to see if you wrote anything at all.
     

Share This Page