Mac mail help please! Can't read messages in junk...

Discussion in 'Mac Apps and Mac App Store' started by triumphboy, Apr 11, 2011.

  1. triumphboy macrumors newbie

    Joined:
    Apr 11, 2011
    #1
    Hello all

    I don't know what I've done but my junk mailbox has turned form blue to white and although I can see there are messages in there using my smart mailbox, I can only see 'from' 'subject' 'date received' and that they are in the junk folder. However, if I highlight any of these emails the content of the message appears to be blank (even though I know they're not).

    I've attached two screen shots showing the white junk folder (which seems to indicate 4 unread messages, although I can't see anything in junk) and my 'Clever Car Buyer' smart mail box which shows the headline of the emails but none of the content.

    I'm confused, could someone please help?? Thanks a lot!

    Mark
     

    Attached Files:

  2. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #2
    What do you get when you click on the triangle next to the Junk folder?

    Also, there is another Junk folder above (seen in the first screen shot)- anything in there?
     
  3. triumphboy thread starter macrumors newbie

    Joined:
    Apr 11, 2011
    #3
    Hi there. Nothing else appears when clicking on the triangle.

    The other junk folder above is an old folder, so my junk up until Jan or so is in there. I must have created another junk folder by mistake at that point i guess.

    The thing is, although the now white folder is called junk, most of my mail ends up there, important ones too. I then use the smart folder to filter 'non junk'. I'm sure that's not the best way to go about it, but that's the postition I'm in so really want to get back those 'lost' emails if possible!

    Thanks for any advice you can give! :)
     
  4. triumphboy thread starter macrumors newbie

    Joined:
    Apr 11, 2011
    #4
    STOP PRESS!

    Have solved it - more by luck than judgement! The junk folder had lost it's mbox extention. Once that was fixed I rebulit the mailbox and everything came back. Phew. Thanks for your input anyway!

    :)
     

Share This Page