Mac Mail in Yosemite

Discussion in 'OS X Yosemite (10.10)' started by bmac89, Aug 3, 2014.

  1. bmac89 macrumors 6502a

    bmac89

    Joined:
    Aug 3, 2014
    #1
    Hello,

    I have installed the Yosemite Beta and generally like the look and feel of the operating system with the exception of a few minor irritations.

    I am coming from Snow Leopard and jumping straight into the Yosemite Beta.
    I understand Mac Mail in Yosemite is very similar to Mavericks.

    What irritates me with the mail app is that when reading or writing an email it doesn't open the message in a proper window but instead a small 'pop-over' window with no traffic light buttons (close, minimise or resize/fullscreen).

    Also you can customise the toolbar in the main mail window, however you can't do so in the email message window. I would like to add "Save to drafts" and other buttons to the message window.

    I have switched to "classic mode" and hoped this would bring back the above features but it doesn't. I hope Apple considers brining back a proper window for reading and writing emails - atleast in "classic mode".

    Your thoughts? Anyway around this? Can you install old Mac Mail (from SL) on Yosemite?

    Thanks
     
  2. bmac89 thread starter macrumors 6502a

    bmac89

    Joined:
    Aug 3, 2014
    #2
    I have just tried mac mail in yosemite again....

    I have discovered that the pop-over screen when reading and writing emails only occurs when running mail in fullscreen mode and a proper window is displayed when not in fullscreen mode (however only on classic mode).

    This is less of a irritation for me but I do hope they change this. In my opinion the pop-over screen is less flexible and reduces usability - making it far to much like a smart phone and not a computer.

    I also fear that the new Photos app may be a step backwards from Iphoto - catering more for the iphone users and not so much for amateur photographers. However I hope I am wrong! I also hope they support Raw photo files.
     
  3. oconnell84 macrumors newbie

    Joined:
    Aug 4, 2014
    #3
    If you don't mind me asking, what email client are you using now? As you mentioned just trying out Mail again.
     
  4. CaffeinatedNoms macrumors member

    CaffeinatedNoms

    Joined:
    Jun 8, 2014
    Location:
    Northeast England
    #4
    Yes, you can:
    [​IMG]

    That doesn't seem to be there. However, you can press File > Save, or Cmd+S, or even just close the window and it'll autosave to draft if you have that enabled, or ask you to confirm your save if you don't.
     
  5. fredcintra macrumors member

    Joined:
    Jun 10, 2011
    #5
    Try double click your e-mail instead of single-click it ;)
     
  6. bmac89 thread starter macrumors 6502a

    bmac89

    Joined:
    Aug 3, 2014
    #6
    Sorry for the confusion. I normally use Mac Mail on Snow Leopard, however I am trying out Yosemite on a separate partition.

    It only works when it is not in fullscreen mode. Fullscreen mode shows a pop-over window and not a real window regardless of whether you are in classic mode or normal mode.

    I did that. The problem is with fullscreen mode. Even in classic mode it shows a pop-over screen and not a real window when reading or writing an email. I'm not reffering to the mail preview.

    Thanks
     
  7. The19th, Aug 5, 2014
    Last edited: Aug 5, 2014

    The19th macrumors regular

    Joined:
    Jul 24, 2014
    Location:
    NorCal
    #7
    I just tried to create a new message in Mavericks Fullscreen Mail and the behavior is the same as you described. It appears this behavior and "discussion" about it has been going on since Lion (10.7 - The version succeeding Snow Leopard)

    https://discussions.apple.com/thread/3195461

    One suggestion mentioned there is to keep another Space populated with one Mail viewer window to refer to other messages while composing in an entirely new Space.

    I'm not going to discuss the merits/difficulties/reasons why it is, since the Apple Discussion thread seems to have beaten that horse to death.

    I would personally run a huge window for Mail rather than fullscreen.
     
  8. bmac89 thread starter macrumors 6502a

    bmac89

    Joined:
    Aug 3, 2014
    #8
    Thanks for the helpful reply. I had no idea that this has been the case since Lion!
    I was hoping that maybe Apple might change this but it seems it is here to stay for now. It seems so counterintuitive, but obviously they wanting to streamline it with iOS. I will stick with no fullscreen for mac mail.

    Thanks
     
  9. The19th macrumors regular

    Joined:
    Jul 24, 2014
    Location:
    NorCal
    #9
    Another suggestion would be to run a huge window and assign Mail to a specific Space.

    (Make a new Space/Desktop, Right click Mail on Dock, Options, Assign to This Desktop)
     
  10. chfilm macrumors 65816

    chfilm

    Joined:
    Nov 15, 2012
    Location:
    Germany
    #10
    It's a shame we need to use a workaround like this since years, but it helps indeed. Been having this problem for a while now and was too stupid to figure this simple trick out :D
     

Share This Page