Mac Mail keeps asking for my password.

mattluc

macrumors member
Original poster
Oct 28, 2008
35
0
York, PA
For one of my e-mail accounts, Mac Mail will randomly give me a popup asking for the password for one of them (it gives me the option to save the password in the keychain). I've opened keychain access before and removed all of the entries for that account, and then that popup might show up once and i'll save the password and then things are fine for a while. But i've done this a number of times and that popup still shows up whenever it wants to! I've also removed the passwords from Mail's account settings, saved, and then put the passwords back in (smtp and pop). Doesn't work.

Any ideas?
 

bananabar

macrumors regular
Sep 10, 2008
218
0
And is Keychain Access in Utilities which is in Applications?

I moved them once and my computer started doing all sorts of funny things - always asking for the password for Mail and my Wi-Fi.
 

dpcalhoun

macrumors member
Sep 8, 2008
39
0
Nashville, TN
this has happened to me before, not really sure why. i believe i deleted the account in mac mail and then opened it back up and it stopped.
 

Buttercookie

macrumors member
Jun 2, 2007
77
0
Happens to me from time to time. Usually when it's happening I also can't access my email online. I blame Comcast.
 

cyclingplatypus

macrumors 65816
Mar 15, 2007
1,079
213
Earth
Wouldn't happen to be a Yahoo email account would it? I get this pretty regularly from them and it is an annoyance but one that goes away on its own.
 

mattluc

macrumors member
Original poster
Oct 28, 2008
35
0
York, PA
I blame Comcast.
How did you know? Yeah, it's comcast.

Sometimes it's time-to-time. Sometimes it's obnoxiously constant. That's why i want to fix it. I think i've tried re-making the account before, but i'll try that again. If the problem recurs, i might send a scathing letter to Comcast.
 

Aea

macrumors 6502a
May 23, 2007
838
208
Denver, Colorado
I have to do this every single day, it's for a work email (POP3), driving me up a wall. I also have to reenter my password for some password protected web pages every time that I visit. I do click save, then I'm asked again, no the passwords don't change and the server never denies the saved details either, it just doesn't ask.

There is no "keychain access" in my applications folder, it's in Applications->Utilities
 

mattluc

macrumors member
Original poster
Oct 28, 2008
35
0
York, PA
Aea:

Applications -> Utilities is what we were (or at least meant to) refer to as the location for Keychain Access.

Regarding the web pages that you have to re-enter passwords for, there are some sites, particularly the more secure ones, that do not allow browsers to enter a saved password and sometimes not even a saved username. My college e-mail for example will sometimes let firefox enter my username, but never lets it enter the password. To my knowledge there's nothing we can do about this (possibly a third-party program or add-in can do this). Perhaps someone else knows more, though.


Everyone:

I'm wondering what causes this Mac Mail password issue...it seems that those with the problem have it with a POP account and that at least two of us have the problem with Comcast. So, does anyone have this problem with any other program, any other type of mail server (imap, exchange...), any other mail host (comcast, yahoo, gmail...), or with any other OS (i use the latest Tiger 10.4...)?
 

mysterytramp

macrumors 65816
Jul 17, 2008
1,334
3
Maryland
I have the same problem. I have Comcast and I'm running Tiger. It doesn't happen all the time, but often enough to be annoyiing.

mt
 

JediMeister

macrumors 68040
Oct 9, 2008
3,263
3
Comcast regularly changes their outgoing port number from 465 to 587 for security purposes. In OS X 10.4, Mail expects you to always have one port number and it always to be on that same port number. In OS X 10.5.5, the Mail application has been modified to always try the default ports of 25, 465, and 587 simultaneously so you'll rarely notice this issue.
 

illegallydead

macrumors 6502a
Oct 22, 2007
714
0
Colorado!!!
Comcast regularly changes their outgoing port number from 465 to 587 for security purposes. In OS X 10.4, Mail expects you to always have one port number and it always to be on that same port number. In OS X 10.5.5, the Mail application has been modified to always try the default ports of 25, 465, and 587 simultaneously so you'll rarely notice this issue.
Apparently that "rarely" isn't all too rare...

All this comes down to is that Comcast blows. I've never had a problem with any other account (IMAP or POP3) except for comcast. They are the Microsoft of ISP's, I tell ya what...
 

mattluc

macrumors member
Original poster
Oct 28, 2008
35
0
York, PA
I think JediMeister is right, this probably happens more rarely to those with Leopard than those with Tiger. That's also a very good answer about the ports, so thanks! That seems like something that would be easy enough to fix in Mail, and if Mac has figured it out for their Leopard version, shouldn't it be easy for that fix to be in a software update?
 

Aea

macrumors 6502a
May 23, 2007
838
208
Denver, Colorado
But what could be causing it for people not using comcast?

I have a GMAIL account, a POP3 account and two IMAP accounts, I have to enter THREE passwords everytime I open mail.app and THREE more passwords when I want to send from these accounts. This is ridiculous, why can't it do something so simple as remembering a password?
 

JediMeister

macrumors 68040
Oct 9, 2008
3,263
3
Aea: I'm not sure if you have Leopard or Tiger, but check these settings...If you access your Mail preferences, and then with the Accounts tab open, in the Account Information section, go down to where it says Outgoing Mail Server (SMTP). Click on the drop-down menu next to it and select 'Edit Server List..." See what kind of authentication each of the servers listed there have, if its set to None, Password, MD5, whatever it may be. If it says None, switch it to password and fill in the fields for the username and password. Click OK which takes you back to the Accounts/Account Information section. Now click on Advanced, which is to the right of Account Information and Mailbox Behaviors. Check there for what the authentication setting is, None, Password, or whatever it may be. Switch it to Password, and again fill in the information. Report back if it works or not.
 

Aea

macrumors 6502a
May 23, 2007
838
208
Denver, Colorado
Have leopard, all auth should be there, I'm even asked to provide a password to get my email even though I click "remember" every time, will try to redo all that manually and save and see if it works.

Edit: Nope, did all that, restart mail. Three password prompts in a row for different accounts. What a useless piece of crap.
 

Gray-Wolf

macrumors 68030
Apr 19, 2008
2,603
2
Pandora, Home Tree
Have leopard, all auth should be there, I'm even asked to provide a password to get my email even though I click "remember" every time, will try to redo all that manually and save and see if it works.

Edit: Nope, did all that, restart mail. Three password prompts in a row for different accounts. What a useless piece of crap.
I had this issue when I reinstalled Leopard. I accidently got it right though through keychain.
 

mattluc

macrumors member
Original poster
Oct 28, 2008
35
0
York, PA
You may try some stuff with the keychain. Go to Applications --> Utilities and open "Keychain Access". Sometimes there are numerous copies of one saved password, you could try removing the extras. You could try removing all (even if there's just one) of them, quitting keychain, and seeing what kind of success you get after the next time you enter a Mail password and tell it to save in keychain.

If not that, maybe there are some other things you can do in keychain that i don't know of...
 

robpaterson

macrumors newbie
Sep 5, 2004
5
0
Manhattan
Dealing with Email Account that Keeps Asking for Password

You may try some stuff with the keychain. Go to Applications --> Utilities and open "Keychain Access". Sometimes there are numerous copies of one saved password, you could try removing the extras. You could try removing all (even if there's just one) of them, quitting keychain, and seeing what kind of success you get after the next time you enter a Mail password and tell it to save in keychain.

If not that, maybe there are some other things you can do in keychain that i don't know of...
Something I just tried that seemed to work was removing an old certificate (for a GoDaddy account) that had expired back in May. That somehow seemed to clear up the issue I was having with one email account constantly asking for a password.
 

ld0yle

macrumors newbie
Dec 14, 2009
2
0
Mac Mail app keeps asking for passwords

I was having the same thing. The smtp not recognizing the password as I tried to send. But it was the Pop account that was at fault. After repeated attempts to Repair Keychain, re-enter information in Mail Preferences and Keychain I deleted the Pop account in Mail Preferences and did a new one. It took about 5 seconds as Mail found my old account's information and created a new one. Immediately, I received 5 messages. Then the smtp account cleared up and sent my message...
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.