Mac Mail keeps prompting for password

Discussion in 'Mac Basics and Help' started by stringtheorist, May 1, 2013.

  1. stringtheorist macrumors regular

    Joined:
    Apr 1, 2008
    #1
    Mac Mail keeps prompting for my password each time it tries to get mail. I can send and receive mail fine but I have to keep putting in my password. I have run this via Sky Support (my service provider) who took me through a password-reset but this did not help. Could something be wrong with my settings?
     
  2. jwjsr macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #2
    I had a similar issue yesterday with Mac mail retrieving from my gmail account and had to reset/change my password via google, they had to email me a code? Then I had to update my password on my iPhone and iPad which I did not want to do as liked my old password.
    Anyway I am now thinking something corrupted my gmail password in Mac mail on the mini somehow.
    I suspect i may could have solved it by repairing permissions or some other utility and not have had to change my password
     
  3. stringtheorist thread starter macrumors regular

    Joined:
    Apr 1, 2008
    #3
    Mine isn't a gmail account, it's just my Sky mail.
     
  4. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #4
    Mail's password prompt is a huge red herring when trying to figure out what's going on; it doesn't always mean there is a problem with your password. Mail tends to pop up the password prompt if it hits *any* error communicating with the mail server. I would suggest running the connection doctor and see if that flags any issues (Mail -> Window (menu) -> Connection Doctor).
     
  5. stringtheorist, May 1, 2013
    Last edited: May 1, 2013

    stringtheorist thread starter macrumors regular

    Joined:
    Apr 1, 2008
    #5
    Connection is fine according to this tool.
     
  6. rhett7660 macrumors G4

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #6
    I get this a lot with my outlook.com address. I have yet to figure out why. It will randomly pop up and request the password. Doesn't matter if I have been connected for 1 minute or 30 hours.

    I have not tried the tool mentioned here as that will be the next step. I am wondering if it is a connection issue though.

    Gmail accounts seem fine.
     
  7. Acorn macrumors 68020

    Acorn

    Joined:
    Jan 2, 2009
    Location:
    macrumors
    #7
    this happens with my yahoo account constantly. it seems as if your logged into the mail from somewhere else then it starts having issues. simply logging out on the other log in doesn't seem to fix it though. its extremely annoying because of the constant pop up log in window
     
  8. dspindl macrumors member

    Joined:
    Sep 30, 2011
    #8
    This just started happening to me last week. Out of the blue, up pops a box that says I need to put in my mail providers password. If I go to Mail preferences>accounts I see that my password is correct. All I've been able to figure out is to go to Mailboxes>take all accounts offline. Then put them back Online. That fixes it. Temporarily.
    However, if I put my Macbook Pro to sleep, or shut it down, then when I open it again...Mail does the same thing. Everything seems to be fine with my Yahoo mail account.....this appears to be a Mac Mail thing.
    VERY annoying.
     
  9. stringtheorist thread starter macrumors regular

    Joined:
    Apr 1, 2008
    #9
    You're not also a Sky subscriber are you?
     
  10. dspindl macrumors member

    Joined:
    Sep 30, 2011
    #10
    stringtheorist........no, sorry. I use Yahoo mail.
     
  11. stringtheorist thread starter macrumors regular

    Joined:
    Apr 1, 2008
    #11
    I've been advised that this problem could be down to a corrupt keychain. Does anyone know anything about this or how to troubleshoot it?
     
  12. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #12
    This could happen. Just open /Applications/Utilities/Keychain Access and delete the entries for the password for you email. Then startup the Mail and when it asks you for the username/password prompt, check to box to save the correct login. See if that helps.

    Plus those will a Yahoo account it seems like Yahoo is playing games with people. To test this go to Yahoo's site and change the email password to 8 character password and see if Mail connects just fine. A lot people have reported this working using Yahoo, even in the Microsoft area.
     
  13. stringtheorist thread starter macrumors regular

    Joined:
    Apr 1, 2008
    #13
    Looking through my keychain I can't see any password entry for the application Mail. Could this be the problem right here?
     

Share This Page