Mac Mail - Mail with attachments getting stuck

Discussion in 'Mac Apps and Mac App Store' started by DeeEss, Oct 16, 2013.

  1. DeeEss macrumors 6502a

    Joined:
    Jan 17, 2011
    #1
    Hi there,

    I have an issue that has arisen that is causing much grief!

    When I send an email with an attachment, it appears to send off as the progress bar completes, it then goes into my sent mailbox but the person never receives the email.

    it seems it's getting stuck before it leaves the computer. I've tested by sending an email to myself and they are definitely getting stuck somewhere.

    I've been in touch with my ISP and we have traced the problem back to Mac Mail. I've tried using Cache Out X and still the problem persists. I'm thinking a clean install may be needed. Any ideas that could be going wrong, it's really making me look bad with customers! :(

    Thanks in Advance, much appreciated!
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Please provide:

    Email Host (and type of account)
    ISP

    and have you tried sending through your email provider's web interface?
     
  3. Jedi Master macrumors regular

    Joined:
    Apr 5, 2013
    Location:
    ar the moment on the Death Star
    #3
    No, attachment


    What happens when you send without an attachment?

    Jed
     
  4. DeeEss thread starter macrumors 6502a

    Joined:
    Jan 17, 2011
    #4
    Hi,

    It's definitely client side as webmail works perfectly fine. I've heavily tested webmail and it works fine. The emails that go missing don't appear on the server log.

    I've been told by one client, that one email, without an attachment, didn't go through. I'm not so sure if that's true though as I have sent countless emails without attachments that have had no other problems reported and all my testing has worked in that regard.

    I'm just wondering if Mac Mail has a corrupted cache or something like that....

    In general I really find Mac Mail is quite buggy these days.
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    This sounds like a server-side issue. Most likely, you are running afoul of the security policies of the server. Whether the issue lies with the outgoing mail server or your recipient's incoming mail server is anyone's guess because you refuse to give any relevant information.
     
  6. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #6
    To test whether it's the server or not, I suggest you try at least one _other_ email app, such as:
    - Thunderbird, or
    - GyazMail

    It takes a moment to get a new app set up for your email, but once running, you can do some test sends with attachments.

    If Thunderbird can send the same content/attachment that Mail.app cannot, then it looks to be a problem with Mail.app, and not with the server.

    I've run into to some settings problems with Apple Mail.app, that I was able to diagnose using the method above. Thunderbird worked fine for me, when Mail.app would choke sending mail...
     
  7. coheteloco macrumors newbie

    Joined:
    Feb 12, 2009
    #7
    Is the size of your attachment the same when you've tested in webmail?

    Does the problem happen with all sizes of attachments?
     
  8. DeeEss thread starter macrumors 6502a

    Joined:
    Jan 17, 2011
    #8
    THanks all for your great suggestions, i'll look in to them now.

    It's never been a problem up till recently. I'm not doing anything differently just all of a sudden, I have issues! Very frustrating!

    Thanks again. If I work out what it is i'll report back.
     

Share This Page