Mac Mail sending from the wrong email address

Souli

macrumors member
Original poster
May 16, 2010
76
0
Hi,
I have a problem with the Apple Mail on my Macbook. I am using gmail as my main email provider but my "main" email address is a gmx.net address. I'm forwarding all my gmx mails to gmail where I organize all my stuff and have gmail setup to reply via the gmx address. This works fine as long as I use the browser to write my mails but when I use the mail app it is not working. The mail app is sending my mails via the normal gmail address instead of gmx.

Is there a way to set this up properly?
 

GGJstudios

macrumors Westmere
May 16, 2008
44,425
780
Hi,
I have a problem with the Apple Mail on my Macbook. I am using gmail as my main email provider but my "main" email address is a gmx.net address. I'm forwarding all my gmx mails to gmail where I organize all my stuff and have gmail setup to reply via the gmx address. This works fine as long as I use the browser to write my mails but when I use the mail app it is not working. The mail app is sending my mails via the normal gmail address instead of gmx.

Is there a way to set this up properly?
In the mail app you can specify which of your email accounts is the default account to be used for composing and sending new messages. However, that does not override the fact that when replying to an email, the reply defaults to the email account that was used to receive the message.
 

angelinanyc1

macrumors newbie
Jan 24, 2014
1
0
It's your "Outgoing Mail" settings

I was having this problem as well, and ran into a lot of frustration trying to find an answer that actually solved my problem and that I could understand. I have three accounts connected to my apple mail app. Then I finally figured it out, and since then, it has worked correctly. Here's what you do:

In Mail, go to your Preferences. Click on one of your accounts on the left side. Where it says "Outgoing Mail Server (SMTP)" Click the dropdown menu and choose "Edit smtp Server List". When you get there, delete any and all smtp servers that you have saved. Click the + to add a new one. You'll add one server for each account you're using.

In "Account Information":
Description: anything you want. something that tells you which account you're using it for.
Server: usually smtp.gmail.com (slightly different if your account is not gmail)
TLS Certificate: None

Then go to "Advanced":
At "authentication", click "password"
Enter the username and password of the account you want for this outgoing server.

Repeat this for as many accounts as you have. Then go back to your main page with the accounts. On each account, go to the Outgoing Mail Server dropdown list and choose the server that you have created for that specific account.

Complicated, but this solved it for me. I hope it works for you!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.