Mac Mail Shortcut

Discussion in 'OS X El Capitan (10.11)' started by russ2204, Feb 1, 2016.

  1. russ2204 macrumors newbie

    russ2204

    Joined:
    Feb 1, 2016
    #1
    How do I setup a shortcut to create a new mail using a specified account ? I have 4 accounts and would like a shortcut to save me having to select the account from the dropdown box. A keyboard shortcut to create new mail using a specified account would be amazing. I am using El Capitan.
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    One way to do this would be a custom “service” created with Automator. This application can be found in your Applications folder. Just create a new service with it (the cog icon), specify in the upper right corner that it is for Mail only and takes no input, then drag the mail action “New Mail Message” from the actions sidebar to the main field. Change the “from” field to your email address and save the service, e.g. “New Message (xyz@mail.com)”. There will now be an option in the Mail application under Mail > Services. Now you only need to assign a shortcut to it. In System Preferences > Keyboard > Shortcuts, look for your service and assign a shortcut. That’s it.
     
  3. russ2204 thread starter macrumors newbie

    russ2204

    Joined:
    Feb 1, 2016
    #3
    --- Post Merged, Feb 1, 2016 ---
    Thanks - I have followed this but nothing is showing up in Services or in the Keyboard Shortcuts. Do I need to save to a specific location ? Also, when creating the email will it apply the correct signature automatically as it does when I do it manually ?
     
  4. KALLT, Feb 1, 2016
    Last edited: Feb 1, 2016

    KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #5
    When you use the normal Save command, it will ask you for a name and create a file in ~/Library/Services (just paste this path into Finder > Go > Go to Folder...). Normally it should appear automatically, but maybe you have to reopen Mail.

    Edit: It's a bit weird here as well, not sure why. I suppose that your system needs to index it and add it to the Services daemon. Make sure that you close System Preferences and Mail before you add it. In any case, logging out/in should definitely make it appear.

    As for the signature, I haven't tested this. I suspect that this should work if the signature is assigned to that account. However, you can just add a signature manually in the service as well.

    That's also a neat idea, although it requires to consequent shortcuts of course.
     
  5. russ2204 thread starter macrumors newbie

    russ2204

    Joined:
    Feb 1, 2016
    #6
    Hi

    I have now copied to the correct folder. I have setup a shortcut in shortcuts. But it does not appear in Mail under Services nor does the shortcut work. I have tried restarting Mail but it made no difference.
     
  6. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #7
    But the service does appear under Shortcuts? Just not in Mail?
     
  7. russ2204 thread starter macrumors newbie

    russ2204

    Joined:
    Feb 1, 2016
    #8
    No - it does not appear. Only in the Keyboard Shortcuts. It is enabled but does not show up anywhere.
     
  8. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #9
    Are you sure you set the parameters right? Service receives "no input" in "Mail". Screen Shot 2016-02-02 at 18.50.27.png
     
  9. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #10
    The keyboard shortcut "Menu Title" has to be the same as it is in the dropdown selector in a new message...and the tricky part is that the dash is an "option-dash".

    Said out loud it would be: firstname space lastname space option-dash space emailaddress
     
  10. russ2204 thread starter macrumors newbie

    russ2204

    Joined:
    Feb 1, 2016

Share This Page