Mac Mail synching with Gmail - problems!!!

les24preludes

macrumors member
Original poster
Feb 6, 2011
96
4
Hi - need help here. I was cleaning out files on a previous Mac Mini (to give to a friend) ready to fire up my new Mac Mini. I deleted the messages on the old Mini under Applications>Mail and sent them to trash. I didn't realise these synched with my Gmail messages. Now on my new Mini when I open gmail, all the messages are still there but have "deleted messages" written in green against them. I want to restore these, and I certainly don't want to find they just go after a specific delay. It's pretty important to keep all these Gmail messages - what can I do? Help appreciated!

Andy
 

Darth.Titan

macrumors 68030
Oct 31, 2007
2,719
328
Austin, TX
You just need to put the deleted messages back in your Inbox. If you're using Mail, it should be drag and drop.

You could also do this using Gmail's webmail.
 

DeepIn2U

macrumors 603
May 30, 2002
6,263
1,745
Toronto, Ontario, Canada
Hi - need help here. I was cleaning out files on a previous Mac Mini (to give to a friend) ready to fire up my new Mac Mini. I deleted the messages on the old Mini under Applications>Mail and sent them to trash. I didn't realise these synched with my Gmail messages. Now on my new Mini when I open gmail, all the messages are still there but have "deleted messages" written in green against them. I want to restore these, and I certainly don't want to find they just go after a specific delay. It's pretty important to keep all these Gmail messages - what can I do? Help appreciated!

Andy
Simply move them to the Inbox - or Label them as "Inbox" then move them there. BY default its 5 days to permanently delete.

PS: Immediately go into Mail Preferences for that account and disable the permanent delete after x days function. Also log onto gmail account that is affected and simply you can move back to inbox there.

Sync again in Mail and then begin to sort.
 

les24preludes

macrumors member
Original poster
Feb 6, 2011
96
4
Hello guys - thanks for responding.

I can't return the messages to Inbox because they're already in the Inbox. the problem is they are flagged with this green sign "deleted messages". Now first off, I don't know what this message means - tried to google it but no luck

Second - the problem is I don't want these messages to suddenly disappear. So yes, I tried to go into "Preferences" but I can't see any Preferences in gmail. All I can see is the cog wheel on the top right, and clicking that brings up a menu, but I can't find anything in this menu that disables the delete message delay. Help!!