mac mail won't connect to server

jjuhlin

macrumors newbie
Original poster
May 29, 2017
4
0
mac mail suddenly stopped connecting to server.

macOS 10.13.6 mail 11.5

I have checked all settings (none of which were changed) with my service provider and everything is ok. They say that I'm not the only mac user to report this kind of problem. I can connect with android phone and PC. I can connect with safari through my provider's webmail app. My wife's iphoneX had the same issue but seems to have resolved itself today with no interference on our part.

Everything points to the problem being a macmail or macOS thing.

I have no updates pending. It does not appear that the problem (started at some point after 10:42 on 3-1) coincides with any recent mac updates that were downloaded to my MacBook.

I've run out of things to try. Any suggestions.
 

BrianBaughn

macrumors 603
Feb 13, 2011
6,362
937
Baltimore, Maryland
The only thing you said that you tried was checking all your settings.

Do you get error messages?

Perhaps it's a problem in your Keychain.

Wait to see what others say first...but if no one comes up with a better idea you could try eliminating all traces of the account on your Mac and then re-adding it. First, get rid of all your SMTP Server List items. Then delete the account from Mail. Next, remove all Keychain items pertaining to the account.
 

techwarrior

macrumors 65816
Jul 30, 2009
1,113
398
Colorado
At one time, I had issues running both Ethernet and WiFi. Once I changed service order, mail starting working again. I recall I disabled Ethernet or WiFi until it worked, the set the order so the one that worked went first. Or, you could just disable one of the interfaces.
 

niji

Contributor
Feb 9, 2003
1,493
1,213
tokyo
mac mail suddenly stopped connecting to server.

macOS 10.13.6 mail 11.5

I have checked all settings (none of which were changed) with mby service provider and everything is ok. They say that I'm not the only mac user to report this kind of problem. I can connect with android phone and PC. I can connect with safari through my provider's webmail app. My wife's iphoneX had the same issue but seems to have resolved itself today with no interference on our part.

Everything points to the problem being a macmail or macOS thing.

I have no updates pending. It does not appear that the problem (started at some point after 10:42 on 3-1) coincides with any recent mac updates that were downloaded to my MacBook.

I've run out of things to try. Any suggestions.
i know you have said that nothing has been changed that would have caused you to not be able to connect.
but, obviously, something has changed, somewhere, somehow.

when i have had problems with macOS Mail not being able to connect to my various email accounts' servers, the problems have been, in order of successfully concentrating effort to fix it:
1 recheck password to be correct
2 recheck incoming port number
3 change the incoming port number to an allowed alternative (many times you are given 2 possibilities for incoming port servers)
4 SSL needed or not?
5 password method correct? (strangely, mac Mail often defaults to the wrong one)

after you have thoroughly played around with the above, then i have found that the advice given above by a different user to throughly and completely nuke the entire mail setting, deleting it, and then creating it again, is indeed the best advice.

the above is especially true if its a Certificate problem. when you set up a new mail setting, if there is a Certificate problem, it gives you one and only one time to actually fix it (when you get an error message saying that the server is not trusted, a screen appears and you can ask for Details, then tell it to Trust it). but you never get that screen again in the way that allows you to fix the problem if you dont fix the problem at that first time it appears.

also: oddly, i dont know the reason, certain ISP can in fact want your iOS Mail settings and your macOS Mail connections to be different.
 
Last edited:

drainsbe

macrumors newbie
Mar 6, 2019
1
0
Had the same issue manifest about the same time w/my yahoo account in macOS Mail, other two accounts continue to work just fine. WebUI for Yahoo works perfectly. Have not been able to find a resolution... have gone back and forth from wifi to wired, wired to wifi.. on wire currently. have deleted, and re-added account. macOS Mail only provides a radio button to choose mail provider... tried circumventing by choosing other, but once you provide the yahoo credentials its as if you chose the yahoo button. the settings it uses for the connection are a mystery.. they have to be somewhere but I cant find them. Currently logging connection messages... from what I've seen so far it appears that connections to the yahoo server establish, but no read/write seems to take place...

INITIATING CONNECTION Mar 06 07:44:05.566 host:imap.gmail.com -- port:993 -- socket:0x0 -- thread:0x600000208700

INITIATING CONNECTION Mar 06 07:44:05.566 host:imap.1and1.com -- port:993 -- socket:0x0 -- thread:0x600000027f40

INITIATING CONNECTION Mar 06 07:44:05.566 host:imap.mail.yahoo.com -- port:0 -- socket:0x0 -- thread:0x6000001e7580

INITIATING CONNECTION Mar 06 07:44:05.566 host:smtp.gmail.com -- port:465 -- socket:0x0 -- thread:0x600000006140

CONNECTED Mar 06 07:44:05.569 [kCFStreamSocketSecurityLevelNone] -- host:imap.mail.yahoo.com -- port:143 -- socket:0x600003e9c060 -- thread:0x6000001e7580

WROTE Mar 06 07:44:11.681 [kCFStreamSocketSecurityLevelTLSv1_2] -- host:imap.1and1.com -- port:993 -- socket:0x600003ef1260 -- thread:0x600000218780
DONE

WROTE Mar 06 07:44:11.682 [kCFStreamSocketSecurityLevelTLSv1_2] -- host:imap.gmail.com -- port:993 -- socket:0x600003edf8a0 -- thread:0x600000119740
DONE

macOS 10.14.3 (18D109)
MacMail Version 12.2 (3445.102.3)



i know you have said that nothing has been changed that would have caused you to not be able to connect.
but, obviously, something has changed, somewhere, somehow.

when i have had problems with macOS Mail not being able to connect to my various email accounts' servers, the problems have been, in order of successfully concentrating effort to fix it:
1 recheck password to be correct
2 recheck incoming port number
3 change the incoming port number to an allowed alternative (many times you are given 2 possibilities for incoming port servers)
4 SSL needed or not?
5 password method correct? (strangely, mac Mail often defaults to the wrong one)

after you have thoroughly played around with the above, then i have found that the advice given above by a different user to throughly and completely nuke the entire mail setting, deleting it, and then creating it again, is indeed the best advice.

the above is especially true if its a Certificate problem. when you set up a new mail setting, if there is a Certificate problem, it gives you one and only one time to actually fix it (when you get an error message saying that the server is not trusted, a screen appears and you can ask for Details, then tell it to Trust it). but you never get that screen again in the way that allows you to fix the problem if you dont fix the problem at that first time it appears.

also: oddly, i dont know the reason, certain ISP can in fact want your iOS Mail settings and your macOS Mail connections to be different.
mac mail suddenly stopped connecting to server.

macOS 10.13.6 mail 11.5

I have checked all settings (none of which were changed) with my service provider and everything is ok. They say that I'm not the only mac user to report this kind of problem. I can connect with android phone and PC. I can connect with safari through my provider's webmail app. My wife's iphoneX had the same issue but seems to have resolved itself today with no interference on our part.

Everything points to the problem being a macmail or macOS thing.

I have no updates pending. It does not appear that the problem (started at some point after 10:42 on 3-1) coincides with any recent mac updates that were downloaded to my MacBook.

I've run out of things to try. Any suggestions.