mac mail won't send. going cuuhraaazy!

Discussion in 'MacBook Pro' started by merkthewhale, Jul 29, 2011.

  1. merkthewhale macrumors newbie

    Joined:
    Jul 29, 2011
    #1
    hi all,
    just got the new macbook pro a couple months ago and havent had one problem, until today i went to starbucks and suddenly couldnt send message on apple mail. (the stamp with the eagle on the bottom)

    ive tried all the port chages (25,587..although my home has always been 993)

    im back home and still cant send any messages. although i am receiving.

    whats up!?:confused:
     
  2. fullojellybeans macrumors regular

    Joined:
    Mar 31, 2010
    #2
    Who's your mail provider? That's a big thing sometimes with apple mail. If it's pop it may have lost connection with the server and sometimes re-adding the email account can fix it. Downside is you may lose all the emails stored on the server.
     
  3. barebackbadger8 macrumors 6502

    barebackbadger8

    Joined:
    Mar 23, 2009
    Location:
    Wolverhampton, UK
    #3
    what smtp/outgoing server are you using?
    if you are using the smtp of your home broadband, then it wont send.
     
  4. merkthewhale thread starter macrumors newbie

    Joined:
    Jul 29, 2011
  5. merkthewhale thread starter macrumors newbie

    Joined:
    Jul 29, 2011
    #5

    i cant afford to lose these emails. they go back 3 years..
     
  6. barebackbadger8 macrumors 6502

    barebackbadger8

    Joined:
    Mar 23, 2009
    Location:
    Wolverhampton, UK
    #6
    i had the same problem,are you using pop or imap?

    smtp.gmail.com
    port 465
    use ssl
    and server needs authentication, same as incoming (username & password)

    it was hit and miss for me aswell so i ended up buying sparrow mail not had 1 problem since
     
  7. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #7
    First of all, if it was working before, you should not have changed your SMTP settings. It's entirely possible that the reason it doesn't work now that you're home is because you broke your outgoing mail settings.

    Next, some ISPs block access to all SMTP servers except their own, and you might have found yourself on one of those networks.

    With GMail, unless you explicitly deleted the messages, they're all still on Google's servers, so you can delete the account from Apple Mail and reconfigure it without losing anything. You absolutely will not lose anything if you don't delete the account (you could just completely disable it).

    Lastly, you may also have tried to send a message that is too big and hung up the IMAP account. Check the ~/Library/Mail/*your IMAP account*/.OfflineCache folder.
     
  8. merkthewhale thread starter macrumors newbie

    Joined:
    Jul 29, 2011
    #8
    i keep getting the "!" next to my inbox which says

    There may be a problem with the mail server or network. Verify the settings for account “Gmail” or try again.

    The server returned the error: The connection to the server “imap.gmail.com” on port 25 timed out.
     
  9. Bungan macrumors newbie

    Joined:
    Oct 5, 2011
    #9
    Mail not sending

    Hi there
    I recently had the same problem re: mail not sending but receiving when I was logged onto other wireless networks.
    I called my ISP, then Apple Care and they went through ALL possible settings and no luck. Reloaded all mail settings - no luck. Also tried all the changes recommended in theses threads (eg outgoing mail settings, changing port numbers etc) and no luck. Then followed recommendations to do complete reboot of Lion - no luck.
    I kept playing on my own and found a solution which has worked so far without fail.
    My ISP (Optus in Australia) and Apple recommended that with the Outgoing mail server settings that I DON"T use the password option.
    That was the last untested variable - so I simply changed the outgoing mail server preferences to "password" - entered my ISP username and password - and bingo - all fixed.
    Hope this helps as I tore my hair out for several days while on the road for business....
     
  10. steevg macrumors member

    Joined:
    Aug 5, 2008
    #10
    Bungan,

    Sorry, but I'm not sure what you're advising here:

    . . . . and then you say:-

    . . . . so did you use the password option or not?
     
  11. torid110 macrumors regular

    Joined:
    Jan 22, 2006
    Location:
    Jersey City, NJ
    #11
    The solution is in your error message. The SMTP server should be smtp.gmail.com

    Here are the instructions from google on how to setup apple mail:

    http://mail.google.com/support/bin/answer.py?answer=81379
     
  12. steevg, Nov 9, 2011
    Last edited: Nov 9, 2011

    steevg macrumors member

    Joined:
    Aug 5, 2008
    #12
    torid110,

    Still not working.

    I've been through the gmail settings and my ISP's setting a dozen times, and also have removed and re-installed my email accounts (gmail and ISP email), and still they're intermittent at best.

    Sometimes they work, other times they hang for a while, and other times (like today) any outgoing email just accumulates.

    I've also checked the Connection Doctor, and this also shows the server's I'm using are online (green gumdrop/indicator)

    I've tried logging out, logging in, rebooting etc etc.
    I'd really like to know what the problems is here, it's been happening for months.

    The real bug-bear, is that I also have a MacBook Pro (fairly new) and have the same OS (10.6.8), and "it" runs fine one the same network with the same settings - why?

    Curious & frustrated.
     
  13. torid110 macrumors regular

    Joined:
    Jan 22, 2006
    Location:
    Jersey City, NJ
    #13
    Bring up terminal and do :

    telnet smtp.gmail.com 25


    Does anything come up ?
     
  14. steevg macrumors member

    Joined:
    Aug 5, 2008
    #14
    torid110

    Thanks for trying to help.

    Terminal results are:-

    telnet smtp.gmail.com 25
    Trying 209.85.227.108...
    Connected to smtp.gmail.com.
    Escape character is '^]'.
    220 mx.google.com ESMTP i8sm3725505wie.11
     
  15. torid110 macrumors regular

    Joined:
    Jan 22, 2006
    Location:
    Jersey City, NJ
    #15
    So it looks like you can connect to it, meaning there doesn't seem to be a network problem. hmmmm ...
     
  16. steevg macrumors member

    Joined:
    Aug 5, 2008
    #16
    I've just tried adding in the gmail DNS Servers . . . . jst in case:

    216.239.32.10
    216.239.34.10
    216.239.36.10
    216.239.38.10

    . . . . but still no-go.
    I may try reloading the email accounts again later today.
    Thanks for trying, I'll keep an eye on this forum, just in case you may think of anything else.

    Thanks.
     
  17. torid110 macrumors regular

    Joined:
    Jan 22, 2006
    Location:
    Jersey City, NJ
    #17
    yeah, doesn't look like a dns issue, since you can resolve the name per the telnet that you did. This is a tough one :)
     
  18. steevg macrumors member

    Joined:
    Aug 5, 2008
    #18
    torid110,

    OK, just spent the best part of 30 minutes on the phone to Xtra here in New Zealand, and still haven't really solved the problem.

    However, things to note for any other NZ'ers are:

    In order to send mail through the send.xtra.co.nz server, you have to go to your account online via www.xtramail.co.nz, choose the "Options/mail options" tab somewhere on the page (this depends on which version web mail you may see), next choose "Mail accounts" and from here you'll need to add your gmail (etc) addresses to this account.

    Note: When you start to add your accounts, it'll ask for a username and password - there's an option to "skip" - choose this option as you don't need to input this info to simply add your other accounts.

    If you don't want to go through all this hassle, it was suggested that the "smtp.xtra.co.nz" server may still be used, but this could be open to getting spam though and into your account.

    At this time I'm using the smtp option, simply to get my mail.

    Seems to be working at present, but will still investigate the send.xtra.co.nz server over the weekend as I prefer the non-spam option.

    Apologies for hijacking the post, but I do feel that it was relevant to the original question.

    Issue is still not resolved, but hopefully we're on the way to getting there.
    No idea' why it should work on the MBP and not the iMac, . . . but that may have to wait for another day!

    Thanks.
     
  19. gtd10 macrumors newbie

    Joined:
    Nov 22, 2011
    #19
    E-mail stopped sending (smtp error) with Mac Mail (OSX10.4)

    My Mail program stopped sending emails, but was still able to receive messages.

    I tries deleting Mail cache settings, restarting mail, and it magically started sending again.
    To do this, in finder click Home>>Library>>Caches>>Mail
    Delete all folders therein.

    Hope someone finds this useful too
     
  20. Sgkranz, May 9, 2012
    Last edited: Jun 2, 2012

    Sgkranz macrumors newbie

    Joined:
    May 8, 2012
    #20
    Mail won't send

    Well the same problem has reoccured and I'm back to square one again.
     

Share This Page