Mac Mail won't send

Discussion in 'Mac Apps and Mac App Store' started by dlaxague, Feb 17, 2015.

  1. dlaxague macrumors newbie

    Joined:
    Aug 29, 2013
    #1
    Hello. I have an older macbook pro using Yosemite and mac mail. Out of the blue yesterday, mail stopped sending my emails. They just sit in the outbox, no error message appears, nothing happens if I select and direct it to send them. I have 3 different email accounts (icloud, earthlink, and gmail) set up and it won't send any of them. No problem receiving mail. Nothing has changed, same internet connection, same computer, etc.

    I am able to send (using the same server) from my iphone.

    I have looked around, and see suggestions to delete and re-add my account, but when I go to do that I'm warned that all (existing) messages will be lost, which is not a workable solution for me. Plus, if it's all 3 of my accounts misbehaving, it does not seem like that's the problem.

    So, is it something with my server, or something within macmail? I'm not very computer literate so keep suggestions simple, please. And thanks for helping!

    Debbie L.
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hello,

    do you use the same outgoing server for the three mail accounts (smtp....) ?
     
  3. simonsayz macrumors newbie

    simonsayz

    Joined:
    Aug 12, 2013
    Location:
    NY
    #3
    Vpn

    Are you using a VPN program that is enabled?
     
  4. dlaxague thread starter macrumors newbie

    Joined:
    Aug 29, 2013
    #4
    No, different outgoing settings for each account (which has worked fine for years). I think ( smtp etc. setting ends differently for each).

    I warned you (I'm pretty clueless). I don't know what a VPN is, nor if I am using it, whether or not it's enabled.

    Debbie L.
     
  5. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #5
    Since it is affecting the 3 mail accounts using different outgoing server settings at the same time, it might be a problem with Keychains.

    Keychains holds all your mail ingoing and outgoing servers passwords.

    Go to Applications / Utilities / Keychains, launch it.

    From the menu bar: Keychains / S.O.S Keychains.
    Select "Verify", Start.
    If needed, "Repair", Start.

    Then reboot, and test Mail.
     
  6. dlaxague thread starter macrumors newbie

    Joined:
    Aug 29, 2013
    #6
    Thank you everyone for trying to help. I think I need to call AT&T (internet provider).

    Bruno, I followed your instructions (it was called "First Aid rather than SOS) and verify did bring up some red issues for earthlink only, and repair did repair them. But still no luck sending mail (and it is not only earthlink that isn't sending).

    I had already tried turning off computer and router/AT&T U-verse and restarting, without success, but did it one more time in desperation. When it came back on and I restarted the computer, ONE message (from my icloud address) of the 5 sitting in my outbox sent (a test to myself). But the others, including others from the icloud email account, did not. Does that make ANY sense?

    Thanks again,
    Debbie L.
     
  7. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #7
    Not exactly...

    When you go to Mail / Preferences / Accounts, do the outgoing servers (smtp....) appear to be "not connected" ?

    Please pardon me if I am not using the right words, my system is not in English (hence the First Aid / S.O.S in Keychains).
     
  8. dlaxague thread starter macrumors newbie

    Joined:
    Aug 29, 2013
    #8
    Bruno, everything looks OK to me in the accounts settings. The accounts are enabled and the outgoing server is shown. In one case (earthlink, I think), there is also the option to "use only this outgoing server", and that is clicked.

    I just spent nearly an hour on the phone to AT&T U-verse, who said it's not their problem, it's something with macmail, although the tech has a mac himself so he had me try a few things (that didn't work, either).

    I'm going to delete my gmail address (the one I use the least and can afford to lose emails) and re-add.

    Thanks again.
    Debbie
     
  9. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #9
    If your are using IMAP accounts, you won't lose anything : what you see on your Mac is what is on the server.
     
  10. dlaxague thread starter macrumors newbie

    Joined:
    Aug 29, 2013
    #10
    Deleting and re-adding the gmail account made no difference.

    I think mac mail is broken (but don't hesitate to tell me if you think I'm wrong). Does anyone have an opinion on the two options I'm considering:

    1. Give up on mac mail and see if Outlook (which I think I already have if I didn't delete it) works.

    2. Drive 2+ hours to a mac repair person (not an Apple store, that's 7-8 hours) and pay for them to fix it.

    Outside option #3 - This computer is almost 4 years old -- worth keeping, right?

    Debbie L.
     
  11. dlaxague thread starter macrumors newbie

    Joined:
    Aug 29, 2013
    #11
    Oh my goodness. I have spent hours today on this. Restarting computer, talking to AT&T and you all, trying all the various fixes suggested, fussing and fiddling in general, etc.

    Just now, after at least the 10th restart (or maybe just coincidentally) mail is sending with no problem.

    I am remembering that in the past, I have occasionally had this problem at certain hotels. While there, the outgoing messages would just sit in the outbox (and I wouldn't have any time to troubleshoot, because I'm usually at conferences when I travel). But when I'd get to the airport, they would all send. Which makes me think maybe it WAS something to do with AT&T U-verse service afterall?

    Thanks again, fingers crossed . . .
    Debbie L.
     
  12. Pharmscott macrumors 6502a

    Pharmscott

    Joined:
    Dec 13, 2011
    Location:
    Sacramento, CA
    #12
    One tip to check your settings easily is to click on the Window menu, then click Connection Doctor. It will test all of your email accounts and let you know if they are not set up properly. Give it a try (even though it's working now).
     
  13. Wek macrumors member

    Wek

    Joined:
    Dec 5, 2014
    Location:
    Denmark
    #13
    I have this problem on and off with gmail and outlook, but only on some accounts.

    Mail is a bad program, that all :(
     
  14. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #14
    That sounds like you are only using that server and not any of the others, so any problem with the earthlink server will affect all 3 accounts.

    Try unchecking that option if you get the problem again.
     

Share This Page