Mac Minecraft Kernel Panic

Discussion in 'Mac and PC Games' started by Hugbees, Dec 21, 2011.

  1. Hugbees macrumors regular

    Joined:
    Dec 13, 2007
    #1
    So Minecraft has been making my computer kernel panic quite frequently lately. I didn't have this problem playing originally in 1.0 a few months ago, but now it happens every few days. I don't have any idea as to what is causing it. The game doesn't run slowly, or things begin to happen before the kernel panic, it just happens. Has anyone else been getting this and/or know how to fix it?

    I'm currently running Mac OSX Snow Leopard 10.6.8
     
  2. CCBPES34 macrumors newbie

    Joined:
    Jun 9, 2011
    #2
    What specs are on your system? Is your Java up to date? Also what size is the save you've been playing on? Minecraft has worked just fine for me, it has been installed for over 4 months now, not a single problem.
     
  3. Hugbees thread starter macrumors regular

    Joined:
    Dec 13, 2007
    #3
    My java is up to date, though Minecraft refuses to run it at 64 bit.

    My graphics card is a 256 MB ATY, RadeonX1600

    2 gigs of ram.

    I mean, I'd think I'd have more than enough to run this game, and when it does run it runs well, unless I mash all of the settings to max then there's some issue but on mid-high settings its great and it doesn't show any sign of slow down before the kernel panic.

    As for the world size, I'm not sure, I play online on a friend's server.
     
  4. CCBPES34 macrumors newbie

    Joined:
    Jun 9, 2011
    #4
    I have the 9400m and 2GB RAM, so I don't think your system is the problem. I would post on the Minecraft forums as well, see if anyone else has been having this problem. If you could give us the Panic Log( located in Library>DiagnosticReports), that would help, too. I do recall one time when Minecraft caused a kernel panic for me, it was using a lot of RAM, and with the programs running in the background, I ran out completely.
     
  5. Hugbees thread starter macrumors regular

    Joined:
    Dec 13, 2007
    #5
    Interestingly enough, I did have the system monitor up when playing and it wasn't even using 20% of the available ram and it panicked.

    I also can't find anything that says DiagnosticReports
     
  6. CayceH macrumors newbie

    Joined:
    Dec 23, 2011
    Location:
    United States
    #6
    Depends if lagging or not

    If you are Lagging I would suggest changing your video settings, I.E. Render Distance, Brightness........
     
  7. Washac macrumors 68020

    Washac

    Joined:
    Jul 2, 2006
    #7
    Hello

    Minecraft in 64bit how to, works a treat :)

    http://www.youtube.com/watch?v=NwbPnSyT6kU
     
  8. Hugbees thread starter macrumors regular

    Joined:
    Dec 13, 2007
    #8
    I am not getting lag, at least, not so much it's an issue. I play online and I get lag spikes here and there but only once a day or so.

    Also, this solution didn't work as I have no JavaVM folder in my library.
     
  9. zeemeerman2 macrumors 6502

    Joined:
    Feb 21, 2010
    #9
    Have you tried using the Minecraft add-on OptiFine? It can drastically improve framerate on lower-end computers*, optimise nothing on higher-end computers**, and smoothen out lag spikes***.
    Download here: http://www.minecraftforum.net/topic/249637-100-optifine-hd-d2-fps-boost-hd-textures/

    * Tested on my low-end Whitebook from 2008 with an Intel GMA X3100: 10 fps without optifine, 30-40 fps with optifine.

    ** Tested on my current model base Macbook Pro 15" with a Radeon HD 6750M.

    *** Look below to screenshots, and corresponding average framerates.

    Before lag spikes:
    [​IMG]

    After lag spikes:
    [​IMG]
     

Share This Page