Mac Mini 1.2G4 on Sony Bravia

Discussion in 'Mac mini' started by jeppson, May 13, 2011.

  1. jeppson macrumors newbie

    Joined:
    May 13, 2011
    #1
    I am trying to use my Mac Mini 1.2G4 (older 2005 model) as a media center.

    I cant make it work with my Sony Bravia 40" KDL-40W4100 tv it keeps saying invalid format (sony).

    So I though I was smart and started doing a new installation of mac while connected to the Sony TV. While installation the resolution worked perfect and even in very high resolution, during final installation the screen went black and after installation it re-booted and then black screen with invalid format message..

    I guess MAC OS X installation changed the resolution after install.
    What can I do?? :confused:

    Please help! My family wants to watch movies :)
     
  2. jeppson thread starter macrumors newbie

    Joined:
    May 13, 2011
    #2
    DVI to HDMI

    Another option is to buy a DVI to HDMI cabel and maybe try that instead?

    Dan:D
     
  3. firedownunder macrumors regular

    Joined:
    May 5, 2011
    #3
    You need to look at your owner's manual (Sony) and see what resolutions are supported for pc connections. Then on your mini open monitor preferences (system preferences, monitor, etc.) and choose the appropriate resolution. The mini is outputting a resolution not supported by your tv, hence the message. If you're not using a second display, you will have to connect to one to make any changes.
     
  4. cocacolakid macrumors 65816

    cocacolakid

    Joined:
    Dec 18, 2010
    Location:
    Chicago
    #4
    Firedownunder is correct, you just need to change the mini's resolution.
     
  5. cocacolakid macrumors 65816

    cocacolakid

    Joined:
    Dec 18, 2010
    Location:
    Chicago
    #5
    The Sony owner's manual and website says that TV will accept a 1920 x 1080p signal only through HDMI or Component cables. If you have it hooked up with a VGA cable, you need to set the mini's resolution to 1080 interlaced.

    Here's how to do it.

    Connect the mini to a computer monitor so you can change the resolution.

    Open System Preferences.

    Go to Displays.

    Check the box in the lower left corner that says, "Show Displays In Menu Bar."

    Depending on how your mini is connected to your monitor, the options might say 1080p or 1080i, or just one instance of 1920x1080. If it says 1080i, choose that. If not, set it to 1920x1080.

    Close System Preferences.

    Now go up and click on the little monitor symbol in the upper right of your top menu bar. It will show you several different resolutions, often easier to figure out what is what than using the previous menu. If it shows 2 different 1920x1080 resolutions, choose the one on the bottom. That should be 1080i.

    Now you can disconnect the mini from the monitor and connect it to the TV. If that was 1080i that you selected, it should work fine. If it still says "Invalid Format", then reconnect to the monitor, go back to the top right, click on the monitor icon and choose the other 1920x1080 resolution, then try it on the TV again.

    If that doesn't work you'll have to choose 1280x768. However 1080i is supported over VGA according to your owner's manual, page 14.

    Link to your owners manual.
     
  6. cocacolakid macrumors 65816

    cocacolakid

    Joined:
    Dec 18, 2010
    Location:
    Chicago
    #6
    You could use a DVI to HDMI adapter, along with an HDMI cable, to get 1080p, however, the HDMI cable won't carry audio with it.

    Looking at the back of your TV in the manual, if you connect it with VGA cables there is a single 2.5 mm audio jack, but if you use HDMI and need separate audio input, it takes Right/Left RCA style jacks. So you'll need a 2.5 mm to RCA jack adapter, plus the corresponding cable to get audio over to the TV with the HDMI input.

    Monoprice is the cheapest place I've always found for cables.
     
  7. cocacolakid macrumors 65816

    cocacolakid

    Joined:
    Dec 18, 2010
    Location:
    Chicago
    #7
    BTW, with an older mini, you should try out the G4 optimized MPlayer as your media player, it will play videos better than Front Row/Quicktime.

    Follow the OP's instructions on the settings, and tell it to be the default player for your file types.
     
  8. firedownunder macrumors regular

    Joined:
    May 5, 2011
    #8
  9. jeppson thread starter macrumors newbie

    Joined:
    May 13, 2011
    #9
    Found temp solution

    I did what I wrote and purchased a DVI to HDMI cabel.

    Now the res works fair, image is missing abit on horizontal view (resolution), but its ok.

    Dan
     
  10. b-rad g macrumors 6502a

    b-rad g

    Joined:
    Jun 29, 2010
    #10
    Make sure you check the display setting and use the Underscan if your missing some of the top and bottom of the screen.
     

Share This Page