Mac Mini / 1080P HDTV Settings

Discussion in 'Apple TV and Home Theater' started by JLandis, Oct 28, 2009.

  1. JLandis macrumors member

    Joined:
    Jul 26, 2008
    #1
    Hello, I have a Pioneer 500M HDTV (1080P) and the new Mac Mini. I will be using this setup to steam video content. In OSX, preferences > display there are a bunch of resolutions to choose from for output. None specifically that say 1920x1080, but there is one for 1080p. The screen display does not fit the TV correctly. I have to select 'overscan' ON for a better fit, still not perfect. Even with that the top system bar is hiding out of the display area. The dock at the bottom looks fine.

    There are other settings such as refresh rate (24, 50-PAL, and 60-NTSC).

    Under Color tab, the mac recognizes the Display Profile as PIONEER-M which seems to be a good sign.

    Of these options what are the best output display settings? What combination should I use/other ideas? Should I be using Overscan? I want the cleanest and most accurate output possible. Thanks for helping me set this up.
     
  2. freepeacesweet macrumors member

    freepeacesweet

    Joined:
    Oct 7, 2008
    Location:
    Cayman Islands
    #2
    On my Sharp 1080p LCD i have to select on the TV menu dot by dot under resolution for the mini output to fit perfect.
     
  3. Flynnstone macrumors 65816

    Flynnstone

    Joined:
    Feb 25, 2003
    Location:
    Cold beer land
    #3
    There is some software that I've used for what your talking about.
    I'm trying to remember the name ...

    It would be nice to drive a HDTV natively to the display resolution.
     
  4. freepeacesweet macrumors member

    freepeacesweet

    Joined:
    Oct 7, 2008
    Location:
    Cayman Islands
    #4
    The software you can use is called SwitchResX.
     
  5. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #5
    Most modern TVs should have, as freepeacesweet said, a dot-by-dot setting in the home theatre/picture settings, and you won't need extra software like SwitchResX.

    But what it's called will depend on the manufacturer. My Toshiba did exactly the same as yours - it auto-selected what it called "Natural" in the Video/Theater Settings, and it needed overscan. Changing this to "Native" fixed this. Experiment with the settings on your TV.

    You'll likely need to be connected to a HDMI port on the TV to use dot-by-dot (at least, I had to with my Toshiba)
     
  6. cawesjmu macrumors 6502

    Joined:
    Apr 4, 2004
    Location:
    Richmond, VA
    #6
    how did you connect them? Mini-DVI to DVI? Mini-DVI to HDMI? Mini display port to DVI? or mini display port to HDMI? I have my MBP to HDTV hooked up via DVI to HDMI and my HDMI port says "HDMI-DVI" so I'm thinking either try and the other HDMI port or try using the DVI port on the back of your TV. See if it's any different. Mine works in the HDMI-DVI port perfectly, but not the 'regular' HDMI port.
     
  7. JLandis thread starter macrumors member

    Joined:
    Jul 26, 2008
    #7
    I am hooked up through mini-displayport > HDMI. I will try some of these settings later such as dot by dot and experimenting with leaving overscan off. Thank you.
     
  8. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #8
    No, you want overscan ON in the Displays preference. If you turn it off you're going to get a big black border around the screen once you eventually track down the dot-by-dot (or whatever Pioneer calls it) mode on your TV.

    That's assuming Pioneer actually has such a mode; it's possible they don't on that model. I've heard that at least some companies don't, though I'm baffled as to why.

    Otherwise you're using the right settings--1920x1080, 60Hz (assuming you're in an NTSC region like North America).

    Edit: According to Pioneer's spec sheet (that's a PDF) the TV does indeed have a dot-by-dot mode, and that's exactly what it's called. It also notes that it doesn't work when the screen is set to PC mode, so you might have to select a different mode to get that option to kick in. Alternately, it might automatically select that if you're in PC mode--according to that sheet it actually has a direct DVI input, so are you using that, or one of the HDMI inputs?

    Also, just to mention, be careful about getting the menu bar or dock burned in. Never owned a plasma TV myself, and I hear they're much better these days about burn-in, but the warning is still there at least.
     
  9. JLandis thread starter macrumors member

    Joined:
    Jul 26, 2008
    #9
    Hey, thanks for looking that up. I will try that out as soon as I get home!

    Thanks!
     
  10. jorba macrumors newbie

    Joined:
    Sep 18, 2008
    #10
    Back in Tiger days, I got my Core Duo mini working with Vizio VX37L using a helper called DisplayConfigX. DisplayConfigX continued to work through the Leopard upgrade, but stopped working at SnowLeopard. I tried SwitchResX and it worked. DVI -> HDMI .

    The display preferences include a "1080i" and 9 of the "x by y" choices. I chose 1366x768. I don't remember if "1080i" was different/worse.
     

Share This Page