mac mini 2012 OX or video card issue?

Discussion in 'Mac mini' started by al404, Apr 28, 2015.

  1. al404 macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #1
    since latest upgrade to 10.10.3 + update fix i get on both monitor some sort of random square pixel row, like when you see digital tv with bad signal

    i never noticed before 10.10.3 upgrade but even after latest fix i still have the issue

    could it be a video card hardware problem?
     
  2. Carl%R macrumors newbie

    Joined:
    Nov 5, 2012
    Location:
    Sweden
    #2
    Same thing here on a 2012 Mac mini. It began after the 10.10.3 update. I have two screens and sometimes it's on the left and sometimes on the right.

    I have cleared caches, reset nvram, run memtest and Apple hardware test and no errors are reported. I even cleaned the inside of the computer from dust in case it was overheating. Temperatures seem normal though.

    So I suspect it's a graphics driver issue in 10.10.3. Unless the video circuits are all failing at the same time on the 2012s...:eek:
     

    Attached Files:

  3. al404 thread starter macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #3
    exactly same issue, but i guess there is some sort of issue with video driver in 10.10.3 because Apple released a fix, that did not fix in my case

    https://support.apple.com/kb/DL1807
     
  4. drasl macrumors member

    Joined:
    Jul 3, 2014
    #4
    Same issue for my Mac mini 2012, the "fix" did not fix the issue for me.
     
  5. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #5
    I too have seen some of this with my 2012 Mini and 10.10.3.
     
  6. xsquid macrumors regular

    xsquid

    Joined:
    May 27, 2015
    #6
    Same here, started at 10.10.3. Late 2012 model.
     
  7. Crosscreek macrumors 68030

    Crosscreek

    Joined:
    Nov 19, 2013
    Location:
    Margarittaville
    #7
    I have seen the same with my 2012 running 10.10.4 beta and had seen it back to 10.3. I have found an easy fix by assigning a hot corner to show all screens and open windows.

    If when the anomaly happens I go to the hot corner and display all open windows and screen and then pick what ever app screen I was using and the pixilation will disappear.


    It is a software problem.

    F4 works too on mine too to display all windows.
     
  8. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #8
    I had this problem with my 2012 Mini Server and 2012 Mini (both 2.3 i7, 16GB RAM) and it was driving me nuts. I fixed it on both Minis a couple of weeks ago by DLing and installing the 10.10.3 Combo installer (from Apple's Support web page), no issues with either Mini since. I hope this helps. I was surprised that the fix for my Minis was that simple.
     
  9. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #9
    These issues went away for me when I updated Little Snitch to 3.5.3 and/or disabled the network monitor in the menu bar.
     
  10. al404 thread starter macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #10
    no Little Snitch, and just happened again in El Capitan :-(
     
  11. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #11
    Mine started having some non-specific panics. I seem to have resolved them by removing and reinstalling the RAM and blowing out the fans with some compressed air to clear the dust.
     
  12. Carl%R macrumors newbie

    Joined:
    Nov 5, 2012
    Location:
    Sweden
    #12
    Yep, me too. The glitching graphics issue seems to have returned in El Capitan.
     
  13. Jig3n macrumors member

    Joined:
    Oct 24, 2012
    #13
    Me too... no problems with windows with bootcamp though..
     
  14. Nanotyrns macrumors 6502a

    Nanotyrns

    Joined:
    Sep 16, 2012
    Location:
    Denver
    #14
    I have a similar issue on my 2012 Mac mini OS X 10.11.1
    Mine seems to surface while watching YouTube videos in Firefox. Sometimes it escalates to video freezes followed by a spontaneous reboot. I can't decide if it's a hardware issue or a software issue. Leaning toward software because it always happens in Firefox but don't know enough about how it all works.

    Anyone have any ideas?
     
  15. Acorn, Oct 25, 2015
    Last edited: Oct 25, 2015

    Acorn macrumors 68020

    Acorn

    Joined:
    Jan 2, 2009
    Location:
    macrumors
    #15
    it does not surprise me one little bit that there is a graphic issue again.
     
  16. milliontown macrumors newbie

    milliontown

    Joined:
    Nov 8, 2015
    #16
    I am having the exact same problem. I was wondering if it was something specific to me, but it seems as though its happening to at least one other person. I really like firefox, but I may have to switch if this continues.
     
  17. treekram, Nov 9, 2015
    Last edited: Nov 9, 2015

    treekram macrumors 65816

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #17
    I have a 2012 2.6 Ghz i7 Mini running El Capitan (10.11.1 15B42). I have this problem when viewing some YouTube videos in Firefox (ver 42.0). I don't know if Flash (19.0.0.226) is involved as the YouTube settings seem to indicate that it prefers using HTML5. I don't have the issue when viewing YouTube in Safari or when using QuickTime or VLC to view videos.

    Interestingly enough, for me, I don't recall this being an issue until 10.10.5.

    There was a thread that I can't find now which said that there was a problem with the Yosemite driver for the HD4000 GPU in the 2012 Mini which caused kernel panics. I didn't have kernel panics when I was running ML (for 26 months). I didn't have a problem with 10.10.2 (the first version of Yosemite I installed) but starting with 10.10.3, I started having kernel panics (continued with 10.10.4 and 10.10.5). For me, the kernel panics have gone away with El Capitan - with 10.11[.0] I have had a GPU restart (the log is named Kernel_[date-time]_[hostname].gpuRestart) which I think resulted in being sent back to the login screen and haven't had anything similar since.

    (I don't recall the pixel row happening before my kernel panics. For me, the kernel panics would typically be - video, if playing would stutter, then freeze, the mouse would be responsive for a little while longer and it would freeze and then the computer would reboot with the "computer restarted because of a problem" message.)
     
  18. Jig3n macrumors member

    Joined:
    Oct 24, 2012
    #18
    I found something that 100% fixed it... In firefox just turn off hardware acceleration. Ever since I did that the glitches want away completely.
     

    Attached Files:

  19. Nanotyrns macrumors 6502a

    Nanotyrns

    Joined:
    Sep 16, 2012
    Location:
    Denver
    #19
    Thanks for the tip! I'll give that a shot and see what happens.
     
  20. treekram macrumors 65816

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #20
    For me, in watching about 45 minutes of YouTube videos without hardware acceleration, the problem does not occur. With it on, it started about 13 minutes in. Good find, Jig3n.

    In looking at Activity Monitor, in watching a particular 360p video I see that it takes about 46%-50% CPU without acceleration, 27%-45% CPU with acceleration.

    Besides the decoding of videos, the hardware acceleration is used in 2D/3D animations. A good example of what this looks like cat be seen at:
    http://webdesign.tutsplus.com/articles/15-inspiring-examples-of-css-animation-on-codepen--cms-23937

    On viewing this page on my Mini, I don't see any on-screen performance degradation between acceleration or not, but the CPU usage is about 100% with acceleration, up to 200% without acceleration. Because lack of acceleration for this page (which has much more animation than the pages I usually visit) seems to just eat more CPU rather than affect on-screen performance, I'll turn it off. However, I'll continue to use Safari for YouTube because it doesn't have this problem and it's more efficient. For the same 360p video, Safari had 3 separate processes - Safari Networking took 1%-10% CPU, http://ww.youtube.com took about 7% CPU and the Safari process itself was 0%-1% CPU. It looks like WindowServer takes about 2% more CPU when viewing the video in Safari vs. Firefox. So a total of 10%-20% CPU. Also, for whatever reason, when the video finishes in YouTube (still on the YouTube page) and everything settles down, Firefox still takes 16%-27% CPU (this drops to near-0 if you close the tab/window). In Safari it stays at about 3% for a little while then drops to near-0.

    I also noticed that one can set hardware acceleration off for Flash (I have tested what effect this has).
    https://forums.adobe.com/thread/891337
     
  21. JamSandwich macrumors regular

    Joined:
    May 19, 2006
    #21
    Nice to read that this appears to be a more common than just me issue. I was worried the GPU was dying or overheating when I saw this. I also see this mainly manifest using YT on Firefox.

    Will try the fix (probably), but maybe this should be the impetus to shift to another browser. I've been a longtime Firefox user, but I'm not loving it lately and it seems a bit resource-hungry.
     
  22. Negritude, Jan 7, 2016
    Last edited: Jan 7, 2016

    Negritude macrumors 6502

    Joined:
    Jul 14, 2011
    #22
    Just adding my experience to help others who come across this thread, I had the EXACT same experience of watching YouTube videos and then suddenly, they would stutter, then freeze, then the machine would spontaneously reboot. I disabled Flash and haven't had any reboots since. I do still have Hardware Acceleration enabled in Firefox though, and one thing that does still happen is that I get graphical glitches in the top left corner of the screen, which go away once I redraw the screen by minimizing or hiding Firefox and then bringing it back to the front. I haven't tested it yet, but I'm pretty sure that if I also diasabled hardware acceleration, the graphical glitches would disappear as well.

    I want to emphasize that this is a Firefox specific issue, as none of the rebooting or graphical glitches occur in any other browser.

    I also want to point out that since disabling Flash, I have run into very few videos that I could not play. Web sites are no longer as dependent on Flash for video playback as they used to be, and you can now disable it and not even notice that's it's gone.

    So, to summarize, you can fix these problems in Firefox by:

    1. Disabling Flash (Tools -> Add-ons -> Plugins -> Set "Shockwave Flash" to "Never Activate")

    and/or

    2. Turning Off Hardware Acceleration (Firefox -> Preferences - > Advanced -> General -> Deselect "Use hardware acceleration when available")
     
  23. al404 thread starter macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #23
    in my case i just get the annoying thing that you can see on post #2
    no slow down, no reboot or other issue

    did you get the same stripes on your monitor?
    how many monitor do you have?
     
  24. Negritude, Jan 7, 2016
    Last edited: Jan 7, 2016

    Negritude macrumors 6502

    Joined:
    Jul 14, 2011
    #24
    For one thing, you should be using 10.10.5, unless you have some specific reason for not upgrading.

    Second, make sure that hardware acceleration is turned off in Firefox, as that is what causes the majority of graphic display glitches.

    Also, if you insist on continuing to use Flash, make sure it's the latest version, which is 20.0.0.267.

    Lastly, try applying the 10.10.5 Combo Update. The combo update is sometimes able to fix things by replacing files that may have gotten messed up or corrupted somehow.
     
  25. al404 thread starter macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #25
    i'm now at latest version of El Capitan, but still get the issue some times
    i try to do what you suggest
     

Share This Page