Mac Mini 2018 Deep Sleep

Discussion in 'Mac mini' started by jrodl123, Nov 20, 2018.

  1. jrodl123 macrumors newbie

    Joined:
    Nov 20, 2018
    Location:
    New York
    #1
    Hi, I've had my Mini i7, 1tb ssd for just under a week and have noticed that after an unknown amount of time the light on the front goes off. After clicking my mouse or pressing a keyboard it does wake up normally, but I can't find any documentation about if this is supposed to happen or how/if I could change this behavior. Apple support wasn't 100% confident that this was an issue and this page on apple support is no longer being updated.

    Anyone else having this issue?
     
  2. harvester32 macrumors member

    Joined:
    Oct 29, 2012
    #2

    Hi I just noticed the same yesterday. I attributed it to having restored my system from a Time Machine backup and something hiccuped. So, I reset the SMC via the T2 procedure listed below. Make sure you go to the bottom of the page where it talks about T2 equipped Macs. So far, my light has been predictable since.

    https://support.apple.com/en-us/HT201295
     
  3. jrodl123 thread starter macrumors newbie

    Joined:
    Nov 20, 2018
    Location:
    New York
    #3

    Thanks. I will give that a try. I set my Mini up as a new machine and did not restore from any backup.
     
  4. Irken Skoodge macrumors newbie

    Joined:
    Nov 19, 2014
  5. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    I suspect that "standby" is not quite the same as "powered off"
    Power state is standby (the Mac is sleeping for some period of time, probably 3 hours now. The Sleep mode shows a flashing power LED, until that 3 hour period (if that is what it is now), and then the LED goes off. The system state is saved. Pressing any key should bring the mini back up and running in a few seconds. If any key does not wake it up, then press and release the power button. You should see a restore screen (sort-of grey background with a white progress indicator while the system is restored, different from powering from completely off.) At least that is how restore from standby has worked on several of the Macs that I have used for the last few years.
     
  6. NerdsLTD, Nov 20, 2018
    Last edited by a moderator: Nov 21, 2018

    NerdsLTD macrumors newbie

    NerdsLTD

    Joined:
    Jan 4, 2011
    #6
    Assuming you have an LG thunderbolt display:
    Took a while to figure this issue out too. It's so simple, it's illusive. You need to update the firmware on your LG display. Remember that useless app LG released for "on screen controls?" If you were like me, you downloaded it, realized it was pointless, and removed it.

    They've added an in line firmware update feature which activates The moment the app is run with a connected LG display. It will walk you through a firmware update or two and prompt you to reboot. After tax: presto! No more zombie display! I then uninstalled the app. The LG app is only available on the Mac App Store. Grab it, use it, and throw it away.

    https://itunes.apple.com/us/app/lg-screen-manager-lg-monitor/id1142051783?mt=12
     
  7. Spectrum macrumors 65816

    Spectrum

    Joined:
    Mar 23, 2005
    Location:
    Never quite sure
    #7
    Is this hibernation mode the same as laptops?
    There is a sleep delay parameter before entering deep sleep / hibernate mode
    See this link: https://computers.tutsplus.com/tutorials/how-to-hibernate-a-mac--cms-23235
     
  8. jrodl123 thread starter macrumors newbie

    Joined:
    Nov 20, 2018
    Location:
    New York
    #8
    My mini doesn't have a flashing LED when it's sleeping.
     
  9. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #9
    OP:

    Just wondering... a question... might be relevant, then again might not be, but...

    ... do you keep the option for "automatic software updates" turned ON?
     
  10. jrodl123 thread starter macrumors newbie

    Joined:
    Nov 20, 2018
    Location:
    New York
    #10

    I have automatic software updates turned off.
     
  11. Macintoshrumors macrumors 6502

    Macintoshrumors

    Joined:
    Oct 18, 2016
    #11
    Can confirm. My late 2014 mini does this.
     
  12. jrodl123 thread starter macrumors newbie

    Joined:
    Nov 20, 2018
    Location:
    New York
    #12

    After resetting my SMC I’ve let the mini sit in standby and somewhere between 24 and 36hrs the light goes off.
     
  13. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #13
    If it's going to be "in standby" for 24 hours, might as well just power it down.
    Then you'll know why the light is off... ;)
     
  14. th0masp macrumors 6502

    Joined:
    Mar 16, 2015
    Location:
    germany
    #14
    I encountered this on my Mac Pro running 10.13.6 recently - when it entered Deep Sleep (TM) I could no longer wake it via keyboard or by turning on the screen, needed to press the power button instead (which is a chore on the Cylinder model in case you are unaware - it's hidden underneath the cables and kinda hard to reach).

    Solution was to enable wake on LAN in the energy preferences, this way it never goes into a coma.

    edit: I should mention: this works in my case because I have turned off a lot of network functionality on all my machines. I would not rule out that in a more standard setup your computer then starts to wake up all the time when pinged by whatever devices you may have.
     
  15. harvester32 macrumors member

    Joined:
    Oct 29, 2012
    #15

    Mine is back too but I've narrowed it down on mine to where I can force it to happen by booting into bootcamp (Win 10) and then back to macOS at which point the light is off. Are you multi boot capable, and could this be your issue?

    Ken
     
  16. jrodl123 thread starter macrumors newbie

    Joined:
    Nov 20, 2018
    Location:
    New York
    #16
    No I have not tone multi boot yet. I'm basically on a stock Mini i7 and have not restored from a previous backup. Apple support seem to think that creating a new user account can determine if this is a real problem.
     
  17. Spectrum macrumors 65816

    Spectrum

    Joined:
    Mar 23, 2005
    Location:
    Never quite sure
    #17
    Old thread, but I have the a 2018 mini now, so revisiting. Indeed, the behaviour you are describing is because the standbydelay parameter is 86,400 seconds = 24 hours. This is the time it waits in sleep mode before going into deep sleep/hibernation. On laptop, standbydelay is only 4200 seconds = 70 minutes.
    You can change this using pmset argument in terminal. See link in earlier comment.
     
  18. jrodl123 thread starter macrumors newbie

    Joined:
    Nov 20, 2018
    Location:
    New York
    #18
    Thanks for the reply. After reading the earlier link and the manual for pmset this now makes more sense. Think i'll leave the setting as it is. There are periods where I'm not using the mini for more then 24h as I also use a macbook, so as long as this is expected behavior I'm no longer concerned.

    -J
     

Share This Page

17 November 20, 2018