Mac Mini 2018 Three Monitors Issue

Discussion in 'Mac mini' started by brianmini, Dec 6, 2018 at 12:03 PM.

  1. brianmini macrumors newbie

    Joined:
    Thursday
    #1
    Hello,

    I just purchased a new mac mini 2018 and I have three monitors connected to it:
    • (One) Dell P2715Q 27" 4k (I run it at 2560x1440) on an HDMI to HDMI port
    • (Two) Dell U2715H 27" 2560x1440, both on DP to USBC ports
    My problem is that, whenever I wake my computer from sleep.. The monitors rearrange themselves. It seems to be completely random. My two Dell U2715H's sometimes only go up to 2048x1152 resolution in the displays settings also.

    How can I fix this issue? I cannot even use my Mac mini because every time I wake it, I spend 5 minutes configuring the monitors...
     
  2. megaseppl macrumors newbie

    Joined:
    Dec 20, 2013
    #2
    I can't really help you - because here it works with 3 screens. No random rearrangements. Even no random desktop backgrounds as I have on other macs.
    I'm using 1 screen with HDMI -> DVI and 2 screens with USB-C -> DP. Does it happen too if you unplug the 4K screen?
     
  3. jeremy5 macrumors newbie

    Joined:
    Sep 12, 2014
    #3
    I have 3 monitors and have had the issue several times after a reboot, but never after waking it. I have tried resetting the PRAM following the instructions here, but am not even sure that I was able to do it right after trying multiple times.

    I've even resorted to changing the cables around after it occurs instead of using the OS, but it didn't seem to make it stick.

    I'm using two USB-C to DVI cables and an HDMI cable. Oddly the HDMI one seems to stay where it should be (in the center), and it's only my two outer monitors occasionally flipping around after a reboot.
     
  4. LeeW macrumors 6502

    LeeW

    Joined:
    Feb 5, 2017
    Location:
    Glasgow, Scotland
    #4
    Mine does that, never figured it out and that is only two screens.
     
  5. jean512 macrumors member

    Joined:
    Oct 1, 2017
    #5
    I had that with 2 usb-c monitors, only after reboot
     

Share This Page