Mac mini 4k issues (Sleep)

Discussion in 'Mac mini' started by luisn17, Feb 16, 2015.

  1. luisn17 macrumors member

    Joined:
    Jun 23, 2008
    Location:
    Miami, Fl
    #1
    Hello,

    I have a mac mini 2014 running yosemite with a samsung U28D590. I at first connected the computer with my HDMI and was able to see 4k resolution. I then followed the steps listed in this forum to get the mac mini to show 4k thru the DP. I have mini DP to a regular DP. I'm running 4k at 50HZ.

    The computer works fine showing 4k content except when I disconnect the HDMI and the computer comes back from sleep. When I wake up the computer with only the DP connected then all i see is a black screen. If both the HDMI and DP are connected then it works with no issues.

    Is anyone else having the same issue? Its almost like either switchesX is not loading the resolution on time?? I don't know what to do but having both HDMI and DP projecting to the computer is overkill.

    If this helps, My mini is 2.7, 16GB memory, and fusion drive.

    Thank you.
     
  2. stempsons macrumors regular

    Joined:
    Feb 15, 2014
    #2
    Yep, exact same issues. I'm running both dp and hdmi and for whatever reason, i can set the pixel clock at 450 and run at 51hz. without the hdmi cable. black screen and screen freezing with anything over 45hz on dp. makes no sense, so i'll just keep the two cables connected and disable the hdmi screen via switch rezx.
     
  3. luisn17 thread starter macrumors member

    Joined:
    Jun 23, 2008
    Location:
    Miami, Fl
    #3
    How are you able to disable the screen? I see the option but its greyed out, did you buy the program? does that make any difference?
     
  4. stempsons macrumors regular

    Joined:
    Feb 15, 2014
    #4
    switch res x has a display set section, where you can set the primary and secondary display, as well as choose which is to be on or off.
     
  5. luisn17 thread starter macrumors member

    Joined:
    Jun 23, 2008
    Location:
    Miami, Fl
    #5
    Thank you, that seems to work. What a retarded workaround but 50hz over 30hz does make a big difference.
     

Share This Page