Mac Mini and sleep mode

svennn

macrumors newbie
Original poster
Nov 21, 2011
6
0
I'm running a new Mac Mini as a media server using Plex.

One issue I have is waking the mini up from sleep. It is running headless switched through an AV receiver to the TV. Everything is installed in a media closet with both IR repeaters and RF remotes.

I want to just hit the "Plex" button on my remote and start using it. However, it is in sleep mode and requires a keyboard stroke or mouse click. It is also looking for a password.

This is not earning me any brownie points from the wife and kids. Simple is good. I thought I changed the correct settings in preferences so it would never sleep but I guess not.

Any input from other users on the optimal settings for this?

Thanks,

Steve
 

OldMike

macrumors 6502
Mar 3, 2009
396
76
Dallas, TX
I'm running a new Mac Mini as a media server using Plex.

One issue I have is waking the mini up from sleep. It is running headless switched through an AV receiver to the TV. Everything is installed in a media closet with both IR repeaters and RF remotes.

I want to just hit the "Plex" button on my remote and start using it. However, it is in sleep mode and requires a keyboard stroke or mouse click. It is also looking for a password.

This is not earning me any brownie points from the wife and kids. Simple is good. I thought I changed the correct settings in preferences so it would never sleep but I guess not.

Any input from other users on the optimal settings for this?

Thanks,

Steve

If you look in your security and privacy under system settings, in the general tab, you can turn off require password after sleep or screen saver begins.

I also run my Mac Mini where the system never goes to sleep, but instead puts the display to sleep after a given length of time (energy saver in system preferences). I don't have a remote and I don't run plex, so I am not sure if this might resolve your issue. I have noticed since switching to lion that waking my screen up from sleep (not the system) requires a mouse click or keyboard press, when pre-lion, it only required a move of the mouse.

-Mike
 

svennn

macrumors newbie
Original poster
Nov 21, 2011
6
0
If you look in your security and privacy under system settings, in the general tab, you can turn off require password after sleep or screen saver begins.

I also run my Mac Mini where the system never goes to sleep, but instead puts the display to sleep after a given length of time (energy saver in system preferences). I don't have a remote and I don't run plex, so I am not sure if this might resolve your issue. I have noticed since switching to lion that waking my screen up from sleep (not the system) requires a mouse click or keyboard press, when pre-lion, it only required a move of the mouse.

-Mike
I'll check that tonight. I think the settings I changed were under energy saver. I set computer sleep and display sleep to never.

The Apple remote will not even wake up the mini anymore. I still need to see how it will work with the plex app for google TV in the other room.

Getting these sleep/wake issues is proving to be an issue.

Thanks.

Steve
 

freepeacesweet

macrumors member
Oct 7, 2008
73
1
Cayman Islands
I have 2 Mac Mini systems running PLEX both have Harmony remotes. On one TV I have sleep turned off and the password turned off. This TV also run a camera so I don't mind it being on. When the AV switches on and the TV the signal is already there. The second one also has the password turned off and is connected to a different brand of TV which the mac mini for some reason loses the EDID of the TV when it switches off. This one needs to enter sleep and then wake up after the TV is switched on so it gets the EDID and the signal is displayed on the screen. I achieved this using the Harmony remote to wake the TV from sleep. It was a setting on the Harmony remote rather than the Mac Mini.
 

OldMike

macrumors 6502
Mar 3, 2009
396
76
Dallas, TX
I'll check that tonight. I think the settings I changed were under energy saver. I set computer sleep and display sleep to never.

The Apple remote will not even wake up the mini anymore. I still need to see how it will work with the plex app for google TV in the other room.

Getting these sleep/wake issues is proving to be an issue.

Thanks.

Steve
Let me know how it goes, because my current Mini may end up going in the living room as well, if I can convince the CFO, I mean the wife, that a new Mini should be added to the family.
 

svennn

macrumors newbie
Original poster
Nov 21, 2011
6
0
I have 2 Mac Mini systems running PLEX both have Harmony remotes. On one TV I have sleep turned off and the password turned off. This TV also run a camera so I don't mind it being on. When the AV switches on and the TV the signal is already there. The second one also has the password turned off and is connected to a different brand of TV which the mac mini for some reason loses the EDID of the TV when it switches off. This one needs to enter sleep and then wake up after the TV is switched on so it gets the EDID and the signal is displayed on the screen. I achieved this using the Harmony remote to wake the TV from sleep. It was a setting on the Harmony remote rather than the Mac Mini.
Interesting. I don't have a Harmony, I use a URC remote. So it is possible it is a handshake issue with the display over HDMI?

I need to tinker some tonight after the kids are in bed....

Steve
 

Cakeove

macrumors newbie
Feb 3, 2011
12
0
I have the same setup

I own a base model Mac mini 2011 and the problem is that need to hit the keyboard for wake up.

Also I leave the plex client running all the time with the tv off. In this mode sometimes the fan start spinning at very high speed, it's so loud that I think the Mac mini will melt.

After quit the plex client, the fans inmediattly starts to slowing down. The temp is also normal.
 

svennn

macrumors newbie
Original poster
Nov 21, 2011
6
0
Just following up with everyone....

I had full success. I changed settings as recommended with one extra. I also needed to turn screen saver to never. Now when I press the Apple TV button on the remote everything switches and I have Plex running full screen with no wake issues.

A quick recap....

system preferences>security & privacy>general> uncheck require password

system preferences>energy saver>computer sleep and display sleep to never

system preferences>desktop and screen saver> under screen saver tab uncheck screensaver

With these setting I no longer need to use the keyboard or mouse to wake the mini.

Now as far as google TV. Perfection. I have a Sony 40" LCD with GTV built in in kitchen. With the Plex app installed everything was detected and streaming in no time from the mini running Plex9. Kids and wife approved. (mother-in-law might be a different story)

Now if I can only get my UNRAID box to auto mount on the mini I will be in great shape......

Steve
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.