Mac Mini and Sony Television DVI to HDMI "Audio Problem"

Discussion in 'Mac mini' started by RaneMc, Jun 9, 2007.

  1. RaneMc macrumors newbie

    Jun 9, 2007
    If anyone has ever encountered a problem like this and either hit a wall or resolved the following situation, please share your ideas and experiences.

    I recently obtained a Mac mini to use with my Sony LCD projection television (model number KDF-E55A20). To connect the two, I used a standard DVI to HDMI conversion cable. The picture looks great.

    I have connected the standard audio output of the mini to the audio portion of the HDMI port (#6) on the television using a cable that changes from the audio-out to RCA (red and white) cables. (I'm sorry I don't know what the name of this sort of cable is, but I know it is very standard).

    The problem: I get no sound!

    To troubleshoot I connected my Powerbook G4 to the same HDMI port (using the provided adapter to connect to the same DVI to HDMI cable). Once I plug in the same audio cable as I tried to use with my mini, I get both picture and sound.

    It seems that the television inactivates the audio input component of the HDMI port if it picks up what it thinks is an HDMI input (since it is supposed to carry audio). BUT IT IS ONLY GETTING DVI!

    So the problem is not with the mini as it produces audio normally. There's a setting (hopefully not hard-wired) with the Sony to inactivate the audio-in on HDMI input.

    Any assistance would be greatly appreciated (even someone saying they've encountered this problem and that there is no fix... at least I can quit trying to fix it).
  2. macfanboy macrumors 6502a

    Jun 5, 2007
    i know!

    i dunno, but probly a setting on the tv is turning it off
  3. RaneMc thread starter macrumors newbie

    Jun 9, 2007
    Thanks for the attempt, but it's nothing as simple as a menu setting.

    Anyone else??
  4. RaneMc thread starter macrumors newbie

    Jun 9, 2007
  5. elec999 macrumors regular

    Jan 25, 2007
    Have you tried checking in the menus of the Sony lcd.
  6. RaneMc thread starter macrumors newbie

    Jun 9, 2007
    Yep. It's not an easy setting like that. I was just hoping to find someone with a similar problem and a solution.

    Thanks anyway.

  7. audiovision macrumors newbie

    Nov 2, 2008
    Well, this may be a year too late...

    I am having the exact same issue with a Sony KDL-46V3000 LCD TV. I have determined that the RCA analog audio input jacks that are associated with HDMI input 1 are only active when there is no HDCP handshake on the HDMI cable plugged into HDMI input 1. This lack of HDCP handshake condition would occur only if you were using a DVI source with a DVI to HDMI cable for the video. If you use an HDMI to HDMI cable from a standard HDMI source, like a blu-ray player, the TV apparently sees the HDCP handshake and deactivates the RCA audio input jacks automatically, even if the HDMI signal is a video-only (no audio) signal.

    I don't know much about the video output on the MacMini, but I would surmise that there IS an HDCP handshake signal there, which is disabling the analog audio inputs on your TV.

    I wish I knew a solution. I'm hoping there's something in the TV service menu that gives the option of having the RCA audio jacks active even when an HDCP handshake is present. I called Sony tech support today, and the 13-year old who spoke with me didn't even really understand my question. He suggested I call tomorrow (Monday) and speak with a product specialist. I will.

    If you have solved this problem already, would you kindly post it here?

  8. ADent macrumors 6502a

    Sep 9, 2007
    There is a $250 Geffen device that add audio to DVI to give a real HDMI with video and audio combined.
  9. gotzero macrumors 68040

    Jan 6, 2007
    Mid-Atlantic, US
  10. Rapmastac1 macrumors 65816


    Aug 5, 2006
    In the Depths of the SLC!
    Or you can get a better sound system than what a tv could offer and run the iMac straight to the input on the speakers? It's much cheaper! It's the route I always take... everybody has to make everything so much harder don't they?

Share This Page