Mac mini AV receiver issue

Discussion in 'Apple TV and Home Theater' started by neo179neo, Aug 24, 2014.

  1. neo179neo macrumors regular

    Joined:
    Sep 29, 2010
    Location:
    Nottingham, UK
    #1
    Hi all, wondering if someone can help... I've got a slight issue which is troubling me...

    I run a mac mini as a media centre htpc hooked up to a newish onkyo AV receiver, the mac mini is practically always on and it is set to never sleep or to display sleep, it works fine, plays fine and sounds fine...

    however my issue is that if i turn the onkyo into standby mode and then later come and turn it back on it won't detect the mac mini, i effectively have to pull the HDMI out, plug it back in and then it recognises it and works fine. I was thinking it might be the AV receiver, however i have also tested this with my PS4 running and the AV in standby and then turning the AV on but it detects the PS4 no problem...

    Any thoughts as to how to fix this? As going to the machine to pull and put back the cable every time is tedious...

    Many thanks
     
  2. HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #2
    Have you tried changing the source? For example, if you have your Mac running HDMI into- say- Video 1, switch to Video 2 and then back again. It sounds like some power-saving option is putting the HDMI link to sleep (even if the Mac isn't asleep) and maybe the Onkyo needs to give the Mac a little e-Nudge to wake up. Just a guess but easy enough for you to try.

    Another little test to try is get something playing on the Mac Mini, then put the Onkyo into standby, then wake it back up. Did the active playback on the Mini resume? Or did the same problem happen again? This would be another way to see if maybe the Mini is putting it's HDMI link to sleep due to inactivity. If the problem doesn't repeat in this scenario, the active playback keeps the channel awake even when the Onkyo goes to "sleep" (standby). When you "wake" the Onkyo, it "sees" the active playback and resumes the passthrough to your TV.
     
  3. neo179neo thread starter macrumors regular

    Joined:
    Sep 29, 2010
    Location:
    Nottingham, UK
    #3
    Thanks for your reply...

    So i tried using a different HDMI input and it still didn't wake up, so i tried playing music through iTunes, onkyo into standby, waited 20mins and then turned it back on and it turned on, i also did the same using plex and it turned on again, a sort of solution so thanks, however my mac usually has an application running e.g. Utorrent, why doesn't this wake it up? Because its actively not passing through video/sound irk the other programmes?
     
  4. HobeSoundDarryl, Aug 25, 2014
    Last edited: Aug 25, 2014

    HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #4
    My guess is that the Mac is set up to sleep what it sees as an inactive port- your HDMI port in this example. While your Onkyo is on, I suspect the Mac "sees" an active HDMI port. When you put your Onkyo to sleep, it doesn't, so then it "sleeps" the HDMI port. The exception is when something is left playing as then the Mac just keeps pumping data to the port whether the Onkyo is on or off. So the latter experiment shows that even if the Onkyo goes into "standby", the :apple:TV will keep pushing media.

    In the situation where your :apple:TV is not pushing media when you turn your Onkyo back on, maybe the Onkyo is not doing something to alert the Mac that there is an active HDMI port awaiting content, or maybe the Mac is not doing something to sense the change on that HDMI port.

    I don't think leaving the :apple:TV pushing media is the best solution here- that was just an experiment to test what might be happening. It's too bad that the input change didn't work as that would have been functionally better. Another option that isn't great but maybe better than leaving media running would be to use an iDevice to try to airplay anything through :apple:TV after you "wake" the Onkyo. In other words, :apple:TV is playing nothing, Onkyo is in "standby". "Wake" both (which should leave you with your original problem). Then try to airplay something through :apple:TV and see if that will wake up the connection to the Onkyo. It might work.

    That's still a less-than-ideal step too but an alternative that might work without leaving media playing all the time.

    Two more things: do you have the slideshow running when you have nothing playing on your :apple:TV for a few minutes? Often this is a slideshow of photos streaming by on the screen. If not, turn that on in "settings" (menu) and then try putting the Onkyo in and then out of "standby". Maybe the slideshow will retain the HDMI connection even when the Onkyo is asleep.

    AND, I think there is still a way to functionally turn on and off the :apple:TV. You might look that up to see if I'm remembering right then try turning it off (which is different than letting it sleep). "Wake" the Onkyo from standy first, then turn on :apple:TV. Perhaps in being turned on instead of waking from sleep, the :apple:TV will look around for an active HDMI connection, which it should find in the just awakened Onkyo. If this works (and if I'm remembering right), it may be the best option.

    I have :apple:TV3 hooked to an Onkyo and don't experience what you are experiencing, so I have a little suspicion of your hardware or HDMI cable. You could swap out the HDMI cable to see if the problem persists (just to eliminate the cable). You might try a different HDMI port too just to eliminate the one port. If neither of those do anything, try cutting the Onkyo out of the equation (just to see if you can isolate the problem to it) by temporarily connecting the HDMI cable directly to the TV (put the TV in "standby" and then "wake" it and see if there's a picture).

    And, I also have my :apple:TV connected to the Onkyo with a optical cable (for Zone 2 audio) and, while probably a wrong guess, maybe connecting that too helps keep both aware of each other when they are asleep & awakened.
     

Share This Page