Mac mini cant find HDD after a ram upgrade

Discussion in 'Mac mini' started by Kissaragi, Jan 8, 2009.

  1. Kissaragi macrumors 68020

    Joined:
    Nov 16, 2006
    #1
    Hi all, i got a 2 gb ram upgrade this morning and opened up the mini to pop it in but when i got it all back together i had the flashing folder with the question mark pop up. I booted into the leopard install cd and disk utility just doesnt show that theres a hard drive in the machine.

    I did miss a screw at first when i was taking the the hdd/optical/fan etc bit out and thought it was just the interconnect board stuck in tightly to the motherboard i tried to lever it out gently, but with maybe more force than was wise. I tried reseating the hard drive and checked all the connections but to no avail.

    The optical drive works fine so do you guys think ive damaged the interconnect board or have i killed the hard disk itself?
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    If you can, check the hard drive in another computer or external hard drive. That will tell you whether or not the hard drive is still good or not.
     
  3. Kissaragi thread starter macrumors 68020

    Joined:
    Nov 16, 2006
    #3
    True, but unfortunately id have to buy an external enclosure to try that. Was hoping someone could give me a best guess as to which it might be.

    I shut the mini down properly before opening it so i cant really see how id have destroyed the hard drive?
     

Share This Page