Mac Mini disassembly [SOLVED, WORKING]

Discussion in 'Mac mini' started by sck1, Sep 1, 2009.

  1. sck1 macrumors newbie

    Joined:
    Aug 8, 2009
    #1
    Hello!

    I just purchased a Mac Mini, which was of course in need of RAM and HDD upgrade.

    However, when I'm booting the Mac again. It just shows a flashing folder with a question mark.

    I googled it up and saw http://8help.osu.edu/1244.html... Now, there's only ONE problem my SuperDrive is not working. It does not want my DVD. :(

    I haven't tried if it worked before -- but, it should have worked.

    When I disassembled it, I accidentally removed a cable which I think may have caused it? I have no other ideas... As the other cables are plugged in. Except I don't have a little cable beside the battery.. which had to be unplugged and nothing else like it on the motherboard.

    I have a picture of the cable. It is located at the back of the SuperDrive.

    http://preview.tinyurl.com/lq68l9

    Could just unplugging that cable make the SuperDrive not work? (weird sentence?). What kinda cable is that anyway? Never seen anything like it before.

    Oh well.... Thanks for any answers...
     
  2. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #2
    I can look when I get home but I'd say if a wire was disconnected it should be reconnected and I would have tested that mini before opening it. I tested mine and ran it for a good week before I did any HDD and ram upgrade.
     
  3. jamin100 macrumors 6502

    Joined:
    Sep 22, 2008
    #3
    Best to look at the ifixit.com guide for taking apart a mini and make sure that you have everything plugged in where it should be
     
  4. sck1 thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #4
    Of course I reconnected it. I have used the Mini since week 34. Just didn't try the SuperDrive (I might not have been clear on that), but it should've worked fine.

    EDIT: Humm.. the cable is not the problem then (Ifixit.com removed the superdrive completely.). So I'm out of ideas.. I guess I'll check some more and see what I can find.

    Thanks for the Ifixit link.

    EDIT2: Eer... I discovered the "problem" *lol*. There was some kind of connector underneath the SuperDrive which I did not connect it to onto the motherboard.. So, I guess it's solved.
     

Share This Page