Mac Mini does not show new internal drive

Discussion in 'Mac Basics and Help' started by macdriver, Apr 30, 2010.

  1. macdriver macrumors newbie

    Joined:
    Apr 30, 2010
    #1
    I replaced the 80 GB drive with a new 500 GB drive, but when I restart from the OS CD, the computer doesn't see the new drive.

    It doesn't show up on the disk utility application, so I guess it's not just in need of formatting.

    The Mini is a 2008 vintage core two duo, 1,83 GHz, and the new drive is a Western Digital serial ATA 56400 rpm WD500BEVTSP.

    Any suggestions for debugging this problem would be greatly appreciated.

    MacDriver

    Maybe I should add, after this happened I re-installed the old drive, and it worked fine, but when I de-re-installed the old drive and re-installed the new drive, it still doesn't show up in disk utilities or system profiler... is it a dead drive?
     
  2. quantum003 macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #2
    I've heard sometimes WD drives will do this... Do you happen to have another Mac? It may be helpful to FireWire transfer your mini into your Mac and see if the disk pops up that way... Otherwise, return the disk... If that's not an option pick up one of those $20 USB to sata/ide adapters and connect the drive that way, through USB... Might get it to mount that way, that's worked for me in the past. If nothing else you can install the OS using that adapter and your next hard drive. That way you can test the os install and the drive without opening and closing the mini.
     
  3. macdriver thread starter macrumors newbie

    Joined:
    Apr 30, 2010
    #3
    Now, it works

    Thanks for the suggestions. I took the easy way out; gave up on the WD, and bought a similar Seagate. This worked without a problem. Hopefully I can return the WD...
     

Share This Page