Mac mini doesn't read Retail SL DVD

Discussion in 'Mac mini' started by :-), Oct 24, 2010.

  1. :-) macrumors member

    Joined:
    Sep 4, 2009
    #1
    Yesterday I tried to reinstall Snow Leopard on my Mac mini 2009. When I inserted SL DVD (get one with mini) mini doesn't seemed to recognized it. It just loads and spin it few minutes and eject it after 2-3 min. Also no DVD option in "Startup disk" menu.

    I was 99% that my SL DVD was corrupted (too scratched) and buy new Retail version in Apple store. When I came home and try to load Retail DVD I have the same issues.

    I tried my friend's SL DVD and his copy loads with no problem at all. I just cannot install SL because DVD wasn't retail.

    Now I don't know what to do. Any idea what would be the cause? I don't think my mini's DVD unit is broken because I can read and burn other DVD's with no problems.

    I hope I was clear and sorry for bad english.
     
  2. hitekalex macrumors 68000

    hitekalex

    Joined:
    Feb 4, 2008
    Location:
    Chicago, USA
    #2
    Yes, you need the SL install disk that came with the Mini.. The retail 10.6.1 disk is missing the NVIDIA 320M drivers, which you need to boot up the Mini. So it won't work.
     
  3. :-) thread starter macrumors member

    Joined:
    Sep 4, 2009
    #3
    I have late 2009 model Mac mini with Nvidia 9400. The retail version is 10.6.3. And the problem is that mini's DVD unit doesn't seemed to recognize SL DVD. And because it doesn't recognize it I cannot even boot or run hardware test form DVD. It just eject it after few minutes in DVD drive. Strange. :confused:
     
  4. Heilage macrumors 68030

    Heilage

    Joined:
    May 1, 2009
    #4
    Sounds like a defective SuperDrive to me. It's typical that it completely rejects discs.
     
  5. :-) thread starter macrumors member

    Joined:
    Sep 4, 2009
    #5
    Thanks for reply. Mini seems to reject only SL install DVD (I have 3 different DVD's, one he accept and two reject). DVD drive normally burns and reads other DVD's. :eek:
     
  6. ahankinson macrumors member

    Joined:
    Feb 1, 2010
    #6
    What happens if you put the DVD in the drive before rebooting?

    Or you hold down the Option key on the grey screen when it's booting, before the little spinner comes on?
     

Share This Page