Mac Mini Dual Drives Problem WTF!?!

Discussion in 'Mac mini' started by strawberrynatto, May 18, 2014.

  1. strawberrynatto macrumors newbie

    Joined:
    Feb 16, 2014
    #1
    Bought a new late 2012 Mac Mini. Bought a Samsung 128gb 840 Pro SSD. Bought a WD Blue 1TB HDD. Bought a USB mouse/keyboard. Connect via HDMI with HDTV.

    Powered on, found the right channel for viewing on HDTV. Clear sailing thru set-up. Verified stock HDD position (lower). Created a Mavericks USB boot key drive. Ordered the OWC Data Doubler.

    Today, opened up the Mac Mini. Took out the stock HDD (too small for my needs). Put the new WD HDD in the upper position, put the Samsung SSD in the bottom/lower position. Put everything back together - no issues or problems.

    Plugged in usb mouse/keyboard. Plugged in usb flash drive. Powered on holding Option key. Nothing happens. Just a white screen. Try again, same result. Try again, holding down C key, gives me an Internet Recovery box in centre screen to click on and below that, pick a wireless connection. Try again, same result.

    Plugging the USB flash key in a laptop shows it works no problem. But no matter even if i disassemble and swap drive positions, still nothing works.

    I'm not cloning anything because I have no files or anything to save or carry over. I'm guessing it's something with my 2 installed drives not having an OS on them, but they USB bootable flash key drive should take care of that. But doesn't.

    Is there an easier/ideal way to do this? I have the stock drive which is set up and running Mavericks.

    I just need to end up with my SSD formatted and a clean install of Mavericks. And my secondary installed HDD (not the stock one, but the new larger sized one) formatted for my music library.
     
  2. apfelmann macrumors 6502

    Joined:
    Jul 23, 2007
    #2
    I read somewhere probably on this forum that mavericks needs a special build for Mac Mini

    so maybe internet recovery or cloning the original drive are the only options
     
  3. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #3
    Did you try to boot the new Mavericks USB boot key right after you created it to see if it worked?
     
  4. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #4
    Nope, there was a special build of Mountain Lion for the 2012 Mini (12B2100) but it uses the stock version of Mavericks.
     
  5. famous600 macrumors 6502a

    famous600

    Joined:
    Apr 8, 2010
    #5
    I would plug Ethernet in. Boot holding command option R to go straight into internet recovery and try it that way.
     
  6. mmomega, May 23, 2014
    Last edited: May 23, 2014

    mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #6
    I had a similar problem back when the Samsung 830 SSD's came out and I had to format the SSD to anything, fat, ntfs, just any file system before my mac would see it.
    After that it was smooth sailing, ever since that one time, I have a USB -> Sata adaptor that I will format any new SSD with before installing and I haven't had a problem since.

    I just installed an 840 Pro 256GB + Samsung 1TB drive in my 2012 i7 mini and I'm waiting for Mavs to download to create a boot disk.
    Same configuration as yours, SSD on the bottom, HDD on top and it worked great in my i5 mini, just switching it over to the i7.

    If the Sammy SSD is brand new I would try formatting it somehow, it worked for me. Hope this helps.


    Final product will end up being
    2012 Mac Mini
    Intel Core i7 2.3GHz to 3.3Ghz TurboBoosted 6MB L3
    Intel HD4000 Graphics
    Corsair Vengeance 2x 8GB 1600MHz 1.5v 204pin RAM
    Samsung 256GB 840 Pro SSD + the stock Samsung/Seagate 1TB 5400rpm HDD Fusion'd
     

    Attached Files:

  7. mmomega, May 23, 2014
    Last edited: May 23, 2014

    mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #7
    Mine seems to be installing now.

    Doing nothing other than turning the Mini on , Holding Option, Booting from Mavericks USB Installer, entered Disk Utility and saw the SSD and HDD marked red.
    Clicked on the SSD and DiskUtility asked if I wanted to create a Fusion drive, I did, so it combined the drives (it asks to "fix" your system) and is now installing Mavericks.

    Been installing for 18 mins and estimates 2 minutes remaining.
     

    Attached Files:

Share This Page