Mac Mini, fans full, no display, no power button response

Discussion in 'Mac mini' started by scottystan, Jul 9, 2013.

  1. scottystan macrumors newbie

    Joined:
    Jul 9, 2013
    #1
    Hi, am new to the forum, I am a Microsoft Certified Technology Specialist, Systems Engineer and plan to take my ACMT exams in the not too distant future.
    I have a most infuriating and confusing problem with my mac mini A1283, (2009 @ 2.23GHz).
    Basically when I insert the power cable into this, the fan comes on full blast, (of it's own accord) and I get no display.
    I have no response from the power button either.
    Please bear in mind that the fans etc start as soon as charger is connected with no press of the power button. The only way to turn this off is to remove the charger.

    To reiterate, the fans start of their own accord as soon as charger is inserted, (no power button presses whatsoever).

    What I have tried:

    1)Reseated RAM
    2)Reset PRAM
    3)Reset SMC
    4)Removed internal battery to reset logic board
    5)Disconnected power button and shorted the pins, (no response)
    6)Reflowed the GPU as believe this model may be prone to GPU issues
    7)Reflowed processor as maybe CPU/GPU suffering heat related stress fractures in BGA solder.

    All the above have made zero difference whatsoever to this.
    I hate to admit defeat, (or don't want to admit I need a new logic board).
    But if anyone out there has any ideas or suggestions I would really appreciate some help.
    I am pretty handy with a soldering iron and am competent to repair the board down to component level.
    Wondering if this issue is symptomatic with a specific component failure on the logic board???

    PLEASE HELP
    Stan
     
  2. Omnius macrumors 6502a

    Joined:
    Jul 23, 2012
    #2
    My 2009 mini knowledge is fairly limited but that's a problem that I've never encountered before.

    Can you describe the circumstances surrounding this problem arising? I think you'd do well to look to electrical issues. As for the fans blasting, the usual culprit for such a problem is that the heat sensor is detached from the hard drive. I am hesitant to suggest that is the problem because you describe it as immediately powering on when plugged in. I almost want to say the power button might be jammed in but that doesn't make a lot of sense either.
     
  3. opinio macrumors 65816

    Joined:
    Mar 23, 2013
    #3
    Sound like a short somewhere on the logic board. Could be metallic based dust shorting a port or connector somewhere as well. You could try carefully vacuuming the external ports. Also check the fan connector and power connector on the logic board. Also check the Ram. Unlikely it is any of those but you never know. The mini will boot even if the fan is not connected so if the fan is reving high then it sounds like a logic board issue.
     
  4. scottystan thread starter macrumors newbie

    Joined:
    Jul 9, 2013
    #4
    Hi, thanks for the replies people. And suggestions also, I failed to mention that I have also completely cleaned the logic board and inside the casing and ports completely with isopropyl alcohol.
    Is a weird one and I don't want to give up on it, I want it REPAIRED as is now a personal challenge he he
     
  5. opinio macrumors 65816

    Joined:
    Mar 23, 2013
    #5
    Maybe you should have put a match to it when it was cleaned with alcohol :) Ooops how did that happen...

    Seriously though, it sounds like your LoBo has gone then. Short of trying different parts to eliminate the problem you have minimal chance of finding the actual issue if it is the LoBo. You might want to eye off the price of an entry level mini or refurb model. A complete mini is fairly close in price to a logic board purchase.
     
  6. Kebabselector macrumors 68030

    Kebabselector

    Joined:
    May 25, 2007
    Location:
    Birmingham, UK
    #6
    Fans running at full speed on the old Mac Mini usually was an indicator that the temp sensor at the front was not seated correctly. However all the excessive work on the MB might have caused further problems.

    I'd take out the memory and put them back in separately (assuming both slots are used).
     

Share This Page