Mac Mini Hard Drive Installation - Can't Recognize Seagate Momentus

Discussion in 'Mac mini' started by pokeydonut, Mar 7, 2009.

  1. pokeydonut macrumors newbie

    Joined:
    Apr 20, 2005
    #1
    Hi-

    My Mac Mini cannot recognize the Seagate 80GB Momentus that is inside it. It saw it for a little, and I went through the whole Leopard installation and then it said at the very end that it couldn't complete the installation and now when I try it can't see the drive at all.

    I tried reseating it - how come no one's talking about how there are four more pins on the seagate than there are ports on the mini. Isn't that a problem? Any advice for making sure the hard drive is in securely?
     
  2. OldMike macrumors 6502

    OldMike

    Joined:
    Mar 3, 2009
    Location:
    Dallas, TX
    #2
    I hate when things like this happen (funny, I thought it only happened to me). I find it odd that it was recognized and then could no longer be found.

    What extra pins are you speaking of? Does the drive also have a legacy molex connection, maybe that is what you are looking at? If so, it is just a different power connection for boards that don't have 15 pin Serial power.

    Do you have an external case to throw the Seagate in to see if it is still functioning properly? I would crack open the mini, throw the old drive in and be sure it still works. At the same time I would try to run the Seagate on its own. If you have a PC also, maybe you could throw it in there just to verify that the drive is ok.

    Out of hundreds of drive installations, I have had drives die on me shortly after installation a couple of times. Although unlikely, it is a possibility.

    Keep us up to date, and let us know how it goes...

    Good Luck!
     
  3. pokeydonut thread starter macrumors newbie

    Joined:
    Apr 20, 2005
    #3
    So I'd written off the internal hard drive of the Mini entirely and partitioned an external hard drive to include a 10GB partition for the leopard installer and a 220GB partition where I installed Leopard and have been booting off that partition and just decided the internal hard drive was a lost cause.

    Well last night I was trying to improve the range of the Bluetooth on the mini (which sucks, by the way) so I turned the Mini so it was sitting on it's front and its top with the apple on it was facing me. Suddenly, Macintosh HD shows up in the Finder sidebar. I tried to install Leopard on it from the Firewire drive and it hung on "Calculating: Time Remaining" and then told me I had to restart.

    It still showed the internal hard drive in the Finder for a while longer but after a while it disappeared again. Any idea what makes a Mini intermittently recognize a hard drive? Obviously it's a hardware issue but I opened it up and it looks to be in there tight. Does anyone have any advice regarding seating this hard drive super-tightly so it stays recognized? Would a dead hard drive or dead logic board result in this sort of on-again, off-again recognition?
     
  4. tobyg macrumors 6502a

    Joined:
    Aug 31, 2004
    #4
    As far as the extra pins, I'm guessing the OP is using an IDE/PATA drive and is referring to the fact that not only does the drive have 44 pins instead of 40 pins as the power is part of the same connector as the data, there are usually 4 extra pins (row of 2x2) that are used to set master/slave/cs configuration on those 2.5" drives.

    Ignore those pins, unless you think you set it wrong. I don't have an old mini but I suspect if you didn't change anything, the drive is set how it should be. There may be a jumper on them, there may be no jumper at all. If you changed the drive, you may need to set it appropriately. I'm not sure what the Mini wants it set to, but probably master or cable select.

    http://www.pcstats.com/articleimages/200609/supertalentFIDE8GB_pins.jpg

    The 40 (39 in this case, as one is removed for keying) pins on the left side are the data. The 4 directly in line with the 40, just to the right, are the power. And the 4 off to the right side by themselves are the master/slave/cable select pins for jumpering whatever setting you need.
     

Share This Page