Mac mini @ instead of "

Discussion in 'Mac mini' started by KezN, Dec 28, 2014.

  1. KezN macrumors newbie

    Joined:
    Dec 24, 2014
    #1
    I am slowly getting to grips with my new mac mini, but have an issue with the keyboard typing @ instead of ". I have tried altering the settings under keyboards to see if using a different country makes any difference, but it doesn't. Could anyone explain how to resolve this issue? Many thanks.
     
  2. bubbleboil macrumors member

    Joined:
    Apr 19, 2014
  3. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #3
    ROFL

    is there any chance your mac was replaced with a TRS-80 ?????

    the trs-80 had a " where the @ normally used to be, which totally explains your problem!!!!!

    [​IMG]

    ----------

    the commidore 64 also had a " where the @ supposed to be
     
  4. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #4
    the @ and " are switched in UK keyboards, compared to america


    mac is misidentifying the keyboard. do not know how to fix.

    when i plug in a keyboard the mac doesn't know about, it asks me to press the keys immediately to the right of the left shift key and immediately left to the right shift key.

    i don't know how to get that screen up manually.
    that would fix your issue.
     
  5. rigormortis, Dec 28, 2014
    Last edited: Dec 28, 2014

    rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #5
    have you tried this?

    ----

    instructions
    1
    Disconnect the external keyboard from the computer's USB port.

    2
    Click the "Finder" icon in the computer's dock, then click the hard drive icon beneath the "Devices" heading.

    3
    Click the "Library" folder icon, followed by the "Preferences" folder icon.

    4
    Click on the file named "com.apple.keyboardtype.plist" and drag the file onto the "Trash" icon in the computer's dock.

    5
    empty trash

    6
    Reconnect the keyboard to the computer's USB port. The Keyboard Setup Assistant will launch automatically. Follow the onscreen instructions to set up the keyboard.
     
  6. dogbertd macrumors newbie

    dogbertd

    Joined:
    Nov 10, 2011
    Location:
    Dundee, Scotland, UK
    #6
    Did you try the "British-PC" keyboard setting? This is a problem I have every time I upgrade, and it's because Apple US keyboards have a subtly different layout to UK keyboards. It's best to use the one called "British-PC".
     
  7. KezN thread starter macrumors newbie

    Joined:
    Dec 24, 2014
    #7
    Thanks everyone for your input.

    Re keyboard type yes I had tried British-PC with no success.

    I have just tried deleting the "com.apple.keyboardtype.plist" file but had problems: firstly there is no hard disk listed under devices but I did manage in a round about way to find the library folder and then preferences. I moved the file to trash but it asked for my password to move it so I had to plug the keyboard back in. I then unplugged it and tried to trash the file but it said that the keyboard was in use. Any suggestions as to what I can do next?

    Many thanks.

    ----------

    No I am just running mac but using an ordinary keyboard as I don't like mac keyboards.
     
  8. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #8
    When asked for your password when deleting the plist file, use the built in on-screen virtual keyboard.
     
  9. tennisproha macrumors 6502a

    Joined:
    Jun 24, 2011
    Location:
    Texas
    #9
    disable your password?
     
  10. KezN thread starter macrumors newbie

    Joined:
    Dec 24, 2014
    #10
    Thanks for the pointer. I have done that but the keyboard setup didn't appear and the keyboard still isn't working correctly. :confused:
     
  11. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #11
    Are you saying that when you follow the instructions on the link I supplied that you do not get the virtual keyboard icon up in your top menu-bar?
    That would be really odd.:confused:
     
  12. KezN thread starter macrumors newbie

    Joined:
    Dec 24, 2014
    #12
    Sorry my explanation wasn't very good. I got the virtual keyboard and used that. I deleted the file and then put the the keyboard usb back in but it didn't run the set up keyboard option though the keyboard worked. :confused:
     
  13. dyt1983, Dec 28, 2014
    Last edited: Jun 1, 2015

    dyt1983 macrumors 65816

    Joined:
    May 6, 2014
    Location:
    USA USA USA
    #13
    edit: To remove personally identifying info not relevant to the conversation.
     
  14. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #14
    Looks like a handy little application, thanks for pointing it out.
     
  15. KezN thread starter macrumors newbie

    Joined:
    Dec 24, 2014
    #15
    Thanks for the suggestion. I shall look that up tomorrow.
     
  16. Beachguy macrumors 6502a

    Beachguy

    Joined:
    Nov 23, 2011
    #16
    The lack of insert and delete (not backspace-and-delete) drives me batty since I sometimes must connect to systems that are not Apple.
     
  17. KezN thread starter macrumors newbie

    Joined:
    Dec 24, 2014
    #17
    Works a treat! Thank you! @" :)
     

Share This Page