Mac mini is toast but i'd like my CD back, please help!

Discussion in 'Mac mini' started by Kurfer, Sep 30, 2009.

  1. Kurfer macrumors regular

    Kurfer

    Joined:
    Mar 13, 2008
    #1
    Well I went to install Snow Leopard and it said it couldn't install because of some GUID error on the drive. My Mac mini has worked fine ever since...I cancel the install and everything is good.

    After a system update my mini rebooted and now is stuck in a constant rebooting state.

    I see grey screen, then folder with ? in it, then apple logo with spinning wheel and it reboots/repeats.

    It doesn't respond to me pressing the C key during startup, I also tried command-option-o-f and nothing.

    How do I get my snow leopard cd out of the drive safely? I am willing to destroy the mini in the process, I figure it's ****ed anyway so I just want my god damned CD back. :(
     
  2. electroshock macrumors 6502a

    electroshock

    Joined:
    Sep 7, 2009
    #2
    It's an Intel Mac Mini? I don't think cmd-o-f works on Intel Macs, only PowerPC-based Macs.

    Try holding down the mouse button then power on the Mini and see if it ejects. (If it's a 2 or 3 button mouse, hold down the left button, I think??)

    Another option: try holding down the Alt key to see if you get a boot selector screen.

    If no dice, you CAN take apart the Mini and partially disassemble the DVD drive and remove the CD, then put stuff back together without any damage to anything. I've done it a couple of times with the Mini. Takes about 25 minutes from start to finish.

    Once you get the CD working again, the first thing you do is head straight to Disk Utility (while booted off the CD, not the hard drive!) then do a 'Repair Disk' to clean up any logical damage before trying anything else with the OS.
     
  3. Kurfer thread starter macrumors regular

    Kurfer

    Joined:
    Mar 13, 2008
    #3
    What a piece of junk, would it have killed them to put an eject button on this thing? Wow!!!

    This mini is fubar, it doesn't respond to ANY keyboard commands and the mouse button trick does not work. I can only assume it's hosed...

    I have not gotten my money's worth of enjoyment out of this junk yet so I think i'm going to see how far I can throw it and what it looks like after it lands.
     
  4. j2048b macrumors 6502a

    Joined:
    Feb 18, 2009
    Location:
    Cali
    #4

    dont throw it!! sell it to me for a good price!!

    it is proably either the pwer supply/ or the hard drive?
     
  5. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #5
    Well, this is a feature on some Macs, though I've only seen it used on older, pre intel and OSX macs. Near the DVD drive slit is there a tiny hole? If there is you can straighten a paper clip and push it into the hole until the DVD pops out... :D

    I've done it on older Macs, its a nice feature, designed for a physical force-removal of a DVD/CD in the computer.:cool:

    I'd be easy if it had a disk tray, just pry out the tray... :(
     
  6. SchneiderMan macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
    #6
    Maybe an apple store can help you, you never know even if its out of warranty.
     
  7. nullx86 macrumors 6502a

    nullx86

    Joined:
    Jun 26, 2009
    Location:
    Wilmington/Jacksonville, NC
    #7
    pop off the casing and look at the front of the dvd drive. there should be a button to push (magic eject button :D)... If not you can always partially disassemble the DVD drive, or plug it into another computer (assuming that its sata)
     
  8. three macrumors 6502a

    three

    Joined:
    Jan 22, 2008
    Location:
    Washington State
    #8
    I've looked long and hard for a magic eject button on my Mac mini, and I couldn't find one. CD's constantly get stuck in my drive since my combo drive is broken and will freeze OS X when it's burning / reading. I plug in another keyboard and hold down F12 (Eject) and it will eventually pop out.
     
  9. Mariusz1977 macrumors member

    Mariusz1977

    Joined:
    Nov 21, 2008
    #9
    Did you hold the mouse button down for awhile when rebooting? It sometimes takes 5-10 seconds to spit out the CD when you do this.
     
  10. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #10
    Your machine isn't broken, it just can't install on a apple partition map... If your mini is indeed Intel, you just need to launch disk utility (from the SL install DVD), and create a new partition, then click Options... and choose GUID instead of Apple Partition Map.

    After it has formatted the drive, it will install.
     
  11. nullx86 macrumors 6502a

    nullx86

    Joined:
    Jun 26, 2009
    Location:
    Wilmington/Jacksonville, NC
    #11
    QFT. Intel macs cant install via APM, has to be GUID. If you want the disk to get out, Hold Option on boot, then mash the eject key on your apple keyboard. I did this by accident today and it worked.
     

Share This Page