Mac Mini, iTunes, and 5.1 Output Frustration

Discussion in 'Mac mini' started by Type4O, Jan 17, 2014.

  1. Type4O macrumors regular

    Joined:
    Aug 23, 2011
    Location:
    Toronto, Canada
    #1
    I have a brand new Mac Mini and an exoense Bose surround sound system (Lifestyle V20). The Mini is plugged in via HDMI and in the System Preferences in OSX it knows what Bose I have. In the Midi settings app, it refuses to allow me to set the HDMI has having 5.1 channels. That's the first problem.

    Secondly, is there a way to tell iTunes to always play the mutichannel (AC3) track. It seems idiotic to me that you buy a 1080HD video from iTunes, and you have to change what track you want on every video as you start to play it.

    Thirdly, iTunes craps out half the time when I try to change the track to the AC3 one. It starts to play, and I the screen blanks, then flickers back on. I change the track to the AC3 one and the screen goes off again and eventually comes back on then the video plays a bit without sound then everything goes black.

    I have to say, considering how user friendly Apple usually is, this is absurdly frustrating to set up. I know the Bose works because we also have our cable box plugged in via HDMI and it works perfectly fine.

    Please, does anyone have any helpful suggestions?

    Thanks
     
  2. niteflyr, Jan 18, 2014
    Last edited: Jan 18, 2014

    niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #2
    I think the first 2 issues are related. iTunes doesn't see a 5.1 connection so it defaults to stereo. I have an older Bose Lifestyle system and I had trouble getting my DVR to play 5.1 thru the Bose. I ended up connecting a digital/optical cable from DVR to the Bose also and that got it working in 5.1. I can't tell you why that worked, but it does for me. The Mac mini's audio out supports digital/optical. You might give that a try. You'll probably need a Toslink mini adaptor to get optical cable connected from mini to the Bose. Something like this:

    http://www.amazon.com/Cables-Go-270...0081489&sr=8-16&keywords=mini+toslink+adapter
     
  3. Type4O thread starter macrumors regular

    Joined:
    Aug 23, 2011
    Location:
    Toronto, Canada
    #3
    Yeah, I had my old Mac Mini hooked up with an optical cable. I was hoping the fact that the new Mini had a built in HDMI meant I wouldn't need the extra audio cable anymore.

    As far as defaulting to the stereo track, I keep reading that you can change the default language for playback in iTunes on the playback tab, but there is no such setting.

    It's very annoying buying HD videos from iTunes only to have to put up with this nonsense. It's a shame VLC can't play video bought through iTunes; at least that forces detection of 5.1.
     
  4. QWERTYMac7 macrumors regular

    Joined:
    Nov 20, 2012
    #4
    iTunes > Preferences > Playback . Audio Language & Subtitle Language
     
  5. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #5
    No such setting option in my iTunes > pref's > playback tab either. Must be referring to an older version of iTunes.
     
  6. QWERTYMac7 macrumors regular

    Joined:
    Nov 20, 2012
    #6
    11.1.3

    Latest version.
     
  7. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #7
    11.1.3 here. Odd.
     

    Attached Files:

  8. QWERTYMac7 macrumors regular

    Joined:
    Nov 20, 2012
  9. obiwan macrumors regular

    Joined:
    Jun 7, 2004
    #9
    I have this same issue. Although in older versions of iTunes once you had selected the 5.1 Surround soundtrack, it would remember your selection next time you played the movie. I therefore went through all my movies and selected the surround sound track, and this sorted the issue. However in the latest version (11.3) iTunes defaults to playing the Stereo Soundtrack each time, and I have to manually select the 'AC3 Audio' track every time.

    I think there is a setting on the AppleTV to default to playing AC3 audio if it finds a movie with a surround audio track, but in iTunes, no setting like this exists.

    I suspect it is another ploy by Apple to get you to buy an AppleTV instead of using a Mac Mini as a media player. Remember Front Row? Now that's been ditched, it seems like Apple is slowly making it more difficult to play 5.1 Audio through iTunes too.
     
  10. ebernet macrumors newbie

    Joined:
    Apr 5, 2005
    Location:
    Seattle, WA
    #10
    iTunes 12.3 with El Capitan now plays 5.1 audio from files I've created out through the optical out to my surround speakers. This is the 1st time it has ever done this with anything, after years and years of hoping and needing to use VLC. Very exciting. This is a game changer...
     
  11. IronWaffle macrumors 6502

    IronWaffle

    #11
    I've been trying to get my Mac mini (2012) to output to 5.1 with no luck. Maybe someone who has it working can lend a hand?

    Here are the details of my setup that I think are relevant:

    Mac mini -> UHDTV (as monitor) via HDMI -> Pioneer SC-1522 A/V receiver -> 7.1 speaker configuration.

    With that, the sound is very thin. If I use Dolby's fake-surround up mix modes then there's still no activity in the subwoofer. I've tried music as well as Star Wars TFA 1080p in iTunes. No luck.

    But wait, there's more!

    I've tried THREE alternate chains, neither of which worked:

    Mac -> Arcam USB DAC -> Receiver

    Mac -> Receiver (via AirPlay)

    Mac -> TV 3 (via AirPlay) -> Receiver (via HDMI)

    All of them sound the same: the tinniest 2.0.

    Now, what's odd is that last one because my TV has no problems producing 5.1 via AirPlay (or HDMI) when playing Netflix, HBO, etc. It only lacks when streaming from my Mac's iTunes library.

    So, I did some research and went into Audio setup. According to that, all the non-stereo options are grayed-out as if I had only a 2.0 system.

    I'm tempted to buy a TOSLINK -> 3.5 mm cable and see if that works (as it did for you) but since those FOUR methods didn't work, I'm skeptical.

    I spent a lot of time on a chat with Apple. Once we got past comments that this sounded like a "pro problem" and "contact the receiver manufacturer" we began to test some things out. Unfortunately, only one significant test was completed before our chat/shared screen session quit. That test was creating a new user and testing there. Same problem. His next top was to backup the Mac and do a factory restore to see what happens.

    I can do that, but I'm open to other suggestions here and maybe some audiophile forums.

    Any ideas? If not, well, wish me luck (if you got this far down tl;dr lane). What a frustrating day!
     
  12. Crosscreek macrumors 68030

    Crosscreek

    Joined:
    Nov 19, 2013
    Location:
    Margarittaville
    #12
    That the only way to get it to work.
     
  13. IronWaffle macrumors 6502

    IronWaffle

    #13
    Thanks!

    The Apple tech I spoke with earlier today thinks it won't work. His reasoning, I believe, was in large part because in "Audio MIDI Setup" all my multichannel options are grayed out. In your experience did that matter?

    Interestingly, by drilling down in my Pioneer receiver's settings this morning I learned that its "Extended Stereo" mode restores subwoofer activity. Unlike most DSP it doesn't seem to monkey around too much with the mix; it seems to just replicate the fronts in the surrounds at a lower volume. None of the Dolby or DTS DSPs had that positive effect and yet they had all the weird (and arguably negative) effects on sound quality.

    I'm supposed to speak with the tech again tomorrow and he may pass this along to engineers. Who knows what will come of it. My little workaround is fine for the time being.

    I've thrown lots of money into my graveyard of useless cables, so I imagine eventually I'll give TOSLINK a try -- especially if others' have gotten it working despite the Audio MIDI grayed-out options.
     
  14. Crosscreek, Apr 12, 2016
    Last edited: Apr 12, 2016

    Crosscreek macrumors 68030

    Crosscreek

    Joined:
    Nov 19, 2013
    Location:
    Margarittaville
    #14
    I have a Pioneer receiver also and used TOSLINK to it and worked fine. I bought mine from Monoprice and make sure when you plug it in that it's in all the way in the audio jack. Make sure you can see the light coming out the end of you cable after plugging in. If you don't see it reseat the audio plug in all the way to activate the light source. My 2012 took some effort to bottom it out. I think you will see those greyed out areas activated once you get it plugged in to your optical port on your receiver.
     
  15. IronWaffle, Apr 13, 2016
    Last edited: Apr 13, 2016

    IronWaffle macrumors 6502

    IronWaffle

    #15
    Thanks for the details. It was enough to get me to give it a shot. The cable should arrive by tonight. First I'll see if it works with my rDAC external DAC; if not I'll go straight to the receiver. After that, if it doesn't work: a deep, mournful sigh. If it dies work: I'll melt into sound.

    Fingers-crossed it'll work. If not, Apple's got a laundry list of onerous things to try to make it "just work."
     
  16. Crosscreek macrumors 68030

    Crosscreek

    Joined:
    Nov 19, 2013
    Location:
    Margarittaville
    #16
    lol That's Apples motto......It Just Works :rolleyes: Good luck.
     
  17. IronWaffle macrumors 6502

    IronWaffle

    #17
    I haven't had an Apple product that just worked since my last iOS 6 device

    True to form, after placing the order I dug around even more on the ol' Internet and found that there is a setting in my receiver that pushes LFE from stereo with even less processing. For those in the future who may stumble into this thread, I switched my subwoofer's setting from "Yes" to "Plus" and now it sounds much better. Well, a bit too boomy but a little volume tweaking on the sub did the trick. That said, that receiver tweak can't fix the surround issue. I rarely use my Mac for video that supports 5.1 but it'll be nice to have it working.

    While odds are that I won't need the cable for my main use, which was making my stereo sound like stereo instead of the external speaker of an iPhone that fell down a well[/hyperbole]. Another upshot is I learned that this cable will allow me to listen to 24-bit files with better fidelity than I do now. I don't have many of those, but it's still a plus.
     

Share This Page