Mac Mini - iTunes Movie Stutter?

Discussion in 'Mac mini' started by thebreadking, Apr 5, 2009.

  1. thebreadking macrumors member

    Joined:
    Nov 26, 2008
    #1
    Hi there, I was hoping you could help me with this conundrum.

    I recently picked up the new Mini (edit: 2.0GHz), and upgraded it with 4gigs of RAM and a 7200RPM HDD, which has been running great through both heavy Photoshop work and the usual normal stuff.

    HOWEVER, whenever I rent a movie from iTunes it skips (or drops?) frames every couple of minutes throughout the entire thing, and these are SD movies! I don't have a problem with 480p online video, or the online 1080p Quicktime HD videos, or my own personal ripped DVDs, but for some reason, all three movies I've rented from iTunes so far have had this problem. I haven't purchased any movies from iTunes, so I can't say if they would have the same effect.

    Is there something I'm missing, or are the iTunes movies just poorly encoded? I look forward to your help!
     
  2. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    You shouldn't have that problem. What I suggest is get in contact with iTunes online support and explain the problem. They might be able to guide you through getting it to work, if not, they will offer you a refund. No point in paying for something if it doesn't work.

    (You might want to try it in a new user)
     
  3. thebreadking thread starter macrumors member

    Joined:
    Nov 26, 2008
    #3
    Thanks for the response. If I contact them, and because I upgraded the RAM and HDD myself, how do I go about addressing that topic? Or do I revert it back to factory specs, rent a movie to check, and go from there? Thanks again.
     
  4. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #4
    That would be best. Get everything back to it's default state and then try it from there.
     

Share This Page