Mac Mini late 2012 no power fan not spinning. Nothing.

dikemee11

macrumors newbie
Original poster
Mar 6, 2014
2
0
Well, not nothing. If I tear apart the whole machine, disconnect the power supply from the logic board and put the machine back together. The mini boots up with out me pressing the power button the fan will spin and run. There is no boot up sound. It ran for 45 minutes once, and roughly 15 another time.

I have tried an SMC reset, re-seating literally everything multiple times. Is there any chance it is the power supply? I know it is likely the logic board, but was curious if anybody has had any similar experiences, and or advice. It was working fine last night, and today this!

Thanks in advance!:)
 

dikemee11

macrumors newbie
Original poster
Mar 6, 2014
2
0
Can I?

The issue is I have added a second hard drive, and taken it apart multiple times. Will Apple still service it under warranty?
 

chrfr

macrumors G3
Jul 11, 2009
8,292
2,589
The issue is I have added a second hard drive, and taken it apart multiple times. Will Apple still service it under warranty?
Apple will probably discover that you've damaged something on the board. I'd start by restoring it to original configuration and letting them check it out.
 

panzer06

macrumors 68040
Sep 23, 2006
3,016
71
Kilrath
The issue is I have added a second hard drive, and taken it apart multiple times. Will Apple still service it under warranty?
As long as you did not break anything it should be fine. Also, many Apple authorized service centers will perform warranty work without question.

Cheers,