Mac Mini & "Mode Not Supported"

Discussion in 'Mac mini' started by Everborne, Jan 21, 2012.

  1. Everborne macrumors newbie

    Joined:
    Mar 31, 2009
    #1
    Hey guys,

    I've just bought a Mac Mini, and I connected it to a Samsung TV screen with an HDMI cable. I turned on the Mac Mini, only to get the "Mode Not Supported" message on my TV screen. After some googling, I realized that the problem might be with the resolution, and the Samsung's inability to handle it. I tried booting up the Mac Mini in Safe Mode (using a Windows, USB keyboard), but nothing happened. The same goes for trying to boot up in Single User Mode.

    Any help would be useful, I'd really like to get my Mac Mini working!
     
  2. omenamato macrumors newbie

    Joined:
    Oct 7, 2005
    #2
    I had the same problem

    Hi

    Put the cable to hdmi/dvi and go to tv's menu and from source and change the ports name or what ever it's called to dvi pc(or something similar). I can't remember the names exactly but it worked with my pc laptop.
     
  3. Everborne thread starter macrumors newbie

    Joined:
    Mar 31, 2009
    #3
    When I tried to change the port's name, the closest option I could find to what you suggested was simply "PC". That didn't work, though :(

    EDIT: This monitor has worked fine with a Sony Vaio before, if that helps.
     
  4. MadDragon1846 macrumors regular

    Joined:
    Mar 23, 2011
    #4
    If you still have a screen to plug it into that can display the picture, maybe you could plug your mini into that, change the screen res to something that your tv can definitely use (something like 800x600 should do. you can make it higher after), then plug it in to your tv and see if that'll work. (thats how I'v fixed the problem in the past with PCs that use dvi. I haven't tried it with a mini with hdmi, so I dunno if it tries to auto-select the screen res when plugged in or not. Worth a try though :D).
     
  5. Everborne thread starter macrumors newbie

    Joined:
    Mar 31, 2009
    #5
    Unfortunately I don't have any spare screens to try what you've suggested :(
     
  6. electrolux76 macrumors member

    Joined:
    Oct 30, 2008
    Location:
    NY,NY
    #6
    Do you have another mac in the house? Or a friend with a mac laptop. If so you can do one of two things:

    •Boot up the mini and then try to connect to it via Screen Sharing from the 2nd Mac and experiment with different resolutions.

    If that doesn't work you could........

    •Connect the display to the second mac (laptop or iMac - must have it's own display.)
    •boot the mini into target disk mode (boot while holding T).
    •Use the Mini as the second Mac's boot device. (connect via firewire and option boot the 2nd mac)
    •While booted from the mini, change the resolution till you have an image on your TV and set the TV as the primary display.
    •Shut everything down
    •Reconnect the mini to the TV and boot it up
     
  7. MadDragon1846 macrumors regular

    Joined:
    Mar 23, 2011
    #7
    Right, well I have done a bit of googling, and found a way that "might" work. (I can't go on my mac at the moment, to test this).

    First start your mac in safe mode, which "should" (again I can't test this at the mo) let you see what you are doing on your monitor. (link shows you how if you don't know): http://support.apple.com/kb/HT1455

    Then this thread shows how to change your screen res: https://discussions.apple.com/thread/1705055?start=0&tstart=0

    Heres the useful posts from there:

    Restart the Mac and immediately hold down the Shift key to start up in Safe Mode. Once you're at the desktop, go to the Preferences folder in your user account and delete the file:

    com.apple.systempreferences.plist

    Restart normally. The file you remove holds various settings, so you'll have to check through the other fields in the System Preferences and reset anything that was not the default.


    That apparently didn't work, but it tells you where 1 file is that "may" need deleting.

    Then:

    Depending, you may also have prefs in...

    /Users/YourUserName/Library/Preferences/ByHost/

    that affect that.


    That seemed to fix the problem for the original poster on that thread, so hopefully that'll work for you too. :)
     
  8. Everborne thread starter macrumors newbie

    Joined:
    Mar 31, 2009
    #8
    @electrolux76: I've got a Macbook, so how do I connect that to the Mini via Screen Sharing?

    @MadDragon1846: I've tried starting the mac in safe mode, but nothing shows up on the monitor, so I can't see anything at all.
     
  9. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #9
    If you don't have Screen Sharing enabled on the Mini, you can't. You need to borrow a monitor to use temporarily to change the Mini's resolution. That's about the only option you have.
     
  10. MadDragon1846, Jan 24, 2012
    Last edited: Jan 24, 2012

    MadDragon1846 macrumors regular

    Joined:
    Mar 23, 2011
    #10
    Well, after a good while, I have figured out how to change the screen res with only the keyboard! :D

    You'll need to do this exact because you'll be changing the screen res without seeing what you are doing. :D (you also need to use an apple keyboard, I'd assume).

    Start up your mini, wait until it's fully loaded up and is sitting at your desktop (you of corse can't see, so just wait a couple of mins to make sure :p)

    Now hold the option key and then press one of the screen brightness keys, just once, no need to hold it.(you can let go of the option key now :p) (the brightness key has a little sun on it). That will open up the display settings!

    Now press the tab key once, and that will highlight the top (highest) screen res setting.

    Now just press the down key a few times to lower the screen res!

    For my monitor, it starts at 1080p at the top, and I have to press down 8 times to get to a screen res of 1024x768, which most modern TVs can support. (note. it takes a few seconds to change the screen res each time you press the down key. So each time you press down, wait like 10 seconds before pressing down again.)

    If theres still no picture after doing that, then screen res isn't the problem. Maybe it's what the refresh rate is set to.

    *edit*
    I'm assuming the mini is new, and doesn't have any windows open and active when you turn it on. (from you saying you just bought it)

    If it isn't new, and may have some open active windows, Then pressing cmd+q a few times should close them.
     
  11. Everborne thread starter macrumors newbie

    Joined:
    Mar 31, 2009
    #11
    @MadDragon1846: That's super helpful, and yes the mac mini is brand new! I've only got a Windows keyboard though, so shall try to figure out what the equivalent commands would be on it!
     
  12. MadDragon1846, Jan 25, 2012
    Last edited: Jan 25, 2012

    MadDragon1846 macrumors regular

    Joined:
    Mar 23, 2011
    #12
    I know that the option key on a windows keyboard is the alt key.

    The brightness key on the apple keyboard is F2, so I guess it's the same on the windows keyboard. I'll try plugging a windows keyboard and find out.

    I'll edit this post in a bit after testing.

    *edit*
    Hmm, sorry to be the bringer of bad news, but I tried all the F keys on my windows keyboard with no success. :(

    Also, I was thinking, if it's completely brand new, and hasnt been set up yet, then you'll need to go through all the setup things, like naming the mini, choosing a login name, etc. :(

    I'll see if theres any other way to change the screen res. (running out of ideas though lol).

    *edit 2*
    I can only think of 2 other options at the moment. 1 is if you have a dvi cable, you could try the hdmi to dvi adapter, that comes with the mini. I dunno if that'd make a difference though, so I wouldn't rush out and buy a cable if you haven't already got 1. (theres an adapter for vga you can buy, but reading the comments about it, it doesn't work on Samsung TVs. Not sure why.)

    And the other option is to either go round a mates house and hook your mini up to their monitor, or pop down the nearest apple store, and get it set up there. (remembering to change the res after going through the setup! Lol).

    If I come across any other random info on changing screen res, meanwhile. I'll let you know.
     
  13. MadDragon1846 macrumors regular

    Joined:
    Mar 23, 2011
    #13
    I'v been looking up electrolux76's suggestion, and I think that will work. I have copied his steps and posted a bit more detail under each step (this is info I got while researching. I haven't got a macbook to test these steps, but I think what I'v typed, is correct lol)

    •Connect the display to the second mac (laptop or iMac - must have it's own display.)
    Have your macbook pro up and running (and updated), and your mac mini turned off (have the keyboard, mouse, and TV plugged in to your mini). Then connect your mini to your macbook, with a firewire cable.

    •boot the mini into target disk mode (boot while holding T).
    Turn on the mini and straight away press and hold the T key on your mini's keyboard. After awhile you'd see a firewire symbol on your monitor, but of corse you won't in your case... I don't know how long it takes, I saw a video on youtube of someone doing that, but they fast forwarded that part of the video, so I'd hold the T key for a min or 2 to make sure.

    •Use the Mini as the second Mac's boot device. (connect via firewire and option boot the 2nd mac)
    Now restart your macbook and hold the option key (alt key in your case), and then select your mini's hdd as the boot device.

    •While booted from the mini, change the resolution till you have an image on your TV and set the TV as the primary display.
    By this step I assume you should see the mini's setup options on your macbook's screen. So go ahead and set up your mini, then go to the display settings, and change the screen res to something like 1024x768, and select your TV as the primary monitor (You'll probably need the TV on for it to be an option).

    •Shut everything down
    Does what it sais on the tin lol

    •Reconnect the mini to the TV and boot it up
    I assume you need the TV connected to your mini from the start or else you wouldn't have the TV as an option as the primary monitor. So for this step, just unplug the firewire cable from the mini, and start the mini up and hopefully it'll be working on the TV.
     
  14. electrolux76 macrumors member

    Joined:
    Oct 30, 2008
    Location:
    NY,NY
    #14
    Hi,
    Sorry, I've been away from the forums for a few days. MadDragon1846, thanks for picking up my slack. Everything in your more detailed post was spot on, except for one important thing. The TV should be hooked up to the MacBook while you're booting the macbook using the Mini's disk as your startup device. This way you're running a dual monitor set up and even if the TV dosen't display anything at start up, you still have the MacBooks's display to make adjustments. Once you find a setting that works that change will be saved to the mini's drive (b/c it's the boot device) and that setting should remain once the mini is shut down, the tv disconnected from the MacBook, connected to the mini and rebooted normally.
    If the TV remains connected to the mini durring the target disk mode it will not display anything except maybe a grey screen with a firewire logo. When in target disk mode, the mini is basically an external firewire disk.

    Also, unrelated to the above, Have you tried doing a "restore to factory defaults on the TV?" We've spent a lot of time in this thread talking about solutions on the Mac side of things and not alot of time thinking about the TV. Before you go through the whole target disk mode booting thing, you may want to spend some time really going deep through your TV menu and maybe even doing a restore to default. I know you said you had another machine hooked to the tv and it worked fine, but you never know. I think it's worth a shot.
     
  15. Everborne thread starter macrumors newbie

    Joined:
    Mar 31, 2009
    #15
    Hey guys, thanks for all the help so far!

    My dad saw fit to simply buy a new monitor to try to solve the problem, so he got a Samsung Syncmaster S20B300. Problem is, now when I connect this to the Mini, I don't get anything at all, not even a "mode not supported". The monitor does work fine with a Sony Vaio, though, which is strange. The mini and the monitor are connected via a HDMI-DVI cable, as the monitor only has DVI and RGB inputs.

    Trying to solve this new problem :(
     
  16. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #16
    Your Mini might actually be DOA if neither display works. However, reboot and hold Cmd-Opt-P-R (Win-Alt-P-R on a Windows keyboard, I think) at the chime (keep holding until it chimes twice) to reset the PRAM, which from memory also resets the default resolution.
     
  17. Wohsurdaddy macrumors newbie

    Joined:
    Aug 12, 2014
    #17
    This worked for me with one exception. I had to arrow up not down to get to a suitable resolution. Thank you so much for the tips. Mini Mac OS Mavericks 10.9.4 on a sylvania 37in LCD TV with HDMi connection and an apple keyboard.
     

Share This Page