Mac Mini mystery

Discussion in 'Mac Basics and Help' started by nucircle, Oct 18, 2009.

  1. nucircle macrumors newbie

    Joined:
    Oct 18, 2009
    #1
    Mac Mini Intel Core 2 Duo 1.83GHz, no hardware changes since purhcased, a year and 4 months ago. OS 10.5.6. I come back to the office and it's frozen. When I try to restart, it gets stuck on the grey apple screen (no wheel underneath either). I did the following:

    • Disconnected all peripherals
    • Reset PRAM
    • Reset SMU (I even tried the PMU reset, which results in the fan spinning at max speed)
    • Holding the option key correctly invokes boot disk options, but no choice works (as explained next)
    • Tried booting up from DVD
    • Tried booting up from external firewire drive
    • Set it in target mode and verified via firewire that the internal drive is working fine (I checked it with Disk Utility with no errors found and even booted up from it). In this mode even the DVD in the Mini's drive showed up on the other computer's desktop and it's perfectly bootable
    • Reseated the RAM
    • Replaced the RAM
    • Booting in single-user mode ends up here: http://nucircle.com/mini.JPG
    • Tried to restore firmware, but no-go (DVD spins up but no progress)
    • Disconnected internal HD to force other boot-up disks to engage
    • Tried another power supply from an identical model
    • Re-applied 10.5.6 update in target mode
    • Ran hardware test - everything checks out fine

    Before I contemplate more drastic measure (like retiring it), is there anything I haven't done? I appreciate any help.
     
  2. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #2
    No wheel spinning indicates that there's a problem booting the kernel. What you can do is restart the Mac while holding down "command" + "v" on the keyboard. When it boots, it will show lines of code on the screen -- essentially these lines of code are what your Mac is secretly doing in the background when you turn it on.

    Watch the lines of code until it stops and freezes. Take note of any errors and/or take note of what the last line of code said. Usually, you can tell what might be causing the problem by looking at that code. It might just be a bad file or extension that needs to be removed. Or it could be the hard drive is failing.
     
  3. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    You didn't read through the steps taken, ziggyonice--the OP even posted a photo of where it stalls when booted in single user mode. Which, from the looks of it, is a kernel panic most of the way through the boot process, around I/O initialization (though I admit to not being able to read boot logs very well).

    The fact that it won't boot from the optical drive, but the hard drive WILL boot another Mac pretty much rules out data corruption on the drive itself. A failing drive can prevent booting from the optical drive--I've seen it happen personally--but then you wouldn't expect it to boot another machine properly.

    Now, you're saying it WILL boot into hardware test, but won't boot an OS install optical disk, right? That means that the CPU/motherboard aren't totally dead, and really it sounds like there is some piece of hardware that's not getting checked (at all, I suppose) by AHT but is initialized by the MacOS proper. You certainly tried all the right things.


    The one thing I can think of that you might not have tried is booting without any peripherals at ALL plugged in, including keyboard and mouse. That is, just the screen and power supply.

    If that doesn't work, then it's got to be something internal, but you'd kind of think bad RAM or a bad motherboard component (I/O controller or something) would have been caught by AHT. Maybe try unplugging the internal Airport card and see if that makes any difference? And/or removing a stick of RAM/swapping with a known-good stick. That seems unlikely, but can't hurt to try.
     
  4. nucircle thread starter macrumors newbie

    Joined:
    Oct 18, 2009
    #4
    Thank you for your replies. Someone suggested it could be the CPU. I ran the AHT for two hours in extended mode today, hoping the heat might cause it to fail. Nothing! Could it still be the CPU, despite the test results? If it is that, I wonder if this Mini isn't just good for replacement parts, now.

    I've tried with no peripherals, just power. No luck. I've also tried a different set of RAM that I know works in another identical Mini. No luck either.

    Thanks again.
     
  5. Dont Hurt Me macrumors 603

    Dont Hurt Me

    Joined:
    Dec 21, 2002
    Location:
    Yahooville S.C.
    #5
    Integrated graphics are fried and you cant do nothing but get a new motherboard. Thats my guess. You could try some different ram just to make sure.
     

Share This Page