Mac mini - No audio device

Discussion in 'Mac mini' started by wooden, Nov 9, 2012.

  1. wooden macrumors newbie

    Joined:
    Nov 9, 2012
    #1
    I'm having a problem with audio my mac mini. It's saying there is no audio device.

    The system is an older model intel mac mini running mountain lion.

    In System prefs/sound, it says 'no output devices found' and the same for input.
    Utilities/audio devices says 'no devices found on the system'
    In about this mac, devices show nothing. There is something saying 'intel high definition audio' but in the pane below it just says 'Audio ID: 0' [not really sure what that means]
    Obviously therefore, no audio apps will output any audio and the volume control on the menu bar is greyed out. When I start the computer I hear no chime.

    Can anyone suggest anything?

    I've tried all the usual stuff such as reboot, repair permissions, plugging a jack in and out and they didn't work. I tried deleting the com.apple.bezelservices.plist which didn't work.
    I have a little usb audio hub which does work for the moment, however I've just bought a nice D/A converter which works straight off the optical out so I want to use that.

    I tried reinstalling OSX. As I had the Mountain lion image in my app store purchases I ran that. It did say it was installing OSX but my system looks the same so I'm wondering if it did enough.

    Is it worth zero-ing out the disk and doing a fresh install off a drive?
     
  2. RTBecard macrumors newbie

    Joined:
    Oct 30, 2013
    #3
    Try reseating the ribbon connecting your audio jack

    Had the exact same problem, just solved it.

    I opened up my mini and re-seated the orange-ish ribbon that connects the audio jacks. It was only SLIGHTLY out of place. It was barely enough to notice visually, but enough to mess with my audio device detection.

    I must have accidentally loosened it when I changed my RAM... however, the strange thing about it was that my audio was sometimes detected and sometimes not... it would work for 2 days fine, then be disabled all of a sudden... Sometimes a restart would fix it, so i did not suspect any hardware problem... finally it got to the point that it was no longer being detected at all. Opened it up, reseated the ribbon that connected the audio port... all problems have been solved since then! :)

    Mac Mini 2.00GHz, core 2 duo, Mountain Lion
     
  3. mattski2 macrumors newbie

    Joined:
    Dec 16, 2013
    #4
    Thank you thank you thank you. That worked for me. Opened the mini with the putty knife and there was the orangey ribbon you're talking about. I removed it at both ends, waggled it a bit (can't be good for it always having that same 90-degree bend in it), replaced it firmly onto the two places it goes. Snapped the mini back together, powered it up, and there was the missing startup bong! Now sound works again.

    If this is really the solution, it seems like a design flaw. It is very easy for that ribbon to get loose at one end or the other. Once that happens you have no sound at all.
     
  4. SirGuyGrand macrumors newbie

    SirGuyGrand

    Joined:
    Sep 21, 2016
    Location:
    Harrogate, North Yorkshire
    #5
    Just discovered this thread. Exceedingly glad I did. Problem solved 30 seconds after opening the case. Thank you.
     
  5. jnels13 macrumors newbie

    Joined:
    Sep 28, 2016
    #6
    Ditto. It's the thread that keeps on giving. Would have been nice if the guy shipping the computer actually including some padding in the box (just the mac mini, cables, and a piece of plastic wrap).
     

Share This Page