mac mini no sound through hdmi to tv

Discussion in 'Mac mini' started by Phillipsg81, Aug 23, 2015.

  1. Phillipsg81 macrumors newbie

    Aug 23, 2015
    I just bought a mac mini and everything works great except the sound. It is connected to my tv via an apple HDMI cable. I have went to the sound output pane and selected the tv as an option. When i do this the volume control display goes clear and there is no sound. and in the audio output pane it says this device has no output controls. The sound works fine through my Apple TV thats also connected to the same tv. Any ideas?
  2. Gav2k macrumors G3


    Jul 24, 2009
    You may need to select the sound output which is in the system pref pane.

    Also check the back of the tv some models have a hdmi port that is for display purposes.
  3. Santabean2000 macrumors 68000


    Nov 20, 2007
    Oddly, I've just encountered the same thing, except my mini is the 2011 version. Just meant that I had to control the volume with the tv remote, which is some respects is not so bad.

    As to why it does this...? Not sure, sorry. I read somewhere that it started after Lion, but I can't confirm that.

    On a side note, (not trying to hijack your thread here...), but the most annoying thing that I have had to deal with is the stupid HDCP rubbish that prevents me playing legitimately bought iTunes movies onto my TV via the mini. I don't understand why the movie industry continues to treat us like criminals. I can buy movies on my computer but can't push them to a big screen..? Do they think that I'll buy the DVD too? Do they think I actually still own a DVD player? Is this 1990?

    Tell me, what is this HDCP crap actually trying to achieve, except pushing otherwise honest people to look for 'alternatives'...
  4. fa8362 macrumors 65816

    Jul 7, 2008
    Use the TV remote to change volume. HDMI has fixed line level output.
  5. Celerondon macrumors 6502a


    Oct 17, 2013
    Southern Cal
  6. iPhil macrumors 68040


    I use my tv remote to control the system volume > System Preferences>Sound>Effects tab - play sound either internal or external speakers ( I choose external so that means my TV speakers) now output tab >TV HDMI Volume is maxed but grayed out... Either HDMI source that i'm on that'll use tv remote for volume

Share This Page