Mac mini not booting up - tried everything!!

Discussion in 'Mac mini' started by brokemacmini, Mar 21, 2009.

  1. brokemacmini macrumors newbie

    Joined:
    Mar 21, 2009
    #1
    Hiya, I'm new to all of this and not particularly clued up when it comes to computer problems but I'm trying to ave myself an expensive trip to the repair shop so any help's appreciated...

    Recently while browsing the internet my computer (Mac Mini) stalled so I held down the power button to turn it off then back on again. However, since doing this it has never reloaded properly, I only get to the grey apple logo screen and the gear just keeps spinning. I've tried starting up in safe mode to no avail, resetting the PRAM to no avail, and when I tried to use the osx install disc it couldn't repair the disk because there was in invalid sibling something or rather (if my memory serves me right). I've also tried rebooting using disk warrior but it comes up with an error message saying i need to restart my computer (in about 5 languages) when I boot up holding down 'c'.

    My latest effort was trying to use fsck to repair the disc amd this is the message i'm getting back, word for word:

    **/dev/rdisk0s3
    **Root file system
    **Checking HFS Plus Volume
    **Checking Extents overflow file
    **Checking Catalog file
    disk0s3: I/0 Error
    disk0s3: I/0 Error
    disk0s3: I/0 Error
    disk0s3: I/0 Error
    disk0s3: I/0 Error
    Invalid sibling link
    (4, 19295)
    **Volume check failed
    localhost:/ root#

    If anyone has any idea how to fix this I'd be glad to hear it as I've got ALL of my OE's travel photos on there and a decent library of music in itunes and garageband.

    Cheers :)
     
  2. googdot macrumors regular

    Joined:
    Jul 12, 2005
    Location:
    Aotearoa...Land Of The Long White Cloud
    #2
    Ouch - that usually means the HD is physically damaged in some way afaik. Have you tried to use the mini on another mac in target mode?
     
  3. bchreng macrumors 65816

    bchreng

    Joined:
    Jul 26, 2005
    #3
    If the HDD were to lose power all of a sudden while it was writing something, could that have caused some sort of physical damage?
     
  4. Tivoli macrumors member

    Joined:
    Apr 25, 2007
    #4
    If disk repair doesn't work I think you will have to visit the repair shop.
     
  5. Aegelward macrumors 6502a

    Joined:
    Jul 31, 2005
    Location:
    UK
    #5
    If your willing you could attempt to replace the drive yourself.

    But it's a tricky process.
     
  6. brokemacmini thread starter macrumors newbie

    Joined:
    Mar 21, 2009
    #6
    Yeah tried running tech tools on it through an imac but it wouldnt even recognise it so no luck there. Does that mean i've lost all my photos and things for good? Thanks for all your help so far. At least now i know its nothing I can fix myself...
     
  7. impreza98 macrumors member

    Joined:
    Sep 3, 2008
    #7
    Hey OP, I'm not sure if this is an issue with the hardware, but here what you can do to isolate whether or not it is.

    Like the other posters have said, see if you can boot to target disk mode. If you can you should back up your data to another drive.

    Whether or not that works you should boot to the Apple Hardware Test from the install disk and see if the computer checks out fine.

    If it does turn out fine then the only way to get your computer back up and running would be to perform an Erase and Install.
     
  8. googdot macrumors regular

    Joined:
    Jul 12, 2005
    Location:
    Aotearoa...Land Of The Long White Cloud
    #8
    If you can't get the disk to mount at all, even in firewire target mode - that's definitely not a good sign.

    Have a look here (or the osx hints post it refers to) as this may shed some light: http://mahalkita.nanogeex.com/2007/09/28/how-to-fix-the-invalid-sibling-link-error/

    Otherwise, I'd resort to ddrescue or something similar to grab the data if you can.
     
  9. poormacmini macrumors newbie

    Joined:
    Mar 23, 2009
    #9
    Happend to me too!

    I tried connecting a firewire cable to another Mac (Macbook) and holding down t while starting up... it worked for me! :) Sadly i fear that my mini is dead forever:( Have also tried everything...

    Cheers
     
  10. SupaTro0pa macrumors newbie

    Joined:
    Apr 2, 2009
    #10
    Fix

    I had a similar problem on my macbook pro. I called apple and they couldn't find anything in the database.

    At the command prompt window (Hold Command key and S key upon startup) Type in fsck_hfs -r /dev/disk0s2 and press Enter. The computer will run about a 10 min scan and attempt to fix the problem. It worked for me, as the other option was a complete wipe of my system.
     

Share This Page