Mac Mini Not Outputting to Display

Discussion in 'Mac mini' started by neojustneo, Oct 11, 2012.

  1. neojustneo macrumors newbie

    Joined:
    Oct 11, 2012
    #1
    OK, so I've got a problem. I have a 2011 Mac Mini that I bought when they were first released. About a week ago, I decided to give my Mini a little boost and I ordered SSD along with an OWC take down kit.

    After I put the SSD in I fired it up but my monitor remained blank. I tried a couple other monitors and DVI/HDMI cords, but still nothing. On top of that, none of the USB ports are outputting any power. The led light in the front is on, and I can see and hear the fan, (not sure about the hard drive) but otherwise nothing else is working.

    Anyone have any idea what the problem might be. I really hope the logic board didn't fry. :(

    -Phillip
     
  2. MJL macrumors 6502a

    Joined:
    Jun 25, 2011
    #2
    I suppose that you unplugged the Mac mini from the mains when you did this and ensured that everything is plugged in properly (I suppose that some of the connectors can be plugged in wrongly with force).

    Barring any installation errors there the only things I can think off is that you need to reset the nvram and pram. If that does not help try putting the old HDD back in. (I've had it with a laptop that it did not want to recognize the SSD - however once formatted properly it worked.)

    If you still have no joy with the old HDD in then you'll need to go to Apple's genius bar and hopefully you will not have left traces of you being in there.....

    If it works with the HDD internally then you can try formatting the SSD in an external enclosure and cloning it before putting it back in.
     
  3. neojustneo thread starter macrumors newbie

    Joined:
    Oct 11, 2012
    #3
    Yeah, I've reset the NVRAM and PRAM. Nothing. :'( I actually have both my HDD and SSD installed in my Mini, but would a unformatted drive really cause it to not startup or output any power to the logic board?
     

Share This Page