Mac Mini only goes to 1920x1080 after update 10.5.7

Discussion in 'Mac mini' started by Bravecat, May 13, 2009.

  1. Bravecat macrumors newbie

    Feb 2, 2007
    Anyone else experiencing the same issue? after updating to 10.5.7 i got a grey band across the bottom of my screen after restart. I logged in and went to system preferences, but the highest resolution i can now choose is 1920x1080.

    My screen is a HP w2448hc, its capable of 1920x1280, worked at this res before update.

    Anyone suggest a fix? or did they restrict the mac mini in the update?

    Many thanks in advance.
  2. 300D macrumors 65816


    May 2, 2009
    Try connecting a different screen then reinstalling yours or holding Command+Option+P+R after rebooting until you hear a second chime.
  3. opeter macrumors 65816


    Aug 5, 2007
    Slovenia, EU
    Are you shure about the 1920x1280 resolution?

    Most 24" LCDs have 1920x1200 resolution.
  4. Bravecat thread starter macrumors newbie

    Feb 2, 2007
    Thanks for the replies... In response to lst post. the resolution is 1920x1200 (my bad)...
  5. jmpage2 macrumors 68040


    Sep 14, 2007
    Try resetting the PRAM as recommended with the CTRL + OPTION + P + R at boot time.
  6. googdot macrumors regular

    Jul 12, 2005
    Aotearoa...Land Of The Long White Cloud
    Heaps of people with the same problem over on Apple discussions.

    Seems to have something to do with the HDMI connection, so maybe try straight DVI?
  7. bed macrumors member

    May 26, 2008
  8. mooblie macrumors 6502


    Apr 23, 2009
    The Highlands, Scotland
    Mini 1.83GHz Core 2 Duo with GMA950, all OK for me with 10.5.7 and 1920x1200 - using VGA output (on DVI socket with adapter) feeding a Dell 2407.

    (Before you ask: I'm not using DVI between the Mini and Dell 2407, as that input is fed from a Matrox MXO on my MacPro as a HD video editing monitor.)

    Seems to be a problem for those using DVI/HDMI out of the Mini?
  9. Glenny2lappies macrumors 6502

    Sep 29, 2006
    Brighton, UK
    No. Seems to be a problem with *all* Macs running with a non-Apple external monitor. Says he who's running a MBP with a Hyundai W240 DVI monitor where the only resolutions available go up to 1080 height, not 1200.

    Fail Apple. It doesn't "just work". I wish I hadn't installed the 10.5.7 update now (was running fine with 10.5.6).
  10. mooblie macrumors 6502


    Apr 23, 2009
    The Highlands, Scotland
    No. I haven't got a problem with either my MacPro or my MacMini - both running 10.5.7 on non-Apple external monitors at 1920x1200.
  11. WorldTravel26 macrumors newbie


    May 6, 2009
    I have the exact same monitor as you, and I had the exact same problem after updating to 10.5.7

    I just switched from my HDMI cable to a straight DVI cable, and it solved the problem. Sucks though if you have to go out and buy an extra cable (and possibly adapter) for something that wasn't "broken" until the "update".
  12. germanix macrumors member

    Apr 10, 2009
    Hannover, Germany
    found this on MacFixit:
    Display Resolutions are Incorrect

    Another prominent issue (after installing the 10.5.7 update) seems to be certain display resolutions are disappearing, resulting in the computer outputting non-native display resolutions to the monitor. In most cases, instead of being able to choose 1920x1200 as the resolution (the native resolution for many widescreen displays), the computer will only output 1920x1080 (the maximum for HDMI connections). This seems to be a conflict in the drivers, since 1920x1080 is the maximum display resolution for HDMI connections.

    There may be several approaches to fixing this problem. The first would be to try a PRAM reset, which can be done by holding the options-command-P-R keys all at once at reboot, and holding them down until the computer resets a few times, then releasing them and allowing the computer to boot normally.

    If a PRAM reset doesn't work, try a workaround suggested by Apple Discussion board user "cizko", which is to install a screen output tweaking program called "SwitchResX" for fine-customization of monitor outputs. The program is a demo, but installing it, setting the screen resolution, and then optionally uninstalling it seems to clear the resolution problem the OS X update.

    A word of note: some people have found that in using SwitchResX, the only way they were able to get things to work was by going to the "Timing Parameters" settings and checking "Use Simplified settings", and then changing the drop-down menu from "GTF" to "CTV-RB".
  13. panzer06 macrumors 68030


    Sep 23, 2006
    10.5.7 installed on my mini and working fine with external Samsung 1920x1200 display.

    I've quite a few of these complaints on the Apple support forums so I don't doubt there's an issue but thankfully it does not apply to me.

  14. Matek macrumors 6502a

    Jun 6, 2007
    Same problem here, except on a MacBook. Surprised this bug wasn't found during testing...
  15. Maoltuile macrumors newbie

    Apr 8, 2009
    Another affected machine, post-update

    I'm having it as well. Mac Pro (2006) with Nvidia 7300 hooked up to an LG 24" via DVI-to-HDMI cable (the screen only accepts VGA otherwise). The native resolution of the screen is 1920x1200, but all I can select now is 1920x1080 or 1600x1200.

    Very, very irritating.
  16. Matek macrumors 6502a

    Jun 6, 2007
    The solution germanix posted works. Install SwitchResX, follow the above instructions ("Use Simplified settings" change the drop-down menu from "GTF" to "CTV-RB"), reboot and the resolution should show up again (you can uninstall the utility afterwards).

Share This Page