Mac Mini Server Won't Sleep

Discussion in 'Mac mini' started by shoebobs, Jul 14, 2010.

  1. shoebobs macrumors regular

    Joined:
    Jul 5, 2008
    #1
    Hi,

    I originally got the new (mid 2010) Mac Mini, but after reading into the features of Snow Leopard Server, I decided to exchange it for the (mid 2010) Mac Mini Server.

    It runs great, I'm really happy with it, but the one issue I have is it won't enter sleep mode on it's own. I've went into all of the System Preferences settings and changed everything to allow it to sleep (SL Server by default does not set it to sleep). However, when the set time is reached, it never enters sleep mode. If I go to the apple icon --> Sleep, it will enter sleep mode fine.

    I have tried resetting the PRAM and SMC, but that did not change anything. I've read one posting on Apple's support forums where someone said they reinstalled the OS and that worked (on a 2009 mini).

    Any other ideas before I have to do a reinstall?
     
  2. shoebobs thread starter macrumors regular

    Joined:
    Jul 5, 2008
    #2
    Ok, looks like I will have to try a reinstall since nobody has any ideas.

    That being said, can I use the optical drive on my MBP for the install (I seem to remember reading you could share the optical drive on macs)? If so, please point me in the right direction.

    Or do I have to put the install disk on an external USB drive?

    Thanks
     
  3. trip1ex macrumors 68000

    Joined:
    Jan 10, 2008
    #3
    CAll Apple. YOu have 90 days free technical phone support.
     
  4. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Calif
  5. shoebobs thread starter macrumors regular

    Joined:
    Jul 5, 2008
    #5
    I understand that, but it's not currently being used as a server. It's at my parents house so they can get to know OS X and decide if they want to get a mac when their current computers are retired. I would like it to sleep when they are not using it, given that is an option in the OS.

    Good point, I'll give them a call next time I'm at my parents house.
     
  6. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #6
    save $300 and exchange your mini server for the standard mini. there's no reason your parents or anyone unfamiliar with macs, let alone mac os x server would need anything more powerful than the base mini with standard config.
     
  7. shoebobs thread starter macrumors regular

    Joined:
    Jul 5, 2008
    #7
    It is just at their house for a brief time period. I am moving in 2 weeks so I am trying to clear out my current place and am storing stuff at their house, such as the mini/monitor/speakers. I figured I would set it up for them as it would be a good opportunity for them to see if they liked OS X.

    Once I move into my new place, I am taking the mini and will be using many of the server functions.
     
  8. shoebobs thread starter macrumors regular

    Joined:
    Jul 5, 2008
    #8
    Just in case anybody else is having the same issue...

    Long story short, it appears the mac mini server is setup to not automatically go to sleep. I turned off every service or anything that may be running in the background, including DNS, and it still would not go to sleep.

    This makes sense that it would not go to sleeep because it is a server, but I was curious if it was an option for the few occasions I don't have file sharing or any other services running.

    What I am still curious about, and forgot to ask the Apple rep, is if sleep is not a feature of mac mini server why is it even an option in system preferences? Wouldn't it just be grayed out or not even be an option in the "Energy Saver" preferences section?

    For anybody else out there that has the Mac Mini Server - can you verify whether yours is able to sleep automatically? I just want to make sure mine is behaving how it should and there isn't anything wrong with the hardware.

    Thanks
     
  9. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Calif
    #9
    take your mini serve to a Genius and let them deal with it.
     
  10. analogkid macrumors regular

    Joined:
    Jun 9, 2003
    Location:
    Savannah
    #10
    Well, the Mini doesn't use much juice when idle, so it's not a huge problem... it burns about the same energy as a night light. You can install from the MBP optical using the utility specifically for that purpose, or from a thumbdrive.
     
  11. shoebobs thread starter macrumors regular

    Joined:
    Jul 5, 2008
    #11
    I called applecare. I'm simply asking if anybody else with the Mac Mini Server is able to have it automatically sleep after a set period of time.
     
  12. DannySmurf macrumors 6502a

    Joined:
    Jul 7, 2005
    #12
    I've noticed the same behaviour, even with Snow Leopard client installed on mine. Does not go to sleep. Not a problem for me. As someone else already said, the power drain of this machine at idle is insignificant. My cable box in standby probably uses more power.
     
  13. shoebobs thread starter macrumors regular

    Joined:
    Jul 5, 2008
    #13
    I put Snow Leopard Client on mine to see if it would go to sleep. I set the sleep timer to one minute, waited 2 minutes and it did not go to sleep. I then went downstairs to watch some TV and when I went to go use the Mini again, it had gone to sleep. So, not sure how long it took or why it wouldn't sleep right away, but eventually it did. If yours is not sleeping even after putting SL client on it, it may be a hardware issue.
     
  14. ciaran00 macrumors 6502

    Joined:
    Mar 11, 2010
    #14
    Same behavior for my mac mini server. I'd like it to sleep during summer months because my apartment gets really hot. I'll call AppleCare tomorrow.

    What is the "Snow Leopard Client". Is it Remote Desktop?
     
  15. CorporateFelon macrumors regular

    CorporateFelon

    Joined:
    Oct 26, 2007
    Location:
    Boston, MA
    #15
    The non Server version of OSX.
     
  16. applemacsmith macrumors newbie

    Joined:
    Mar 22, 2009
    #16
    Try installing ' PleaseSleep ' - it worked for me

    Best

    AMS
     

Share This Page