Mac Mini - Sleep / Darkwake

Discussion in 'Mac mini' started by Jimb0, Mar 18, 2013.

  1. Jimb0 macrumors newbie

    Joined:
    Nov 20, 2012
    #1
    Hi,

    I'm hoping someone can help. I have a late 2012 i7 mac mini and use it remotely from work via teamviewer. I want to be able to set the mini up so that when it's asleep I can send a wake on lan command (magic packet) and it wakes the machine up (and I can then connect teamviewer).

    I use iNet pro on my iphone to send the WOL request. At present, when the mini is asleep and my phone is connected to my same network, when I send the WOL command the light on the front of the mini goes from pulsing to being on continously. However the Mini doesn't wake up. This indicates the mini has received the command but I've read this state is called a Darkwake state and prevents the mini fully waking up. Does anyone know how to switch this off?

    The same thing happens when I send the command from outside my network (over 3G) indicating again the magic packets are being forwarded by my router.

    The obvious solution is to set the mini never to sleep, but I don't want to leave it on continously 24/7 which is what i'm currently doing.

    For info i'm running 10.8.3.

    Any help would be appreciated, many thanks.
     
  2. palebluedot macrumors 6502a

    palebluedot

    Joined:
    Jun 29, 2008
    #2
    Sleep has been really messed up in OS X for awhile. I assume it is the same issue we have with Synergy where the computer is on, the keyboard (via Synergy) is in use because you can hear sound, but OS X does not wake the monitor.
     
  3. jpxdude macrumors member

    Joined:
    Oct 2, 2006
    #3
    There is a way to switch off Darkwake by amending a plist file, and setting the flag to 0. I forget how, but a quick search for a mountain lion specific solution should be out there somewhere. It works for me with Teamviewer!
     
  4. Donka macrumors 68020

    Donka

    Joined:
    May 3, 2011
    Location:
    Scotland
    #4
    I've seen this behavior with a couple of iPhone apps for WOL when working remotely.
    I use the following site from work instead and if the mini doesn't wake on the first attempt, going back and sending the wake command a second time pretty much always works:

    http://www.dslreports.com/wakeup
     
  5. Jimb0 thread starter macrumors newbie

    Joined:
    Nov 20, 2012
  6. Donka macrumors 68020

    Donka

    Joined:
    May 3, 2011
    Location:
    Scotland
    #6
    NP. Keep us posted with how you get on.
    I'm assuming you have your router set to forward UDP port 9?
    Do you have a static IP address from your ISP or doyou use a DNA service?
     
  7. Jimb0 thread starter macrumors newbie

    Joined:
    Nov 20, 2012
    #7
    Just as an update if anyone is interested, I edited the .plist file in the system preferences folder and set the parameter darkwake=0 which I think is what jpxdude was talking about. WOL still didn't work but I think it's because my sky router can't deal with forwarding magic packets from outside it's own network.

    However, when the mini is asleep and I open plex on my iphone (from the internet, not my home wifi), it wakes the mini up and I can then connect with team viewer. Seems to be a pretty good work around
     

Share This Page