Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Ropie

macrumors regular
Original poster
Aug 6, 2007
184
0
England
After installing Mavericks my late 2012 Mac Mini power light no longer pulses when the system is put to sleep; instead it just resolutely glows at normal operating brightness, refusing even to have the decency to dim itself! It was definitely pulsing the night before the upgrade as I was staring at it as I went to sleep..

Edit - it's not the end of the world, as otherwise 10.9 seems very very good.
 

Gary King

macrumors 6502
Jun 14, 2004
495
1
Yep I have noticed this too. Perhaps it's part of the "Power Nap" feature in Mavericks which allows it to perform activities even when asleep? I think this only works on SSDs and Fusion drives, so I assume you have one of these in your Mac Mini? I have an SSD so this is probably the reason for me.
 

atrevers

macrumors regular
May 24, 2007
128
27
UK
I've got a 2011 mini that doesn't do Power Nap (even though I've added a 3rd party SSD) - sleeps as previously, with pulsating power light.
 

ivnj

macrumors 65816
Dec 8, 2006
1,363
82
I've got a 2011 mini that doesn't do Power Nap (even though I've added a 3rd party SSD) - sleeps as previously, with pulsating power light.

Mine too. I just don't have any ssd's. It is all stock. Except I have 8gb ram now instead of the stock 2gb. But the rest is all stock. I just tried and its the same as before and as atrevers said. You hit sleep and then nothing happens. But as soon as the hd finishes spinning down the light goes dim. And then bright. Back and forth.
 

Negritude

macrumors 6502
Jul 14, 2011
297
199
After installing Mavericks my late 2012 Mac Mini power light no longer pulses when the system is put to sleep; instead it just resolutely glows at normal operating brightness, refusing even to have the decency to dim itself!

Are you sure the system is actually sleeping? Run this command in terminal:

pmset -g

If you see anything on the "sleep" parameter line that shows processes that are preventing the system from sleeping, let us know.
 

Gary King

macrumors 6502
Jun 14, 2004
495
1
Turns out the reason my Mac Mini wasn't sleeping was because I had "File sharing" enabled in the "Sharing" System Preferences pane. However, in previous versions of OS X, my Mac would sleep fine even with this enabled. But starting with Mavericks, this prevents my Mac from sleeping. So I have to disable it every night before sleeping my Mac now.
 

Ropie

macrumors regular
Original poster
Aug 6, 2007
184
0
England
Turns out the reason my Mac Mini wasn't sleeping was because I had "File sharing" enabled in the "Sharing" System Preferences pane.
This was not enabled on mine.

Are you sure the system is actually sleeping? Run this command in terminal:

pmset -g
I tried this and got a 0. However, I've noticed that the problem seems to have rectified itself! It now goes to sleep and the light pulses straightaway, whereas before it would not even start pulsing hours after being put to sleep. Must have been some process that has now finished...
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.