Mac Mini slow going to sleep

Discussion in 'Mac mini' started by geraldfleck, Oct 9, 2013.

  1. geraldfleck macrumors newbie

    Joined:
    Oct 26, 2012
    #1
    Hi all,

    My late-2012 Mac Mini has been wonderful so far. Just a few days ago, though, a problem has presented itself:

    When I select "Sleep" from the Apple menu, it takes between 10 and 15 seconds for the computer to actually go to sleep. In the meantime, it simply looks and functions as though I hadn't clicked anything.

    One suggestion I found was to make sure there were no print jobs pending -- there aren't. What else can I check? I have plenty of memory (16 GB; usually 10 or 11 GB free according to Activity Monitor). And other than this problem, everything is snappy and perfect. So I can't figure out what is causing the delay.

    Thanks for any suggestions. I'll be happy to post log information, etc.
     
  2. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #2
    My mid 2011 mini started doing that after I did the 10.8.5 supplemental update. I'm sure others are having the same issue. Apple, PLEASE FIX THIS!!
     
  3. geraldfleck thread starter macrumors newbie

    Joined:
    Oct 26, 2012
    #3
    Ah, now that you mention it, the problem may have started just after I did that update. Can't say for sure, though.
     
  4. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #4
    Mine definitely started doing it after the update. It used to go to sleep just about instantly before. Now takes 20 to 25 seconds. Very annoying!
     
  5. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #5
    The update may have switched sleep mode to 'Safe Sleep'

    to check which mode is active, open a Terminal window and type in

    pmset -g | grep hibernatemode

    ==============================
    0= old style sleep (fast)
    3= new (save to disk style, takes more time)
     
  6. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #6
    tried that. It says it's set to 0. I'll try sleeping my mini again and see if there's any change

    Edit: still slow..
     
  7. geraldfleck thread starter macrumors newbie

    Joined:
    Oct 26, 2012
  8. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #8
    I thought you said it was slow. That's normal. Plus, the more memory you have the longer it takes.
     
  9. geraldfleck thread starter macrumors newbie

    Joined:
    Oct 26, 2012
    #9
    It's not normal. Normal is selecting "Sleep" from the Apple menu and having the computer go instantly to sleep. It worked this way for the first 11 months. Now something has changed.
     
  10. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #10
    That has never been normal. There are housekeeping tasks the machine does before it goes to sleep. If you put the computer to sleep, I have to assume you're done working on it. Just walk away and let it do its thing.
     
  11. geraldfleck thread starter macrumors newbie

    Joined:
    Oct 26, 2012
    #11
    You're absolutely right. But that doesn't explain why an instantaneous sleep WAS normal for me and now no longer is. Something changed, and I'm curious what it was (even if I do walk away and let it do its thing). Thanks for your help.
     
  12. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #12
    I've had my mac mini since August of 2012 and mine always went to sleep right away, or at least sleep my monitor right away. Now it takes about 25 seconds for my monitor to sleep. For 25 seconds, I see my desktop after I do the keyboard sleep command. This hasn't been the norm for all of my past Macs. Why the sudden change?
     
  13. blanka macrumors 68000

    Joined:
    Jul 30, 2012
    #13
    Why put it to sleep? It is basically functioning the same when sleeping as a shut down Mini. Shut down here takes 2 seconds, booting around 10, so what's the problem? Why is there a sleep function Überhaupt?
     
  14. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #14
    Shutdown takes 2 seconds? Booting takes 10 seconds?? LOL! What planet are you living on?
     
  15. geraldfleck thread starter macrumors newbie

    Joined:
    Oct 26, 2012
    #15
    True, or one could just leave it running with the monitor(s) turned off. But there is even a delay in shutting down...same as putting it to sleep. And something has changed recently to cause this delay.
     
  16. geraldfleck thread starter macrumors newbie

    Joined:
    Oct 26, 2012
    #16
    Looks like Google Chrome is the culprit. If I close out of Chrome before selecting Sleep, I get instantaneous sleep. If Chrome is open, I get a delay.

    There is already a long discussion about it here:

    https://code.google.com/p/chromium/issues/detail?id=132336

    And it seems to have something to do with the latest Chrome update.

    But I don't see a solution yet...(other than closing Chrome before sleep).
     
  17. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #17
    wow!!! you are right! I close Chrome and it does sleep right away. Strange that I noticed the slow sleep issues right after the latest OSX update. Somehow Chrome must be interacting badly with 10.8.5. in some way... Thanks for figuring this one out!
     
  18. blanka macrumors 68000

    Joined:
    Jul 30, 2012
    #18
    Just with my MacMini 2011 with Samsung 830 and Snow Lopy. Maybe Mountain Kitty is a lot slower, I don't now. And I can even type the password in those 10 seconds.
     
  19. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #19
    Wow man, very impressive. I haven't timed mine, but it takes about a minute starting or shutting down with Mountain Lion. I have a base mid 2011 with 8 gigs of ram, and the stock 5400 rpm HD. Maybe I'll install an SSD if that will make that much of a difference.

    P.S. I'm sorry if I came off like a dickhead.
     
  20. geraldfleck thread starter macrumors newbie

    Joined:
    Oct 26, 2012
    #20
    Mine is also fast with the Samsung 830 (plus stock HDD) and 16GB ram. Boots in less than 20 seconds. Love the Mac Mini!

    Now let's hope Google releases a fix for Chrome!
     
  21. xArtx macrumors 6502a

    Joined:
    Mar 30, 2012
    #21
    No it's not, because I just put my mini to sleep in one second,
    woke it up in two seconds, and this web page is still here!

    and it didn't have to scratch around a HDD booting the OS again.
     
  22. blanka macrumors 68000

    Joined:
    Jul 30, 2012
    #22
    In theory leaving everything open where it is sounds tempting, but especially browsers become a mess. They really benefit of rebooting. And if I am away for more than an hour, I don't want one key access to everything I'm working on. But it is a thing of preference. I use cookie-self-destruct, wiping cookies of every browser tab I close, so I don't expect MR to stay logged in.
     
  23. montom macrumors member

    Joined:
    Jun 25, 2005
    #23
    Had same issue with a 2010 mini, and found it was an HP Device Monitor problem. Put your mac to sleep, wake it, and check your Console -> All Messages for any timeouts.
     
  24. toddzrx macrumors 6502a

    toddzrx

    Joined:
    Nov 20, 2012
    #24
    I know this isn't the solution to your problem (since it appears to be a Chrome issue), but just so you know: I had similar symptoms on my iMac a couple of months ago, sometimes taking almost a minute to go to sleep (and that's with an internal SSD). Turns out the problem was with an external HD that was going bad, and I assume the same thing could happen if the HD were internal.

    Just something to consider.
     
  25. geraldfleck thread starter macrumors newbie

    Joined:
    Oct 26, 2012
    #25
    Thanks for the tip. I checked Console, and all of my timeouts are "Google Chrome He". So I think it is a Chrome issue.
     

Share This Page